summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-18 16:19:02 +0000
committerSam James <sam@gentoo.org>2023-11-18 16:19:22 +0000
commit756733286e2ed54ba2318b8172622e7635c69626 (patch)
tree105ea449d98c39efa08984d7cf4855a0285d223b /app-containers
parentapp-containers/crun: use configure cache for subconfigure (diff)
downloadgentoo-756733286e2ed54ba2318b8172622e7635c69626.tar.gz
gentoo-756733286e2ed54ba2318b8172622e7635c69626.tar.bz2
gentoo-756733286e2ed54ba2318b8172622e7635c69626.zip
app-containers/crun: follow skel.ebuild order for phase definitions
Define in order of execution. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/crun/crun-1.11.2.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/app-containers/crun/crun-1.11.2.ebuild b/app-containers/crun/crun-1.11.2.ebuild
index 12801625cad9..029066f58826 100644
--- a/app-containers/crun/crun-1.11.2.ebuild
+++ b/app-containers/crun/crun-1.11.2.ebuild
@@ -58,6 +58,14 @@ src_compile() {
emake crun
}
+# the crun test suite is comprehensive to the extent that tests will fail
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
+# due to this we disable most of the core test suite by unsetting PYTHON_TESTS
+src_test() {
+ emake check PYTHON_TESTS=
+}
+
src_install() {
emake "DESTDIR=${D}" install-exec
doman crun.1
@@ -66,11 +74,3 @@ src_install() {
einfo "Cleaning up .la files"
find "${ED}" -name '*.la' -delete || die
}
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-# due to this we disable most of the core test suite by unsetting PYTHON_TESTS
-src_test() {
- emake check PYTHON_TESTS=
-}