summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-09 13:55:22 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-09 13:57:47 +0200
commit4b833df7426f2c94fcd079b53cdaa2ace4f338c4 (patch)
tree549f06f43340ea6a597721665f836c869a07f86b /app-benchmarks/stress-ng/files
parentapp-text/cb2bib: Drop 1.9.9 (diff)
downloadgentoo-4b833df7426f2c94fcd079b53cdaa2ace4f338c4.tar.gz
gentoo-4b833df7426f2c94fcd079b53cdaa2ace4f338c4.tar.bz2
gentoo-4b833df7426f2c94fcd079b53cdaa2ace4f338c4.zip
app-benchmarks/stress-ng: bump to version 0.11.17
Closes: https://bugs.gentoo.org/728728 Closes: https://github.com/gentoo/gentoo/pull/16321 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks/stress-ng/files')
-rw-r--r--app-benchmarks/stress-ng/files/stress-ng-0.11.17-makefile.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-benchmarks/stress-ng/files/stress-ng-0.11.17-makefile.patch b/app-benchmarks/stress-ng/files/stress-ng-0.11.17-makefile.patch
new file mode 100644
index 000000000000..d3c5e93b0074
--- /dev/null
+++ b/app-benchmarks/stress-ng/files/stress-ng-0.11.17-makefile.patch
@@ -0,0 +1,61 @@
+--- stress-ng-0.11.17.orig/Makefile 2020-07-27 13:38:23.000000000 +0200
++++ stress-ng-0.11.17/Makefile 2020-08-09 13:43:30.919796477 +0200
+@@ -21,7 +21,7 @@
+ # Codename "synthetic system strainer"
+ #
+
+-CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2 -std=gnu99
++CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -std=gnu99
+
+ #
+ # Pedantic flags
+@@ -358,12 +358,10 @@
+ .o: stress-ng.h Makefile
+
+ .c.o:
+- @echo "CC $<"
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-ng: $(OBJS)
+- @echo "LD $@"
+- @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -o $@
+ @sync
+
+ makeconfig:
+@@ -384,7 +382,7 @@
+ sed '$$ s/.$$//' >> apparmor-data.c
+ @echo "};" >> apparmor-data.c
+ @echo "const size_t g_apparmor_data_len = sizeof(g_apparmor_data);" >> apparmor-data.c
+- @echo "CC $<"
++ echo "CC $<"
+ @$(CC) -c apparmor-data.c -o apparmor-data.o
+ @rm -rf apparmor-data.c apparmor-data.bin
+
+@@ -401,12 +399,12 @@
+ @$(CC) $(CFLAGS) -E core-perf-event.c | grep "PERF_COUNT" | \
+ sed 's/,/ /' | sed s/'^ *//' | \
+ awk {'print "#define _SNG_" $$1 " (1)"'} > core-perf-event.h
+- @echo CC $<
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ echo CC $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-vecmath.o: stress-vecmath.c
+- @echo CC $<
+- @$(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
++ echo CC $<
++ $(CC) $(CFLAGS) -fno-builtin -c -o $@ $<
+ @touch stress-ng.c
+
+ $(OBJS): stress-ng.h Makefile
+@@ -459,7 +457,7 @@
+ mkdir -p ${DESTDIR}${BINDIR}
+ cp stress-ng ${DESTDIR}${BINDIR}
+ mkdir -p ${DESTDIR}${MANDIR}
+- cp stress-ng.1.gz ${DESTDIR}${MANDIR}
++ cp stress-ng.1 ${DESTDIR}${MANDIR}
+ mkdir -p ${DESTDIR}${JOBDIR}
+ cp -rp example-jobs/*.job ${DESTDIR}${JOBDIR}
+ mkdir -p ${DESTDIR}${BASHDIR}