summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/cdbackup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/cdbackup')
-rw-r--r--app-backup/cdbackup/Manifest2
-rw-r--r--app-backup/cdbackup/cdbackup-0.7.0.ebuild34
-rw-r--r--app-backup/cdbackup/cdbackup-0.7.1.ebuild34
-rw-r--r--app-backup/cdbackup/metadata.xml5
4 files changed, 75 insertions, 0 deletions
diff --git a/app-backup/cdbackup/Manifest b/app-backup/cdbackup/Manifest
new file mode 100644
index 000000000000..a325475cef67
--- /dev/null
+++ b/app-backup/cdbackup/Manifest
@@ -0,0 +1,2 @@
+DIST cdbackup-0.7.0.tar.gz 22004 SHA256 d960bd67cc06e972c099aca8139b3b2aa35e54d32fda1a6d58f354fb82892a5c SHA512 c64f5c9c4541384a6281ded526fe6b4e47a7912f4b6356474d89a715e8ba42eae7208a4d22f9ff1a7c1b2ce4e91cf0936b14cefba33652563a1c8236959d5ba8 WHIRLPOOL 457a1ca3efa801104b8248196b58c3873b311d3a0ac4e166238dd47017cbc18d01f000536f6c57f65934175bd4083c3fc3ad12f99232fe5a9e42a71c4e92530b
+DIST cdbackup-0.7.1.tar.gz 22710 SHA256 b9d94acd0065c243b2a9d5a47af768ddae003f81a181a61155065a11bb59449c SHA512 9246295090a7d52ff452d5d24a429f2a21179e4d8deb4e9d6f2ab607dd04230830e3524f25d0180e36f62c7f7f87dec11cb3c1c01cde51708d467d6e0a4afc8f WHIRLPOOL 4267f0b48c6835efc8ac4ee2851febdc149985fc466321c25a840a6539348941baf6c43c4e4425a4eb004c5cdf312e10a560a0e3a8ddceb4fa8442c485ec606e
diff --git a/app-backup/cdbackup/cdbackup-0.7.0.ebuild b/app-backup/cdbackup/cdbackup-0.7.0.ebuild
new file mode 100644
index 000000000000..542f40f1a389
--- /dev/null
+++ b/app-backup/cdbackup/cdbackup-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Allows streaming backup utilities to dump/restore from CD-R(W)s or DVD(+/-RW)s"
+HOMEPAGE="http://www.muempf.de/index.html"
+SRC_URI="http://www.muempf.de/down/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-cdr/cdrtools-1.11.28"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e '/cd\(backup\|restore\)/,+1 s:CFLAGS:LDFLAGS:' \
+ "${S}"/Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ dobin cdbackup cdrestore || die "dobin failed"
+ doman cdbackup.1 cdrestore.1 || die "doman failed"
+ dodoc CHANGES CREDITS README || die "dodoc failed"
+}
diff --git a/app-backup/cdbackup/cdbackup-0.7.1.ebuild b/app-backup/cdbackup/cdbackup-0.7.1.ebuild
new file mode 100644
index 000000000000..a01f7997009b
--- /dev/null
+++ b/app-backup/cdbackup/cdbackup-0.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Allows streaming backup utilities to dump/restore from CD-R(W)s or DVD(+/-RW)s"
+HOMEPAGE="http://www.muempf.de/index.html"
+SRC_URI="http://www.muempf.de/down/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-cdr/cdrtools-1.11.28"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e '/cd\(backup\|restore\)/,+1 s:CFLAGS:LDFLAGS:' \
+ "${S}"/Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ dobin cdbackup cdrestore || die "dobin failed"
+ doman cdbackup.1 cdrestore.1 || die "doman failed"
+ dodoc CHANGES CREDITS README || die "dodoc failed"
+}
diff --git a/app-backup/cdbackup/metadata.xml b/app-backup/cdbackup/metadata.xml
new file mode 100644
index 000000000000..e94d7236906d
--- /dev/null
+++ b/app-backup/cdbackup/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>app-backup</herd>
+</pkgmetadata>