summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-05 06:10:40 +0100
committerSam James <sam@gentoo.org>2024-04-05 06:10:40 +0100
commit6823bf88c865d03bb8eaf10eabbb8f9a10dd5eed (patch)
tree9bd5085270bcdf3a1cd9c9997d9b6155dd39a488 /app-arch
parentsci-mathematics/slepc: add 3.20.1 (diff)
downloadgentoo-6823bf88c865d03bb8eaf10eabbb8f9a10dd5eed.tar.gz
gentoo-6823bf88c865d03bb8eaf10eabbb8f9a10dd5eed.tar.bz2
gentoo-6823bf88c865d03bb8eaf10eabbb8f9a10dd5eed.zip
app-arch/gxz: new package, add 0.5.12
An alt xz implementation written in pure Go (with no deps too!). Not abandoning the king xz-utils, but need this to do some comparison work. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gxz/Manifest1
-rw-r--r--app-arch/gxz/gxz-0.5.12.ebuild23
-rw-r--r--app-arch/gxz/metadata.xml11
3 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/gxz/Manifest b/app-arch/gxz/Manifest
new file mode 100644
index 000000000000..3fac29d8d583
--- /dev/null
+++ b/app-arch/gxz/Manifest
@@ -0,0 +1 @@
+DIST gxz-0.5.12.tar.gz 4176087 BLAKE2B 0bf4795ec1d008ef956d42d9d78b3f3f65bb9555436c64869a82aa6c058ac3aa5e8912a8e451cdafccaeaf4d9bb30404e2cd60a00f620baf01e6b6d892d59a3f SHA512 13928dfbd8514eb7c778a84405ba2342159da8f59783f82b5774643190b12d5fc1aed927b67946d5ef246d5cc61b3be23eaa08695c61aea70229617b1ce757ff
diff --git a/app-arch/gxz/gxz-0.5.12.ebuild b/app-arch/gxz/gxz-0.5.12.ebuild
new file mode 100644
index 000000000000..d8b591f20950
--- /dev/null
+++ b/app-arch/gxz/gxz-0.5.12.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pure golang package for reading and writing xz-compressed files"
+HOMEPAGE="https://github.com/ulikunitz/xz"
+SRC_URI="https://github.com/ulikunitz/xz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/xz-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build ./cmd/gxz
+}
+
+src_install() {
+ dobin gxz
+}
diff --git a/app-arch/gxz/metadata.xml b/app-arch/gxz/metadata.xml
new file mode 100644
index 000000000000..dbf55dc84298
--- /dev/null
+++ b/app-arch/gxz/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ulikunitz/xz</remote-id>
+ </upstream>
+</pkgmetadata>