summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-24 20:34:46 +0000
committerSam James <sam@gentoo.org>2024-12-24 20:34:46 +0000
commit6098341be488fbe7f73b0de44b6c2fddef166741 (patch)
tree2be8abda5504da7e2a57fef3b6c8302c45d80ed3 /app-arch
parentapp-arch/dpkg: add 1.22.0 (diff)
downloadgentoo-6098341be488fbe7f73b0de44b6c2fddef166741.tar.gz
gentoo-6098341be488fbe7f73b0de44b6c2fddef166741.tar.bz2
gentoo-6098341be488fbe7f73b0de44b6c2fddef166741.zip
app-arch/dpkg: add 1.22.11
Bug: https://bugs.gentoo.org/916229 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/Manifest1
-rw-r--r--app-arch/dpkg/dpkg-1.22.11.ebuild113
-rw-r--r--app-arch/dpkg/files/dpkg-1.22.11-sq-tests.patch63
3 files changed, 177 insertions, 0 deletions
diff --git a/app-arch/dpkg/Manifest b/app-arch/dpkg/Manifest
index c5724e181ad4..553bcc73c327 100644
--- a/app-arch/dpkg/Manifest
+++ b/app-arch/dpkg/Manifest
@@ -4,3 +4,4 @@ DIST dpkg_1.21.1.tar.xz 4986936 BLAKE2B f5b0f9fe7ac5fe7ba47191a9e467356e74841884
DIST dpkg_1.21.15.tar.xz 5350148 BLAKE2B f26611db365266ef9f43484c20d3150889238b34b156cac26f0ae8ae9572e7e4a9839e08a0073a25c886cd2891fc6d84afc97262ae6992267b47fa6e86c03a33 SHA512 eb31db63dd454048c3b7539b539720ed71239303ca679df92b934e971914d63dd771da09149054048e24dde1f5627ee24d43dbd8782ca1dc28c4a2bd3ed8f26a
DIST dpkg_1.21.19.tar.xz 5360888 BLAKE2B 1a48781c136b47b74fb947a14ddfde8e3d8441f728215257d4c7b9618b5af79225be6312a31166181acbf5c05a408332d9faae2c7e16f7757a442e8d4e6a0afd SHA512 660297e678326350b70e6a49635642347413046ebab05bdc076505511e844f7de0261a12c6c07e586d661f6536b987e3c32c21b8cc95d7135538a5c2f6d1514e
DIST dpkg_1.22.0.tar.xz 5519320 BLAKE2B 0f25fae75027330c85b2c897358cdfed72eca75650ddb841f1f56b4357905ad7a9a5e83b477499a74557587bb24a823d47dca93242250d23ee37a5969cb02de3 SHA512 7edee5920ee46883eb29bee80307e0a9dc394df84cd642fffef72927b578a6cde9a9565ab8c391528ca353a58345a144fa133a4d3a128a2a712640a2afda61e9
+DIST dpkg_1.22.11.tar.xz 5697040 BLAKE2B 7bd7f90a8ae98ac7401bc2b8e7b0d2cc002a57bfdc5521d9049a995130011a3042ac6d24d6ecd5410e1db2c2e936eae5085a2af5fb11b0a73fd66bae33b33956 SHA512 8caeb52625e34109bbc3abf1b62792053f989e560b541ec9de85f3fe563f8bcb06db102dbae83058aba16e6f4729260e15e1c7a470762a261bec5460358c0fe9
diff --git a/app-arch/dpkg/dpkg-1.22.11.ebuild b/app-arch/dpkg/dpkg-1.22.11.ebuild
new file mode 100644
index 000000000000..a2a3db70857c
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.22.11.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="https://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bzip2 +lzma nls selinux static-libs test +update-alternatives +zlib +zstd"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-arch/gzip-1.7
+ >=app-arch/tar-1.34-r1
+ app-crypt/libmd
+ >=dev-lang/perl-5.32.1:=
+ sys-libs/ncurses:=[unicode(+)]
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ nls? ( virtual/libintl )
+ selinux? ( sys-libs/libselinux )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ test? (
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+BDEPEND="
+ sys-devel/flex
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+"
+RDEPEND+=" selinux? ( sec-policy/selinux-dpkg )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.22.0-flags.patch
+ "${FILESDIR}"/${PN}-1.22.11-sq-tests.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's|\<ar\>|${AR}|g' src/at/deb-format.at src/at/testsuite || die
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export AR CC
+
+ local myconf=(
+ --disable-compiler-warnings
+ --disable-devel-docs
+ --disable-dselect
+ --disable-start-stop-daemon
+ --enable-unicode
+ --localstatedir="${EPREFIX}"/var
+ $(use_enable nls)
+ $(use_enable update-alternatives)
+ $(use_with bzip2 libbz2)
+ $(use_with lzma liblzma)
+ $(use_with selinux libselinux)
+ $(use_with zlib libz)
+ $(use_with zstd libzstd)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local DOCS=( debian/changelog THANKS TODO )
+ default
+
+ # https://bugs.gentoo.org/835520
+ mv -v "${ED}"/usr/share/zsh/{vendor-completions,site-functions} || die
+
+ # https://bugs.gentoo.org/840320
+ insinto /etc/dpkg/origins
+ newins - gentoo <<-_EOF_
+ Vendor: Gentoo
+ Vendor-URL: https://www.gentoo.org/
+ Bugs: https://bugs.gentoo.org/
+ _EOF_
+ dosym gentoo /etc/dpkg/origins/default
+
+ keepdir \
+ /usr/$(get_libdir)/db/methods/{mnt,floppy,disk} \
+ /var/lib/dpkg/{alternatives,info,parts,updates}
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+}
diff --git a/app-arch/dpkg/files/dpkg-1.22.11-sq-tests.patch b/app-arch/dpkg/files/dpkg-1.22.11-sq-tests.patch
new file mode 100644
index 000000000000..51df67ce1ca0
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.22.11-sq-tests.patch
@@ -0,0 +1,63 @@
+https://git.dpkg.org/cgit/dpkg/dpkg.git/commit/?id=fc7bda93992086e01b62d08fa5ca2b70a69b62aa
+
+From fc7bda93992086e01b62d08fa5ca2b70a69b62aa Mon Sep 17 00:00:00 2001
+From: Guillem Jover <guillem@debian.org>
+Date: Tue, 3 Dec 2024 02:40:48 +0100
+Subject: Dpkg::OpenPGP::Backend::Sequoia: Adapt to new CLI 0.40.0 API
+
+As the API is not yet stable (but it is getting closer to be), we
+need to adapt it to the current version.
+---
+ scripts/Dpkg/OpenPGP/Backend/Sequoia.pm | 11 ++++++-----
+ 2 files changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/scripts/Dpkg/OpenPGP/Backend/Sequoia.pm b/scripts/Dpkg/OpenPGP/Backend/Sequoia.pm
+index 36801c9f5..82c64591c 100644
+--- a/scripts/Dpkg/OpenPGP/Backend/Sequoia.pm
++++ b/scripts/Dpkg/OpenPGP/Backend/Sequoia.pm
+@@ -69,7 +69,7 @@ sub armor
+ return OPENPGP_MISSING_CMD unless $self->{cmd};
+
+ # We ignore the $type, and let "sq" handle this automatically.
+- my $rc = $self->_sq_exec(qw(toolbox armor --output), $out, $in);
++ my $rc = $self->_sq_exec(qw(packet armor --output), $out, $in);
+ return OPENPGP_BAD_DATA if $rc;
+ return OPENPGP_OK;
+ }
+@@ -81,7 +81,7 @@ sub dearmor
+ return OPENPGP_MISSING_CMD unless $self->{cmd};
+
+ # We ignore the $type, and let "sq" handle this automatically.
+- my $rc = $self->_sq_exec(qw(toolbox dearmor --output), $out, $in);
++ my $rc = $self->_sq_exec(qw(packet dearmor --output), $out, $in);
+ return OPENPGP_BAD_DATA if $rc;
+ return OPENPGP_OK;
+ }
+@@ -93,6 +93,7 @@ sub inline_verify
+ return OPENPGP_MISSING_CMD unless $self->{cmd};
+
+ my @opts;
++ push @opts, '--cleartext';
+ push @opts, map { ('--signer-file', $_) } @certs;
+ push @opts, '--output', $data if defined $data;
+
+@@ -109,7 +110,7 @@ sub verify
+
+ my @opts;
+ push @opts, map { ('--signer-file', $_) } @certs;
+- push @opts, '--detached', $sig;
++ push @opts, '--signature-file', $sig;
+
+ my $rc = $self->_sq_exec(qw(verify), @opts, $data);
+ return OPENPGP_NO_SIG if $rc;
+@@ -124,7 +125,7 @@ sub inline_sign
+ return OPENPGP_NEEDS_KEYSTORE if $key->needs_keystore();
+
+ my @opts;
+- push @opts, '--cleartext-signature';
++ push @opts, '--cleartext';
+ push @opts, '--signer-file', $key->handle;
+ push @opts, '--output', $inlinesigned;
+
+--
+cgit v1.2.3