summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-18 02:57:48 +0000
committerSam James <sam@gentoo.org>2024-01-18 03:19:19 +0000
commit226fcb9d41b4be413a80adac41ddcf090f260bae (patch)
tree3ba0f2377d3b10cfb543040c5a7982072f66fef1 /app-arch/cpio
parentapp-arch/tar: run tests in parallel (diff)
downloadgentoo-226fcb9d41b4be413a80adac41ddcf090f260bae.tar.gz
gentoo-226fcb9d41b4be413a80adac41ddcf090f260bae.tar.bz2
gentoo-226fcb9d41b4be413a80adac41ddcf090f260bae.zip
app-arch/cpio: run tests in parallel
Inspired by vapier's cd7f047fe43fb631c4ca6979c6efb5038c616f41. `RUNTESTFLAGS` has been in the back of my head for a while now as I've been meaning to figure out the interaction between it and parallel make and which packages actually need it. This only shaves off about ~10s or so consistently for me for cpio though, as its test suite is smaller, but maybe it'll do better on slower machines. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/cpio')
-rw-r--r--app-arch/cpio/cpio-2.15.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-arch/cpio/cpio-2.15.ebuild b/app-arch/cpio/cpio-2.15.ebuild
index e9733b098ca1..6f98be317e83 100644
--- a/app-arch/cpio/cpio-2.15.ebuild
+++ b/app-arch/cpio/cpio-2.15.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit multiprocessing
+
DESCRIPTION="File archival tool which can also read and write tar files"
HOMEPAGE="https://www.gnu.org/software/cpio/cpio.html"
SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
@@ -39,6 +41,10 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ emake check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+}
+
pkg_postinst() {
# Ensure to preserve the symlink before app-alternatives/cpio
# is installed