summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-28 07:54:16 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-07-05 19:41:13 +0200
commit6333666920d4994a9fee1350c9b440d32d686209 (patch)
tree31c735bda5175f6ba6d3846c08ee85e74a5b5749 /app-admin
parentdev-python/pypiserver: Check for dev-python/twice w/ PYTHON_USEDEP (diff)
downloadgentoo-6333666920d4994a9fee1350c9b440d32d686209.tar.gz
gentoo-6333666920d4994a9fee1350c9b440d32d686209.tar.bz2
gentoo-6333666920d4994a9fee1350c9b440d32d686209.zip
app-admin/logmon: EAPI8 bump, fix SRC_URI
The source archive changed, however the code didn't changed at all. Only a logmon.spec was added and the directory structure + some svn related files changed. Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37328 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logmon/Manifest3
-rw-r--r--app-admin/logmon/logmon-0.4.4-r1.ebuild6
-rw-r--r--app-admin/logmon/logmon-0.4.4-r2.ebuild52
3 files changed, 57 insertions, 4 deletions
diff --git a/app-admin/logmon/Manifest b/app-admin/logmon/Manifest
index f094bdedbc5d..4bf8875833eb 100644
--- a/app-admin/logmon/Manifest
+++ b/app-admin/logmon/Manifest
@@ -1 +1,2 @@
-DIST LogMon-0.4.4.tar.bz2 65975 BLAKE2B 67f7dee996d18ef398dfbdf56c9092d2906f562aa245de0dc481eaa5c17edd8c9b300f234363641d6911cfe7b6d8c736a354e5f424eec948f0d520bb01e047ca SHA512 9ddbccfea0cae3d7fa6ffa9576f0030b6fb66e0dca152fb5242e7bd19ce319e922264720fa44f6b65319f8b25ad9e208a01434b94c629fa737bdd82ea22a4fac
+DIST LogMon-0.4.4.tar.bz2 66904 BLAKE2B 2b4ba55a4a4924580d0ad1c3e7320ceb36919e9d6eab23e6fc4e03085f878db1ae49c7fb69986fbe266387c85be859a34834e2d5c81c3bdd7e116bd6710e63e2 SHA512 4d75e9664a92a196eb2d0b4e3673b87adf9d4b53d4d99c1c8a72620637f005422af4d2a008e861ea03772c1007d510fd4a9b1c9847b024af6711959680ac6edc
+DIST logmon-0.4.4.r1.tar.bz2 66904 BLAKE2B 2b4ba55a4a4924580d0ad1c3e7320ceb36919e9d6eab23e6fc4e03085f878db1ae49c7fb69986fbe266387c85be859a34834e2d5c81c3bdd7e116bd6710e63e2 SHA512 4d75e9664a92a196eb2d0b4e3673b87adf9d4b53d4d99c1c8a72620637f005422af4d2a008e861ea03772c1007d510fd4a9b1c9847b024af6711959680ac6edc
diff --git a/app-admin/logmon/logmon-0.4.4-r1.ebuild b/app-admin/logmon/logmon-0.4.4-r1.ebuild
index 9aaa2ca57d66..a572ede4cc80 100644
--- a/app-admin/logmon/logmon-0.4.4-r1.ebuild
+++ b/app-admin/logmon/logmon-0.4.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,8 +8,8 @@ inherit autotools flag-o-matic
MY_P="LogMon-${PV}"
DESCRIPTION="Split-screen terminal/ncurses based log viewer"
HOMEPAGE="http://www.edespot.com/logmon/"
-SRC_URI="http://www.edespot.com/code/LogMon/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.edespot.com/logmon/files/${MY_P}.tar.bz2 -> ${P}.r1.tar.bz2"
+S="${WORKDIR}/${PV}/${MY_P}"
LICENSE="Artistic"
SLOT="0"
diff --git a/app-admin/logmon/logmon-0.4.4-r2.ebuild b/app-admin/logmon/logmon-0.4.4-r2.ebuild
new file mode 100644
index 000000000000..79b173210a7c
--- /dev/null
+++ b/app-admin/logmon/logmon-0.4.4-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_P="LogMon-${PV}"
+DESCRIPTION="Split-screen terminal/ncurses based log viewer"
+HOMEPAGE="http://www.edespot.com/logmon/"
+SRC_URI="http://www.edespot.com/logmon/files/${MY_P}.tar.bz2"
+S="${WORKDIR}/${PV}/${MY_P}"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # Bug 119403 - should be in upstream next release
+ "${FILESDIR}"/${P}-char2int.diff
+
+ # Bug 250602, gcc43 fix
+ "${FILESDIR}"/${P}-gcc43.patch
+
+ # Fixes maintainer-mode detected.
+ "${FILESDIR}"/${P}-maintainer-mode.patch
+
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ # Uses removed 'register' keyword, bug #894206
+ append-cxxflags -std=c++14
+
+ econf
+}
+
+src_install() {
+ dobin logmon
+
+ dodoc AUTHORS ChangeLog README TODO
+}