summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-02-13 11:10:21 -0800
committerPatrick McLean <chutzpah@gentoo.org>2024-02-13 11:27:22 -0800
commitda5fe311f71bcf58ab584c6d198b8cd65c4ca0d7 (patch)
treebdbd084c64e41e1badca1930818004ef49bdc461 /app-admin/salt
parentprofiles.desc: Add 23.0 mips profiles (diff)
downloadgentoo-da5fe311f71bcf58ab584c6d198b8cd65c4ca0d7.tar.gz
gentoo-da5fe311f71bcf58ab584c6d198b8cd65c4ca0d7.tar.bz2
gentoo-da5fe311f71bcf58ab584c6d198b8cd65c4ca0d7.zip
app-admin/salt: Skip systemd tests in 3005.5 (bug #924377)
Closes: https://bugs.gentoo.org/924377 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-admin/salt')
-rw-r--r--app-admin/salt/salt-3005.5.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-admin/salt/salt-3005.5.ebuild b/app-admin/salt/salt-3005.5.ebuild
index 9de6de9dfe39..ecb95415f5f1 100644
--- a/app-admin/salt/salt-3005.5.ebuild
+++ b/app-admin/salt/salt-3005.5.ebuild
@@ -265,6 +265,26 @@ python_test() {
# need root
tests/pytests/unit/modules/test_cmdmod.py::test_runas_env_sudo_group
)
+ # https://bugs.gentoo.org/924377
+ has_version 'sys-apps/systemd' || EPYTEST_DESELECT+=(
+ tests/pytests/unit/modules/test_aptpkg.py::test_autoremove
+ tests/pytests/unit/modules/test_aptpkg.py::test_upgrade
+ tests/pytests/unit/modules/test_aptpkg.py::test_upgrade_downloadonly
+ tests/pytests/unit/modules/test_aptpkg.py::test_upgrade_allow_downgrades
+ tests/pytests/unit/modules/test_aptpkg.py::test_call_apt_default
+ tests/pytests/unit/modules/test_aptpkg.py::test_call_apt_with_kwargs
+ tests/pytests/unit/modules/test_linux_sysctl.py::test_persist_no_conf_failure
+ tests/pytests/unit/modules/test_yumpkg.py::test_latest_version_with_options
+ tests/pytests/unit/modules/test_yumpkg.py::test_list_repo_pkgs_with_options
+ tests/pytests/unit/modules/test_yumpkg.py::test_list_upgrades_dnf
+ tests/pytests/unit/modules/test_yumpkg.py::test_list_upgrades_yum
+ tests/pytests/unit/modules/test_yumpkg.py::test_refresh_db_with_options
+ tests/pytests/unit/modules/test_yumpkg.py::test_call_yum_default
+ tests/pytests/unit/modules/test_yumpkg.py::test_call_yum_with_kwargs
+ tests/unit/modules/test_kernelpkg_linux_yum.py::YumKernelPkgTestCase::test_remove_error
+ tests/unit/modules/test_kernelpkg_linux_yum.py::YumKernelPkgTestCase::test_remove_success
+ tests/unit/modules/test_zypperpkg.py::ZypperTestCase::test_remove_purge
+ )
# testsuite likes lots of files
ulimit -n 4096 || die