summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/qpage/qpage-3.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/qpage/qpage-3.3.ebuild')
-rw-r--r--app-admin/qpage/qpage-3.3.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/qpage/qpage-3.3.ebuild b/app-admin/qpage/qpage-3.3.ebuild
new file mode 100644
index 000000000000..dfb769629093
--- /dev/null
+++ b/app-admin/qpage/qpage-3.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Sends messages to an alphanumeric pager via TAP protocol"
+HOMEPAGE="http://www.qpage.org/"
+SRC_URI="http://www.qpage.org/download/${P}.tar.Z"
+
+LICENSE="qpage"
+SLOT="0"
+KEYWORDS="alpha amd64 x86"
+IUSE="tcpd"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}
+ virtual/mta"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-fix-warning.patch
+}
+
+src_compile() {
+ tc-export CC
+ econf || die "econf failed"
+
+ # There doesn't seem to be a clean way to disable tcp wrappers in
+ # this package if you have it installed, but don't want to use it.
+ if ! use tcpd ; then
+ sed -i 's/-lwrap//g; s/-DTCP_WRAPPERS//g' Makefile
+ echo '#undef TCP_WRAPPERS' >> config.h
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ dodir /var/spool/qpage
+ fowners daemon:daemon /var/spool/qpage
+ fperms 770 /var/spool/qpage
+
+ dodir /var/lock/subsys/qpage
+ fowners daemon:daemon /var/lock/subsys/qpage
+ fperms 770 /var/lock/subsys/qpage
+
+ insinto /etc/qpage
+ doins example.cf || die "doins example.cf failed"
+
+ doinitd "${FILESDIR}"/qpage
+}
+
+pkg_postinst() {
+ elog
+ elog "Post-installation tasks:"
+ elog
+ elog "1. Create /etc/qpage/qpage.cf (see example.cf in that dir)."
+ elog "2. Insure that the serial port selected in qpage.cf"
+ elog " is writable by user or group daemon."
+ elog "3. Set automatic startup with rc-update add qpage default"
+ elog "4. Send mail to tomiii@qpage.org telling him how"
+ elog " you like qpage! :-)"
+ elog
+}