summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-04-23 00:12:00 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2017-04-23 00:12:21 +0200
commit5d2f077380c83dec1845cdd21323d2364724625c (patch)
tree6e54bac2c408b452982b40bf5b039299ebf010e4 /app-admin/logrotate/files
parentdev-python/webpy: version bump. (diff)
downloadgentoo-5d2f077380c83dec1845cdd21323d2364724625c.tar.gz
gentoo-5d2f077380c83dec1845cdd21323d2364724625c.tar.bz2
gentoo-5d2f077380c83dec1845cdd21323d2364724625c.zip
app-admin/logrotate: Bumps version to 3.12.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/logrotate/files')
-rw-r--r--app-admin/logrotate/files/logrotate-3.12.1-Werror.patch12
-rw-r--r--app-admin/logrotate/files/logrotate-3.12.1-fbsd.patch36
-rw-r--r--app-admin/logrotate/files/logrotate-3.12.1-ignore-hidden.patch14
3 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/logrotate/files/logrotate-3.12.1-Werror.patch b/app-admin/logrotate/files/logrotate-3.12.1-Werror.patch
new file mode 100644
index 000000000000..b8054e50a027
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate-3.12.1-Werror.patch
@@ -0,0 +1,12 @@
+diff -Nuar a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2017-04-21 12:58:48.000000000 +0200
++++ b/Makefile.am 2017-04-23 00:02:39.312011684 +0200
+@@ -9,7 +9,7 @@
+ # GNU General Public License for more details.
+ #
+ AM_CPPFLAGS = -include config.h
+-AM_CFLAGS = -Wall -Werror
++AM_CFLAGS = -Wall
+ sbin_PROGRAMS = logrotate
+ logrotate_SOURCES = config.c log.c logrotate.c \
+ log.h logrotate.h queue.h
diff --git a/app-admin/logrotate/files/logrotate-3.12.1-fbsd.patch b/app-admin/logrotate/files/logrotate-3.12.1-fbsd.patch
new file mode 100644
index 000000000000..67a60e3af177
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate-3.12.1-fbsd.patch
@@ -0,0 +1,36 @@
+diff -Nuar a/config.c b/config.c
+--- a/config.c 2017-04-22 23:46:08.201991730 +0200
++++ b/config.c 2017-04-22 23:49:43.021996055 +0200
+@@ -25,6 +25,10 @@
+ #include <sys/mman.h>
+ #include <libgen.h>
+
++#if !defined(PATH_MAX) && defined(__FreeBSD__)
++#include <sys/param.h>
++#endif
++
+ #include "log.h"
+ #include "logrotate.h"
+
+diff -Nuar a/logrotate.c b/logrotate.c
+--- a/logrotate.c 2017-04-21 10:52:10.000000000 +0200
++++ b/logrotate.c 2017-04-22 23:50:20.691996814 +0200
+@@ -1,6 +1,6 @@
+ #include "queue.h"
+ /* alloca() is defined in stdlib.h in NetBSD */
+-#ifndef __NetBSD__
++#if !defined(__NetBSD__) && !defined(__FreeBSD__)
+ #include <alloca.h>
+ #endif
+ #include <limits.h>
+@@ -27,6 +27,10 @@
+ #include <limits.h>
+ #endif
+
++#if !defined(PATH_MAX) && defined(__FreeBSD__)
++#include <sys/param.h>
++#endif
++
+ #include "log.h"
+ #include "logrotate.h"
+
diff --git a/app-admin/logrotate/files/logrotate-3.12.1-ignore-hidden.patch b/app-admin/logrotate/files/logrotate-3.12.1-ignore-hidden.patch
new file mode 100644
index 000000000000..0bbb91dcb4fc
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate-3.12.1-ignore-hidden.patch
@@ -0,0 +1,14 @@
+diff -Nuar a/config.c b/config.c
+--- a/config.c 2017-04-18 14:57:02.000000000 +0200
++++ b/config.c 2017-04-22 23:46:08.201991730 +0200
+@@ -389,7 +389,9 @@
+ int i;
+
+ /* Check if fname is '.' or '..'; if so, return false */
+- if (fname[0] == '.' && (!fname[1] || (fname[1] == '.' && !fname[2])))
++ /* Don't include 'hidden' files either; this breaks Gentoo
++ portage config file management http://bugs.gentoo.org/87683 */
++ if (fname[0] == '.')
+ return 0;
+
+ /* Check if fname is ending in a taboo-extension; if so, return false */