summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2016-02-15 07:38:21 +0100
committerTomas Mozes <hydrapolic@gmail.com>2016-02-15 07:38:21 +0100
commit06ee7b08257b57492ab541f4b1363b696d686b67 (patch)
treeaf26ff3bec54aae5ac100add9cd3ddbec4a3289f /app-admin/filebeat-bin
parentx11-wm/jwm: Stable for HPPA (bug #571450). (diff)
downloadgentoo-06ee7b08257b57492ab541f4b1363b696d686b67.tar.gz
gentoo-06ee7b08257b57492ab541f4b1363b696d686b67.tar.bz2
gentoo-06ee7b08257b57492ab541f4b1363b696d686b67.zip
app-admin/filebeat-bin: bump to version 1.1.1
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-admin/filebeat-bin')
-rw-r--r--app-admin/filebeat-bin/Manifest2
-rw-r--r--app-admin/filebeat-bin/filebeat-bin-1.0.1.ebuild2
-rw-r--r--app-admin/filebeat-bin/filebeat-bin-1.1.1.ebuild49
3 files changed, 52 insertions, 1 deletions
diff --git a/app-admin/filebeat-bin/Manifest b/app-admin/filebeat-bin/Manifest
index a5766ccab4ef..3f802d1bda8c 100644
--- a/app-admin/filebeat-bin/Manifest
+++ b/app-admin/filebeat-bin/Manifest
@@ -1,2 +1,4 @@
DIST filebeat-1.0.1-i686.tar.gz 3073413 SHA256 a9ccf9a4f1d3e2c840ad153ae4594a4cabccaa53c178c3ad585590e10994d7b8 SHA512 164835cb4dd98b6e897e004fdc0c099022be8e83ced89a0dbbbec119f32eaaf9f6ed5eaec41d3c86d5722df662577d83b9623b057ac7913038b04ee344ae5a85 WHIRLPOOL 9983b74569ff303cdfcff8968a0a93dab34e1f9c3d184f89e88e066106cd94a687e07a94e3ba6ac6019d786cad50a07ec8052043a5bdd3cbc095eaae64c50c0f
DIST filebeat-1.0.1-x86_64.tar.gz 3265179 SHA256 662bceca18eabf9c81681b790776398a78fdf36604b5d0edc8abedd28980de52 SHA512 5ec0a0371790a425fac67ddb164fc4b347eb79468f85b8a64d78491a478aacfc2d3eaad62f654847c7381d4dc3686075e428ecc2271f415aa1cc83b5c84e72b7 WHIRLPOOL 58c86a41cdd2543d8de82e0572af27adac7d44d09c7866c984616c7dcb296087eaa25f6c7de234f27ed25698bad9d18a444bfd89166c5a415457a2f473fa6263
+DIST filebeat-1.1.1-i686.tar.gz 3421542 SHA256 c425223e0fd6fe2c768cf1982a5da997ec1ef183ebcbb3419d815c26851b4ff4 SHA512 e912407b1ebf265741fbeb2ecd742850f428e103a116773bf06e8835ef12179d10767d650f79342e440efe7786f88740787ff8c75cc0df0f7295de5d8f4b1eed WHIRLPOOL 2b937f428889e79c25bc80cbd499c02d42bc5583c681df6b1e6610a58d4ef5fa24254bfe1c51303b4b6dcfd05d6ff2bce4484c4d75fde0b2add47ae17da58b1f
+DIST filebeat-1.1.1-x86_64.tar.gz 3633191 SHA256 2df9ec1b4e0e78b1edfa678d70c1b4dde3c06f2f166accdb176617377061b583 SHA512 d9da1999302c5de476b7788102af0ab7786100f90cd957f2fe3e212b871d38c017aedfea7eaa32865dc0f3e21e256b6597a3575072e9320674d49fbc2f1ab1d8 WHIRLPOOL 1bf075c967a39a270cd37ae94d222fb0ec1cf2e7faf3e0bc74b1461093ea9547e67bb8969e5a4033e793653772de659ee39e20c06926ed44ce48228b915cc47d
diff --git a/app-admin/filebeat-bin/filebeat-bin-1.0.1.ebuild b/app-admin/filebeat-bin/filebeat-bin-1.0.1.ebuild
index 96d830c7b279..c905816e3be9 100644
--- a/app-admin/filebeat-bin/filebeat-bin-1.0.1.ebuild
+++ b/app-admin/filebeat-bin/filebeat-bin-1.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/app-admin/filebeat-bin/filebeat-bin-1.1.1.ebuild b/app-admin/filebeat-bin/filebeat-bin-1.1.1.ebuild
new file mode 100644
index 000000000000..c905816e3be9
--- /dev/null
+++ b/app-admin/filebeat-bin/filebeat-bin-1.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN/-bin/}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="amd64? ( https://download.elastic.co/beats/${MY_PN}/${MY_P}-x86_64.tar.gz )
+ x86? ( https://download.elastic.co/beats/${MY_PN}/${MY_P}-i686.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ if use amd64; then
+ S="${WORKDIR}/${MY_P}-x86_64"
+ elif use x86; then
+ S="${WORKDIR}/${MY_P}-i686"
+ fi
+
+ default
+}
+
+src_install() {
+ keepdir /etc/${MY_PN}
+ keepdir /var/lib/${MY_PN}
+
+ fperms 0750 /var/lib/${MY_PN}
+
+ newconfd "${FILESDIR}/${MY_PN}.confd" ${MY_PN}
+ newinitd "${FILESDIR}/${MY_PN}.initd" ${MY_PN}
+
+ insinto /etc/${MY_PN}
+ newins ${MY_PN}.yml ${MY_PN}.yml.example
+
+ dobin ${MY_PN}
+}
+
+pkg_postinst() {
+ if [[ ! -e /etc/${MY_PN}/${MY_PN}.yml ]]; then
+ elog "Before starting filebeat, you need to create a configuration file at:"
+ elog "/etc/${MY_PN}/${MY_PN}.yml"
+ fi
+}