summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-08-31 00:10:15 +0200
committerUlrich Müller <ulm@gentoo.org>2019-08-31 00:10:15 +0200
commit1494a489641e916d6d23b57d738c82251580c71d (patch)
tree046967408d2639ebb98f655370a06a3a5503e74c /app-admin/emacs-updater
parentprofiles: [QA] Add missing eapi file in default/bsd/fbsd/amd64/11.1/clang. (diff)
downloadgentoo-1494a489641e916d6d23b57d738c82251580c71d.tar.gz
gentoo-1494a489641e916d6d23b57d738c82251580c71d.tar.bz2
gentoo-1494a489641e916d6d23b57d738c82251580c71d.zip
app-admin/emacs-updater: Bump to version 1.16.
Closes: https://bugs.gentoo.org/631132 Closes: https://bugs.gentoo.org/693140 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-admin/emacs-updater')
-rw-r--r--app-admin/emacs-updater/Manifest1
-rw-r--r--app-admin/emacs-updater/emacs-updater-1.16.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/emacs-updater/Manifest b/app-admin/emacs-updater/Manifest
index 9073c749e580..e23041d5e148 100644
--- a/app-admin/emacs-updater/Manifest
+++ b/app-admin/emacs-updater/Manifest
@@ -1 +1,2 @@
DIST emacs-updater-1.15.tar.xz 7020 BLAKE2B bb35103b328a57dcaeb11c258bddbd3a08141d1e245ac4943c7a5a8b815440db0cd06eaac01ad2a00e6e2aa0d23311d774d190fd761be66514856077b3c4e296 SHA512 8cc7dd3e0e28ae71030c7c5f29d54f24e12adcbd0615f3c598ad262bd233f028c2424c277aac7dff7b4201a2ac24bfab0e05d1fdc07edcee2c184a733f699b8a
+DIST emacs-updater-1.16.tar.xz 7112 BLAKE2B 82160ef71b4c22a385a45765c1f60b7d428297cfb3b51f84bd44b176d1bd302165f9ccdde803aae628a2dab9e0520098082232c513b2006ae5facfa283f287ab SHA512 3de3126debc49ea47bd57802c1a3aa82a0769ab392741fb891c93ffb66141f05f58025fa0de746ec78795fc34c135536740e447e1f6a4ae59aa847d21bd6215b
diff --git a/app-admin/emacs-updater/emacs-updater-1.16.ebuild b/app-admin/emacs-updater/emacs-updater-1.16.ebuild
new file mode 100644
index 000000000000..ef79c178430b
--- /dev/null
+++ b/app-admin/emacs-updater/emacs-updater-1.16.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Rebuild Emacs packages"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="|| ( sys-apps/util-linux app-misc/getopt )"
+RDEPEND="${DEPEND}
+ >=app-portage/portage-utils-0.3
+ virtual/emacs"
+
+src_prepare() {
+ default
+
+ if ! has_version sys-apps/util-linux; then
+ # BSD ships a dumb getopt(1), so use getopt-long instead
+ sed -i -e '/^GETOPT=/s/getopt/&-long/' emacs-updater || die
+ fi
+
+ if [[ -n ${EPREFIX} ]]; then
+ sed -i -e "1s:/:${EPREFIX%/}/:" \
+ -e "s:^\([[:upper:]]*=\)/:\1${EPREFIX%/}/:" \
+ emacs-updater || die
+ fi
+}
+
+src_install() {
+ dosbin emacs-updater
+ doman emacs-updater.8
+}