summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrealaltffour <56314286+realaltffour@users.noreply.github.com>2020-03-10 04:43:41 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-03-15 19:51:50 +0200
commit5cd52ba5291c71e801b5b49eb665efdcf95183a5 (patch)
tree167ae5f86a9cd76820082e4b5ca09439f6dffedf /app-admin/doas/doas-6.6.1.ebuild
parentmail-filter/spamassassin: Cleanup 3.4.2 ebuilds (diff)
downloadgentoo-5cd52ba5291c71e801b5b49eb665efdcf95183a5.tar.gz
gentoo-5cd52ba5291c71e801b5b49eb665efdcf95183a5.tar.bz2
gentoo-5cd52ba5291c71e801b5b49eb665efdcf95183a5.zip
app-admin/doas: Bump version to 6.6.1
Signed-off-by: Ayham Abou Al Fadl <ayhamaboualfadl@gmail.com> Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-admin/doas/doas-6.6.1.ebuild')
-rw-r--r--app-admin/doas/doas-6.6.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/doas/doas-6.6.1.ebuild b/app-admin/doas/doas-6.6.1.ebuild
new file mode 100644
index 000000000000..013cb7f30509
--- /dev/null
+++ b/app-admin/doas/doas-6.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run commands as super user or another user, alternative to sudo from OpenBSD"
+
+MY_PN=OpenDoas
+MY_P=${MY_PN}-${PV}
+HOMEPAGE="https://github.com/Duncaen/OpenDoas"
+SRC_URI="https://github.com/Duncaen/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="pam"
+
+RDEPEND="pam? ( sys-libs/pam )"
+DEPEND="${RDEPEND}
+ virtual/yacc"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror //' Makefile || die
+}
+
+src_configure() {
+ tc-export CC AR
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ $(use_with pam) \
+ || die
+}