summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-01-02 10:53:34 +0400
committerJason Zaman <perfinion@gentoo.org>2016-01-02 10:54:21 +0400
commit7eb7107cf02c65a8bb2947c9379002e067b957af (patch)
treea123cfd1d23c333f07425ad78473f8b77847a471 /app-admin/collectd
parentdev-ruby/httpclient: add 2.7.1 (diff)
downloadgentoo-7eb7107cf02c65a8bb2947c9379002e067b957af.tar.gz
gentoo-7eb7107cf02c65a8bb2947c9379002e067b957af.tar.bz2
gentoo-7eb7107cf02c65a8bb2947c9379002e067b957af.zip
app-admin/collectd: version bump to 5.5
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-admin/collectd')
-rw-r--r--app-admin/collectd/Manifest1
-rw-r--r--app-admin/collectd/collectd-5.5.0.ebuild399
-rw-r--r--app-admin/collectd/metadata.xml112
3 files changed, 464 insertions, 48 deletions
diff --git a/app-admin/collectd/Manifest b/app-admin/collectd/Manifest
index 3bb23b29a922..81e7cd7b6c4c 100644
--- a/app-admin/collectd/Manifest
+++ b/app-admin/collectd/Manifest
@@ -1 +1,2 @@
DIST collectd-5.4.1.tar.bz2 1521907 SHA256 75452129f271cb0aad28e57f12a49070618bbb7b6a9d64cf869e8766fa2f66e0 SHA512 96289f52d3d1da55c862ae9ee2f57972682d7eab87387e97efa41fb5197599e097abd71aed2fe014e26af37c9ae98471e06dd181c725849976242642ce5c9492 WHIRLPOOL 2ed85b9d6d00c4e7dc6af236b637e282f17c6c0b20c1ba3da9c12ea85c5fdea1add2e29165874c7e9620852e422282d489436a4e245b161902f8926185edec16
+DIST collectd-5.5.0.tar.bz2 1824495 SHA256 847684cf5c10de1dc34145078af3fcf6e0d168ba98c14f1343b1062a4b569e88 SHA512 d2c2840f681c10345e02ad8df0f7c581dcb45bee276589fcd96b3dadd281a79ebb3b9a34a186242ef41285dde7fc505432376138ff4f72c4f60f1b840e640017 WHIRLPOOL 6223ca363984ab3777ca89e2cd5011f059b6ca7f5c66c5e7325d3155ce38ef2829caced3ad27e4d5016c5fdba59bb21b9b47d840ea0c4d164c3674b6ee5062ac
diff --git a/app-admin/collectd/collectd-5.5.0.ebuild b/app-admin/collectd/collectd-5.5.0.ebuild
new file mode 100644
index 000000000000..012278f2d738
--- /dev/null
+++ b/app-admin/collectd/collectd-5.5.0.ebuild
@@ -0,0 +1,399 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GENTOO_DEPEND_ON_PERL="no"
+JAVA_PKG_OPT_USE="collectd_plugins_java"
+# XXX: 5.4.1-r0 stated 2* but it builds fine against 3.4
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils fcaps java-pkg-opt-2 linux-info multilib perl-app python-single-r1 systemd user
+
+DESCRIPTION="Collects system statistics and provides mechanisms to store the values"
+
+HOMEPAGE="http://collectd.org"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="contrib debug kernel_linux kernel_FreeBSD kernel_Darwin perl selinux static-libs"
+
+# The plugin lists have to follow here since they extend IUSE
+
+# Plugins that to my knowledge cannot be supported (eg. dependencies not in gentoo)
+COLLECTD_IMPOSSIBLE_PLUGINS="aquaero mic netapp pinba sigrok write_kafka xmms"
+
+# Plugins that still need some work
+COLLECTD_UNTESTED_PLUGINS="amqp apple_sensors genericjmx ipvs lpar modbus tape"
+
+# Plugins that have been (compile) tested and can be enabled via COLLECTD_PLUGINS
+COLLECTD_TESTED_PLUGINS="aggregation apache apcups ascent battery bind ceph
+ cgroups conntrack contextswitch cpu cpufreq csv curl curl_json curl_xml dbi df
+ disk dns drbd email entropy ethstat exec fhcount filecount fscache gmond
+ hddtemp interface ipc ipmi iptables irq java load log_logstash logfile lvm
+ madwifi match_empty_counter match_hashed match_regex match_timediff match_value
+ mbmon md memcachec memcached memory multimeter mysql netlink network nfs nginx
+ notify_desktop notify_email ntpd numa nut olsrd onewire openldap openvpn oracle
+ perl ping postgresql powerdns processes protocols python redis routeros
+ rrdcached rrdtool sensors serial smart snmp statsd swap syslog table tail
+ target_notification target_replace target_scale target_set tcpconns teamspeak2
+ ted thermal threshold tokyotyrant turbostat unixsock uptime users uuid varnish
+ virt vmem vserver wireless write_graphite write_http write_log write_mongodb
+ write_redis write_sensu write_tsdb zfs_arc zookeeper"
+
+COLLECTD_DISABLED_PLUGINS="${COLLECTD_IMPOSSIBLE_PLUGINS} ${COLLECTD_UNTESTED_PLUGINS}"
+
+COLLECTD_ALL_PLUGINS=${COLLECTD_TESTED_PLUGINS}
+
+for plugin in ${COLLECTD_ALL_PLUGINS}; do
+ IUSE="${IUSE} collectd_plugins_${plugin}"
+done
+unset plugin
+
+# Now come the dependencies.
+
+COMMON_DEPEND="
+ dev-libs/libgcrypt:0
+ sys-devel/libtool
+ perl? ( dev-lang/perl:=[ithreads] )
+ collectd_plugins_apache? ( net-misc/curl )
+ collectd_plugins_ascent? ( net-misc/curl dev-libs/libxml2 )
+ collectd_plugins_bind? ( dev-libs/libxml2:= )
+ collectd_plugins_ceph? ( dev-libs/yajl:= )
+ collectd_plugins_curl? ( net-misc/curl )
+ collectd_plugins_curl_json? ( net-misc/curl dev-libs/yajl:= )
+ collectd_plugins_curl_xml? ( net-misc/curl dev-libs/libxml2:= )
+ collectd_plugins_dbi? ( dev-db/libdbi:= )
+ collectd_plugins_dns? ( net-libs/libpcap:= )
+ collectd_plugins_gmond? ( sys-cluster/ganglia )
+ collectd_plugins_ipmi? ( >=sys-libs/openipmi-2.0.16-r1 )
+ collectd_plugins_iptables? ( >=net-firewall/iptables-1.4.13 )
+ collectd_plugins_log_logstash? ( dev-libs/yajl:= )
+ collectd_plugins_lvm? ( sys-fs/lvm2 )
+ collectd_plugins_memcachec? ( dev-libs/libmemcached:= )
+ collectd_plugins_mysql? ( >=virtual/mysql-5.0 )
+ collectd_plugins_netlink? ( net-libs/libmnl:= )
+ collectd_plugins_nginx? ( net-misc/curl )
+ collectd_plugins_notify_desktop? ( x11-libs/libnotify:= )
+ collectd_plugins_notify_email? ( net-libs/libesmtp dev-libs/openssl:0= )
+ collectd_plugins_nut? ( sys-power/nut )
+ collectd_plugins_onewire? ( sys-fs/owfs )
+ collectd_plugins_oracle? ( dev-db/oracle-instantclient-basic )
+ collectd_plugins_openldap? ( net-nds/openldap )
+ collectd_plugins_perl? ( dev-lang/perl:=[ithreads] )
+ collectd_plugins_ping? ( net-libs/liboping:= )
+ collectd_plugins_postgresql? ( dev-db/postgresql:= )
+ collectd_plugins_python? ( ${PYTHON_DEPS} )
+ collectd_plugins_redis? ( dev-libs/hiredis:= )
+ collectd_plugins_routeros? ( net-libs/librouteros:= )
+ collectd_plugins_rrdcached? ( net-analyzer/rrdtool )
+ collectd_plugins_rrdtool? ( net-analyzer/rrdtool )
+ collectd_plugins_sensors? ( sys-apps/lm_sensors )
+ collectd_plugins_smart? ( dev-libs/libatasmart:= )
+ collectd_plugins_snmp? ( net-analyzer/net-snmp )
+ collectd_plugins_tokyotyrant? ( net-misc/tokyotyrant )
+ collectd_plugins_varnish? ( www-servers/varnish )
+ collectd_plugins_virt? ( app-emulation/libvirt dev-libs/libxml2 )
+ collectd_plugins_write_http? ( net-misc/curl )
+ collectd_plugins_write_mongodb? ( dev-libs/mongo-c-driver:= )
+ collectd_plugins_write_redis? ( dev-libs/hiredis:= )
+
+ kernel_FreeBSD? (
+ collectd_plugins_disk? ( sys-libs/libstatgrab:= )
+ collectd_plugins_interface? ( sys-libs/libstatgrab:= )
+ collectd_plugins_load? ( sys-libs/libstatgrab:= )
+ collectd_plugins_memory? ( sys-libs/libstatgrab:= )
+ collectd_plugins_swap? ( sys-libs/libstatgrab:= )
+ collectd_plugins_users? ( sys-libs/libstatgrab:= )
+ )"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ collectd_plugins_java? ( >=virtual/jdk-1.6 )
+ kernel_linux? (
+ collectd_plugins_vserver? ( sys-kernel/vserver-sources )
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ collectd_plugins_java? ( >=virtual/jre-1.6 )
+ collectd_plugins_syslog? ( virtual/logger )
+ selinux? ( sec-policy/selinux-collectd )"
+
+REQUIRED_USE="
+ collectd_plugins_python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.4.1"-{libocci,lt}.patch
+ "${FILESDIR}/${PN}-4.10.3"-werror.patch
+)
+
+# @FUNCTION: collectd_plugin_kernel_linux
+# @DESCRIPTION:
+# USAGE: <plug-in name> <kernel_options> <severity>
+# kernel_options is a list of kernel configurations options; the check tests whether at least
+# one of them is enabled. If no, depending on the third argument an elog, ewarn, or eerror message
+# is emitted.
+collectd_plugin_kernel_linux() {
+ local multi_opt opt
+ if has ${1} ${COLLECTD_ALL_PLUGINS}; then
+ if use collectd_plugins_${1}; then
+ for opt in ${2}; do
+ if linux_chkconfig_present ${opt}; then return 0; fi
+ done
+ multi_opt=${2//\ /\ or\ }
+ case ${3} in
+ (info)
+ elog "The ${1} plug-in can use kernel features that are disabled now; enable ${multi_opt} in your kernel"
+ ;;
+ (warn)
+ ewarn "The ${1} plug-in uses kernel features that are disabled now; enable ${multi_opt} in your kernel"
+ ;;
+ (error)
+ eerror "The ${1} plug-in needs kernel features that are disabled now; enable ${multi_opt} in your kernel"
+ ;;
+ (*)
+ die "function collectd_plugin_kernel_linux called with invalid third argument"
+ ;;
+ esac
+ fi
+ fi
+}
+
+collectd_linux_kernel_checks() {
+ linux-info_pkg_setup
+
+ # battery.c:/proc/pmu/battery_%i
+ # battery.c:/proc/acpi/battery
+ collectd_plugin_kernel_linux battery ACPI_BATTERY warn
+
+ # cgroups.c:/sys/fs/cgroup/
+ collectd_plugin_kernel_linux cgroups CONFIG_CGROUPS warn
+
+ # cpufreq.c:/sys/devices/system/cpu/cpu%d/cpufreq/
+ collectd_plugin_kernel_linux cpufreq SYSFS warn
+ collectd_plugin_kernel_linux cpufreq CPU_FREQ_STAT warn
+
+ # nfs.c:/proc/net/rpc/nfs
+ # nfs.c:/proc/net/rpc/nfsd
+ collectd_plugin_kernel_linux nfs NFS_COMMON warn
+
+ # serial.c:/proc/tty/driver/serial
+ # serial.c:/proc/tty/driver/ttyS
+ collectd_plugin_kernel_linux serial SERIAL_CORE warn
+
+ # swap.c:/proc/meminfo
+ collectd_plugin_kernel_linux swap SWAP warn
+
+ # thermal.c:/proc/acpi/thermal_zone
+ # thermal.c:/sys/class/thermal
+ collectd_plugin_kernel_linux thermal "PROC_FS SYSFS" warn
+ collectd_plugin_kernel_linux thermal ACPI_THERMAL warn
+
+ # vmem.c:/proc/vmstat
+ collectd_plugin_kernel_linux vmem VM_EVENT_COUNTERS warn
+
+ # uuid.c:/sys/hypervisor/uuid
+ collectd_plugin_kernel_linux uuid SYSFS info
+
+ # wireless.c:/proc/net/wireless
+ collectd_plugin_kernel_linux wireless "MAC80211 IEEE80211" warn
+}
+
+pkg_setup() {
+ if use kernel_linux; then
+ if linux_config_exists; then
+ einfo "Checking your linux kernel configuration:"
+ collectd_linux_kernel_checks
+ else
+ elog "Cannot find a linux kernel configuration. Continuing anyway."
+ fi
+ fi
+
+ java-pkg-opt-2_pkg_setup
+ use collectd_plugins_python && python-single-r1_pkg_setup
+
+ enewgroup collectd
+ enewuser collectd -1 -1 /var/lib/collectd collectd
+}
+
+src_prepare() {
+ default
+ epatch_user
+
+ # There's some strange prefix handling in the default config file, resulting in
+ # paths like "/usr/var/..."
+ sed -i -e "s:@prefix@/var:/var:g" src/collectd.conf.in || die
+
+ sed -i -e "s:/etc/collectd/collectd.conf:/etc/collectd.conf:g" contrib/collectd.service || die
+
+ # fix installdirs for perl, bug 444360
+ sed -i -e 's/INSTALL_BASE=$(DESTDIR)$(prefix) //' bindings/Makefile.am || die
+
+ if use collectd_plugins_java; then
+ # Set javac -source and -target flags according to (R)DEPEND.
+ sed -i -e "s/\$(JAVAC)/\0 $(java-pkg_javac-args)/g" bindings/java/Makefile.am || die
+ fi
+
+ rm -r libltdl || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # Now come the lists of os-dependent plugins. Any plugin that is not listed anywhere here
+ # should work independent of the operating system.
+
+ local linux_plugins="barometer battery cpu cpufreq disk drbd entropy
+ ethstat interface iptables ipvs irq ipc load memory md netlink nfs
+ numa processes serial swap tcpconns thermal turbostat users vmem
+ vserver wireless zfs_arc"
+
+ local libstatgrab_plugins="cpu disk interface load memory swap users"
+ local bsd_plugins="cpu tcpconns ${libstatgrab_plugins} zfs_arc"
+
+ local darwin_plugins="apple_sensors battery cpu disk interface memory processes tcpconns"
+
+ local osdependent_plugins="${linux_plugins} ${bsd_plugins} ${darwin_plugins}"
+ local myos_plugins=""
+ if use kernel_linux; then
+ einfo "Enabling Linux plugins."
+ myos_plugins=${linux_plugins}
+ elif use kernel_FreeBSD; then
+ einfo "Enabling FreeBSD plugins."
+ myos_plugins=${bsd_plugins}
+ elif use kernel_Darwin; then
+ einfo "Enabling Darwin plugins."
+ myos_plugins=${darwin_plugins}
+ fi
+
+ # Do we debug?
+ local myconf="$(use_enable debug)"
+
+ local plugin
+
+ # Disable what needs to be disabled.
+ for plugin in ${COLLECTD_DISABLED_PLUGINS}; do
+ myconf+=" --disable-${plugin}"
+ done
+
+ # Set enable/disable for each single plugin.
+ for plugin in ${COLLECTD_ALL_PLUGINS}; do
+ if has ${plugin} ${osdependent_plugins}; then
+ # plugin is os-dependent ...
+ if has ${plugin} ${myos_plugins}; then
+ # ... and available in this os
+ myconf+=" $(use_enable collectd_plugins_${plugin} ${plugin})"
+ else
+ # ... and NOT available in this os
+ if use collectd_plugins_${plugin}; then
+ ewarn "You try to enable the ${plugin} plugin, but it is not available for this"
+ ewarn "kernel. Disabling it automatically."
+ fi
+ myconf+=" --disable-${plugin}"
+ fi
+ elif [[ "${plugin}" = "collectd_plugins_perl" ]]; then
+ if use collectd_plugins_perl && ! use perl; then
+ ewarn "Perl plugin disabled as perl bindings disabled by -perl use flag"
+ myconf+= --disable-perl
+ else
+ myconf+=" $(use_enable collectd_plugins_${plugin} ${plugin})"
+ fi
+ else
+ myconf+=" $(use_enable collectd_plugins_${plugin} ${plugin})"
+ fi
+ done
+
+ # JAVA_HOME is set by eclasses.
+ if use collectd_plugins_java; then
+ myconf+=" --with-java"
+ fi
+
+ # Need libiptc ONLY for iptables. If we try to use it otherwise bug 340109 happens.
+ # lots of libs are only needed for plugins, if they are disabled, also disable the lib
+ use collectd_plugins_iptables || myconf+=" --with-libiptc=no"
+ use collectd_plugins_openldap || myconf+=" --with-libldap=no"
+ use collectd_plugins_redis || use collectd_plugins_write_redis || myconf+=" --with-libhiredis=no"
+ use collectd_plugins_smart || myconf+=" --with-libatasmart=no"
+ use collectd_plugins_virt || myconf+=" --with-libvirt=no"
+
+ if use perl; then
+ myconf+=" --with-perl-bindings=INSTALLDIRS=vendor"
+ else
+ myconf+=" --without-perl-bindings"
+ fi
+
+ # No need for v5upgrade
+ myconf+=" --disable-target_v5upgrade"
+
+ # Finally, run econf.
+ KERNEL_DIR="${KERNEL_DIR}" econf --config-cache --without-included-ltdl $(use_enable static-libs static) --localstatedir=/var ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ perl_delete_localpod
+
+ find "${D}/usr/" -name "*.la" -exec rm -f {} + || die
+
+ use collectd_plugins_java && java-pkg_regjar "${ED}"/usr/share/${PN}/java/*.jar
+
+ fowners root:collectd /etc/collectd.conf
+ fperms u=rw,g=r,o= /etc/collectd.conf
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use contrib ; then
+ insinto /usr/share/doc/${PF}
+ doins -r contrib
+ fi
+
+ keepdir /var/lib/${PN}
+ fowners collectd:collectd /var/lib/${PN}
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ systemd_dounit "contrib/${PN}.service"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate" collectd
+
+ sed -i -e 's:^.*PIDFile "/var/run/collectd.pid":PIDFile "/var/run/collectd/collectd.pid":' "${D}"/etc/collectd.conf || die
+ sed -i -e 's:^# SocketFile "/var/run/collectd-unixsock":# SocketFile "/var/run/collectd/collectd-unixsock":' "${D}"/etc/collectd.conf || die
+ sed -i -e 's:^.*LoadPlugin perl$:# The new, correct way to load the perl plugin -- \n# <LoadPlugin perl>\n# Globals true\n# </LoadPlugin>:' "${D}"/etc/collectd.conf || die
+ sed -i -e 's:^.*LoadPlugin python$:# The new, correct way to load the python plugin -- \n# <LoadPlugin python>\n# Globals true\n# </LoadPlugin>:' "${D}"/etc/collectd.conf || die
+}
+
+collectd_rdeps() {
+ if (use collectd_plugins_${1} && ! has_version "${2}"); then
+ elog "The ${1} plug-in needs ${2} to be installed locally or remotely to work."
+ fi
+}
+
+pkg_postinst() {
+ use collectd_plugins_ping && fcaps cap_net_raw usr/sbin/collectd
+
+ collectd_rdeps apcups sys-power/apcupsd
+ collectd_rdeps hddtemp app-admin/hddtemp
+ collectd_rdeps mbmon sys-apps/xmbmon
+ collectd_rdeps memcached ">=net-misc/memcached-1.2.2-r2"
+ collectd_rdeps ntpd net-misc/ntp
+ collectd_rdeps openvpn ">=net-misc/openvpn-2.0.9"
+ collectd_rdeps write_mongodb "dev-db/mongodb"
+
+ echo
+ elog "collectd is now started as unprivileged user by default."
+ elog "You may want to revisit the configuration."
+ elog
+
+ if use collectd_plugins_email; then
+ ewarn "The email plug-in is deprecated. To submit statistics please use the unixsock plugin."
+ fi
+ if use contrib; then
+ elog "The scripts in /usr/share/doc/${PF}/collection3 for generating graphs need dev-perl/HTML-Parser,"
+ elog "dev-perl/config-general, dev-perl/regexp-common, and net-analyzer/rrdtool[perl] to be installed."
+ fi
+}
diff --git a/app-admin/collectd/metadata.xml b/app-admin/collectd/metadata.xml
index 536b2ec9cf52..1f920dde419a 100644
--- a/app-admin/collectd/metadata.xml
+++ b/app-admin/collectd/metadata.xml
@@ -15,6 +15,7 @@
<flag name='collectd_plugins_ascent'>Build the ascent input plugin (statistics about a free server for World of Warcraft)</flag>
<flag name='collectd_plugins_battery'>Build the battery input plugin (charge, current and voltage of ACPI and PMU based laptop batteries)</flag>
<flag name='collectd_plugins_bind'>Build the bind input plugin (name server and resolver statistics)</flag>
+ <flag name='collectd_plugins_ceph'>Build the plugin for <pkg>sys-cluster/ceph</pkg></flag>
<flag name='collectd_plugins_cgroups'>Build the cgroups CPU accounting collection plugin</flag>
<flag name='collectd_plugins_conntrack'>Build the conntrack input plugin (number of nf_conntrack entries)</flag>
<flag name='collectd_plugins_contextswitch'>Build the contextswitch input plugin (number of context switches done by the operating system)</flag>
@@ -28,88 +29,103 @@
<flag name='collectd_plugins_df'>Build the df input plugin (mountpoint usage)</flag>
<flag name='collectd_plugins_disk'>Build the disk input plugin (sectors read/written, number of read/write actions, average completion time of IO-operations)</flag>
<flag name='collectd_plugins_dns'>Build the dns input plugin (collects statistics of your DNS traffic on port udp/53)</flag>
+ <flag name='collectd_plugins_drbd'>Build the plugin for DRBD statistics</flag>
<flag name='collectd_plugins_email'>Build the email input plugin (opens a UNIX domain socket and starts accepting connections on that socket)</flag>
<flag name='collectd_plugins_entropy'>Build the entropy input plugin (available entropy on a system)</flag>
<flag name='collectd_plugins_ethstat'>Build the ethstat input plugin (performance statistics of Linux ethernet cards)</flag>
<flag name='collectd_plugins_exec'>Build the exec input/output plugin (executes scripts / applications and reads values back)</flag>
+ <flag name='collectd_plugins_fhcount'>Build the plugin for File handles statistics</flag>
<flag name='collectd_plugins_filecount'>Build the filecount input plugin (countd the number of files in a directory and all its subdirectories)</flag>
<flag name='collectd_plugins_fscache'>Build the fscache input plugin (information about the caching infrastructure for network file-systems etc)</flag>
<flag name='collectd_plugins_gmond'>Build the gmond input plugin (receive data from gmond, the client daemon of the Ganglia project)</flag>
<flag name='collectd_plugins_hddtemp'>Build the hddtemp input plugin (temperature of hard disks)</flag>
<flag name='collectd_plugins_interface'>Build the interface input plugin (information about traffic, packets and errors of interfaces)</flag>
- <flag name='collectd_plugins_ipmi'>Build the ipmi input plugin (read hardware sensors from servers using the Intelligent Platform Management Interface (IPMI))</flag>
- <flag name='collectd_plugins_iptables'>Build the iptables input plugin (statistics from a ip_tables based packet filter)</flag>
- <flag name='collectd_plugins_irq'>Build the irq input plugin (number of times each interrupt has been handled by the os)</flag>
- <flag name='collectd_plugins_java'>Build the java input plugin (embeds a JVM into collectd for writing plugins)</flag>
- <flag name='collectd_plugins_libvirt'>Build the libvirt input plugin (statistics about virtualized guests on a system)</flag>
- <flag name='collectd_plugins_load'>Build the load input plugin (system load)</flag>
+ <flag name='collectd_plugins_ipc'>Build the plugin for IPC statistics</flag>
+ <flag name='collectd_plugins_ipmi'>Build the ipmi input plugin (read hardware sensors from servers using the Intelligent Platform Management Interface (IPMI))</flag>
+ <flag name='collectd_plugins_iptables'>Build the iptables input plugin (statistics from a ip_tables based packet filter)</flag>
+ <flag name='collectd_plugins_irq'>Build the irq input plugin (number of times each interrupt has been handled by the os)</flag>
+ <flag name='collectd_plugins_java'>Build the java input plugin (embeds a JVM into collectd for writing plugins)</flag>
+ <flag name='collectd_plugins_libvirt'>Build the libvirt input plugin (statistics about virtualized guests on a system)</flag>
+ <flag name='collectd_plugins_load'>Build the load input plugin (system load)</flag>
+ <flag name='collectd_plugins_log_logstash'>Build the plugin for Logstash json_event compatible logging</flag>
<flag name='collectd_plugins_logfile'>Build the logfile output plugin (writes log messages to a text file)</flag>
<flag name='collectd_plugins_lvm'>Build the LVM input plugin</flag>
- <flag name='collectd_plugins_madwifi'>Build the madwifi input plugin (information about Atheros wireless LAN chipsets)</flag>
+ <flag name='collectd_plugins_madwifi'>Build the madwifi input plugin (information about Atheros wireless LAN chipsets)</flag>
<flag name='collectd_plugins_match_empty_counter'>Build the match_empty_counter filter plugin</flag>
<flag name='collectd_plugins_match_hashed'>Build the match_hashed filter plugin</flag>
<flag name='collectd_plugins_match_regex'>Build the match_regex filter plugin</flag>
<flag name='collectd_plugins_match_timediff'>Build the match_timediff filter plugin</flag>
<flag name='collectd_plugins_match_value'>Build the match_value filter plugin</flag>
- <flag name='collectd_plugins_mbmon'>Build the mbmon input plugin (information from mainboard sensors)</flag>
- <flag name='collectd_plugins_md'>Build the md input plugin (disk states in Linux md devices)</flag>
+ <flag name='collectd_plugins_mbmon'>Build the mbmon input plugin (information from mainboard sensors)</flag>
+ <flag name='collectd_plugins_md'>Build the md input plugin (disk states in Linux md devices)</flag>
<flag name='collectd_plugins_memcachec'>Build the memcachec input plugin (connects to a memcached server)</flag>
- <flag name='collectd_plugins_memcached'>Build the memcached input plugin (connects to a memcached daemon)</flag>
- <flag name='collectd_plugins_memory'>Build the memory input plugin (physical memory utilization)</flag>
- <flag name='collectd_plugins_multimeter'>Build the multimeter input plugin (reads a voltage or current from a multimeter connected to a serial bus)</flag>
- <flag name='collectd_plugins_mysql'>Build the mysql input plugin (connects to an MySQL-database and issues a SHOW STATUS command)</flag>
- <flag name='collectd_plugins_netlink'>Build the netlink input plugin (opens a netlink socket to the Linux kernel for getting statistics)</flag>
- <flag name='collectd_plugins_network'>Build the network input/output plugin (communicates with other instances of collectd)</flag>
- <flag name='collectd_plugins_nfs'>Build the nfs input plugin (usage of the Network File System)</flag>
- <flag name='collectd_plugins_nginx'>Build the nginx input plugin (number of requests handled by the nginx daemon)</flag>
+ <flag name='collectd_plugins_memcached'>Build the memcached input plugin (connects to a memcached daemon)</flag>
+ <flag name='collectd_plugins_memory'>Build the memory input plugin (physical memory utilization)</flag>
+ <flag name='collectd_plugins_multimeter'>Build the multimeter input plugin (reads a voltage or current from a multimeter connected to a serial bus)</flag>
+ <flag name='collectd_plugins_mysql'>Build the mysql input plugin (connects to an MySQL-database and issues a SHOW STATUS command)</flag>
+ <flag name='collectd_plugins_netlink'>Build the netlink input plugin (opens a netlink socket to the Linux kernel for getting statistics)</flag>
+ <flag name='collectd_plugins_network'>Build the network input/output plugin (communicates with other instances of collectd)</flag>
+ <flag name='collectd_plugins_nfs'>Build the nfs input plugin (usage of the Network File System)</flag>
+ <flag name='collectd_plugins_nginx'>Build the nginx input plugin (number of requests handled by the nginx daemon)</flag>
<flag name='collectd_plugins_notify_desktop'>Build the notify_desktop output plugin (uses libnotify to display notifications to the user)</flag>
<flag name='collectd_plugins_notify_email'>Build the notify_email output plugin (uses libESMTP to send notifications to a configured email address)</flag>
- <flag name='collectd_plugins_ntpd'>Build the ntpd input plugin (queries an NTP server)</flag>
- <flag name='collectd_plugins_numa'>Build the numa input plugin (statistics of the Linux Non-Uniform Memory Access (NUMA) subsystem)</flag>
- <flag name='collectd_plugins_nut'>Build the nut input plugin (collects UPS statistics using the Network UPS Tools)</flag>
- <flag name='collectd_plugins_oracle'>Build the oracle input plugin (SQL-queries one or more Oracle database systems)</flag>
+ <flag name='collectd_plugins_ntpd'>Build the ntpd input plugin (queries an NTP server)</flag>
+ <flag name='collectd_plugins_numa'>Build the numa input plugin (statistics of the Linux Non-Uniform Memory Access (NUMA) subsystem)</flag>
+ <flag name='collectd_plugins_nut'>Build the nut input plugin (collects UPS statistics using the Network UPS Tools)</flag>
<flag name='collectd_plugins_olsrd'>Build the olsrd input plugin (reads information about the Optimized Link State Routing daemon)</flag>
- <flag name='collectd_plugins_onewire'>Build the onewire input plugin (collects temperature information from sensors)</flag>
- <flag name='collectd_plugins_openvpn'>Build the openvpn input plugin (reads the status file printed by OpenVPN)</flag>
- <flag name='collectd_plugins_perl'>Build the perl language binding plugin (embeds a Perl interpreter into collectd for writing plugins)</flag>
- <flag name='collectd_plugins_ping'>Build the ping input plugin (measures network latency)</flag>
- <flag name='collectd_plugins_postgresql'>Build the postgresql input plugin (connects to and executes SQL statements on a PostgreSQL database)</flag>
- <flag name='collectd_plugins_powerdns'>Build the powerdns input plugin (connects to a local PowerDNS instance)</flag>
- <flag name='collectd_plugins_processes'>Build the processes input plugin (statistics about processes)</flag>
- <flag name='collectd_plugins_protocols'>Build the protocols input plugin (network protocols)</flag>
- <flag name='collectd_plugins_python'>Build the python language binding plugin (embeds a Python interpreter into collectd for writing plugins)</flag>
- <flag name='collectd_plugins_rrdcached'>Build the rrdcached input/output plugin (connects to rrdcached and submits updates for RRD files)</flag>
- <flag name='collectd_plugins_rrdtool'>Build the rrdtool output plugin (writes values to RRD-files)</flag>
+ <flag name='collectd_plugins_onewire'>Build the onewire input plugin (collects temperature information from sensors)</flag>
+ <flag name='collectd_plugins_openldap'>Build the plugin for OpenLDAP statistics</flag>
+ <flag name='collectd_plugins_openvpn'>Build the openvpn input plugin (reads the status file printed by OpenVPN)</flag>
+ <flag name='collectd_plugins_oracle'>Build the oracle input plugin (SQL-queries one or more Oracle database systems)</flag>
+ <flag name='collectd_plugins_perl'>Build the perl language binding plugin (embeds a Perl interpreter into collectd for writing plugins)</flag>
+ <flag name='collectd_plugins_ping'>Build the ping input plugin (measures network latency)</flag>
+ <flag name='collectd_plugins_postgresql'>Build the postgresql input plugin (connects to and executes SQL statements on a PostgreSQL database)</flag>
+ <flag name='collectd_plugins_powerdns'>Build the powerdns input plugin (connects to a local PowerDNS instance)</flag>
+ <flag name='collectd_plugins_processes'>Build the processes input plugin (statistics about processes)</flag>
+ <flag name='collectd_plugins_protocols'>Build the protocols input plugin (network protocols)</flag>
+ <flag name='collectd_plugins_python'>Build the python language binding plugin (embeds a Python interpreter into collectd for writing plugins)</flag>
+ <flag name='collectd_plugins_redis'>Build the Redis input plugin</flag>
<flag name='collectd_plugins_routeros'>Build the routeros input plugin (collect information on devices running RouterOS)</flag>
- <flag name='collectd_plugins_sensors'>Build the sensors input plugin (uses lm-sensors to read hardware sensors)</flag>
- <flag name='collectd_plugins_serial'>Build the serial input plugin (collects the traffic on serial interfaces)</flag>
- <flag name='collectd_plugins_snmp'>Build the snmp input plugin (read values from network devices using SNMP)</flag>
+ <flag name='collectd_plugins_rrdcached'>Build the rrdcached input/output plugin (connects to rrdcached and submits updates for RRD files)</flag>
+ <flag name='collectd_plugins_rrdtool'>Build the rrdtool output plugin (writes values to RRD-files)</flag>
+ <flag name='collectd_plugins_sensors'>Build the sensors input plugin (uses lm-sensors to read hardware sensors)</flag>
+ <flag name='collectd_plugins_serial'>Build the serial input plugin (collects the traffic on serial interfaces)</flag>
+ <flag name='collectd_plugins_smart'>Build the plugin for SMART statistics</flag>
+ <flag name='collectd_plugins_snmp'>Build the snmp input plugin (read values from network devices using SNMP)</flag>
<flag name='collectd_plugins_statsd'>Build the statsd input plugin (accepts statsd-type metrics from a UDP socket)</flag>
- <flag name='collectd_plugins_swap'>Build the swap input plugin (amount of memory currently written to swap)</flag>
+ <flag name='collectd_plugins_swap'>Build the swap input plugin (amount of memory currently written to swap)</flag>
<flag name='collectd_plugins_syslog'>Build the syslog output plugin (receives messages from collectd and dispatches them to syslog)</flag>
- <flag name='collectd_plugins_table'>Build the table input plugin (parses table-like structured plain text)</flag>
- <flag name='collectd_plugins_tail'>Build the tail input plugin (follows logfiles as e.g. tail -f)</flag>
+ <flag name='collectd_plugins_table'>Build the table input plugin (parses table-like structured plain text)</flag>
+ <flag name='collectd_plugins_tail'>Build the tail input plugin (follows logfiles as e.g. tail -f)</flag>
<flag name='collectd_plugins_target_notification'>Build the target_notification filter plugin</flag>
<flag name='collectd_plugins_target_replace'>Build the target_replace filter plugin</flag>
<flag name='collectd_plugins_target_scale'>Build the target_scale filter plugin</flag>
<flag name='collectd_plugins_target_set'>Build the target_set filter plugin</flag>
- <flag name='collectd_plugins_tcpconns'>Build the tcpconns input plugin (number of TCP connections to or from a specified port)</flag>
- <flag name='collectd_plugins_teamspeak2'>Build the teamspeak2 input plugin (collects traffic statistics from a teamspeak2 instance)</flag>
- <flag name='collectd_plugins_ted'>Build the ted input plugin (connects to The Energy Detective and reads the current power over connected power lines)</flag>
+ <flag name='collectd_plugins_tcpconns'>Build the tcpconns input plugin (number of TCP connections to or from a specified port)</flag>
+ <flag name='collectd_plugins_teamspeak2'>Build the teamspeak2 input plugin (collects traffic statistics from a teamspeak2 instance)</flag>
+ <flag name='collectd_plugins_ted'>Build the ted input plugin (connects to The Energy Detective and reads the current power over connected power lines)</flag>
<flag name='collectd_plugins_thermal'>Build the thermal input plugin (ACPI thermal zone information)</flag>
<flag name='collectd_plugins_threshold'>Build the threshold plugin (checks values against configured thresholds and creates notifications if values are out of bounds)</flag>
- <flag name='collectd_plugins_tokyotyrant'>Build the tokyotyrant input plugin (number of records and file size from a running Tokyo Tyrant server)</flag>
- <flag name='collectd_plugins_uptime'>Build the uptime input plugin (system uptime)</flag>
+ <flag name='collectd_plugins_tokyotyrant'>Build the tokyotyrant input plugin (number of records and file size from a running Tokyo Tyrant server)</flag>
+ <flag name='collectd_plugins_turbostat'>Build the plugin for Advanced statistic on Intel cpu states</flag>
<flag name='collectd_plugins_unixsock'>Build the unixsock output plugin (opens a UNIX domain socket and accepts connections)</flag>
- <flag name='collectd_plugins_users'>Build the users input plugin (number of users currently logged in)</flag>
+ <flag name='collectd_plugins_uptime'>Build the uptime input plugin (system uptime)</flag>
+ <flag name='collectd_plugins_users'>Build the users input plugin (number of users currently logged in)</flag>
<flag name='collectd_plugins_uuid'>Build the uuid plugin (tries hard to determine the UUID of the system it is running on)</flag>
- <flag name='collectd_plugins_varnish'>Build the varnish input plugin</flag>
- <flag name='collectd_plugins_vmem'>Build the vmem input plugin (information about the virtual memory subsystem)</flag>
- <flag name='collectd_plugins_vserver'>Build the vserver input plugin (virtual servers running on a system)</flag>
- <flag name='collectd_plugins_wireless'>Build the wireless input plugin (signal quality, signal power and signal-to-noise ratio for wireless LAN cards)</flag>
+ <flag name='collectd_plugins_varnish'>Build the varnish input plugin</flag>
+ <flag name='collectd_plugins_virt'>Build the libvirt input plugin (statistics about virtualized guests on a system)</flag>
+ <flag name='collectd_plugins_vmem'>Build the vmem input plugin (information about the virtual memory subsystem)</flag>
+ <flag name='collectd_plugins_vserver'>Build the vserver input plugin (virtual servers running on a system)</flag>
+ <flag name='collectd_plugins_wireless'>Build the wireless input plugin (signal quality, signal power and signal-to-noise ratio for wireless LAN cards)</flag>
<flag name='collectd_plugins_write_graphite'>Build the write_graphite output plugin (sends the values collected by collectd to Carbon, the storage layer of the Graphite time-series database)</flag>
<flag name='collectd_plugins_write_http'>Build the write_http output plugin (sends the values collected by collectd to a web-server)</flag>
+ <flag name='collectd_plugins_write_log'>Build the Log output plugin</flag>
<flag name='collectd_plugins_write_mongodb'>Build the write_mongodb output plugin (sends the values collected by collectd to a MongoDB)</flag>
+ <flag name='collectd_plugins_write_redis'>Build the Redis output plugin</flag>
+ <flag name='collectd_plugins_write_sensu'>Build the Sensu output plugin</flag>
+ <flag name='collectd_plugins_write_tsdb'>Build the TSDB output plugin</flag>
+ <flag name='collectd_plugins_zfs_arc'>Build the plugin for ZFS ARC statistics</flag>
+ <flag name='collectd_plugins_zookeeper'>Build the plugin for Zookeeper statistics</flag>
<flag name='contrib'>Install user-contributed files in the doc directory</flag>
</use>
</pkgmetadata>