summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-05 15:12:34 +0100
committerSam James <sam@gentoo.org>2022-10-05 16:44:46 +0100
commit25868abde2571e793d7b63eb828b52e1bf1f11af (patch)
tree5b10ff8aa4b3ec0b7a99345d9031ad85ef4b6c5b /app-admin/augeas/augeas-1.13.0.ebuild
parentapp-editors/emacs: Depend on x11-libs/cairo[X] (diff)
downloadgentoo-25868abde2571e793d7b63eb828b52e1bf1f11af.tar.gz
gentoo-25868abde2571e793d7b63eb828b52e1bf1f11af.tar.bz2
gentoo-25868abde2571e793d7b63eb828b52e1bf1f11af.zip
app-admin/augeas: add 1.13.0
Closes: https://bugs.gentoo.org/833352 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/augeas/augeas-1.13.0.ebuild')
-rw-r--r--app-admin/augeas/augeas-1.13.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/augeas/augeas-1.13.0.ebuild b/app-admin/augeas/augeas-1.13.0.ebuild
new file mode 100644
index 000000000000..b471ac9f4b88
--- /dev/null
+++ b/app-admin/augeas/augeas-1.13.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="https://github.com/hercules-team/augeas/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=app-doc/NaturalDocs-1.40
+ virtual/pkgconfig
+ test? ( dev-lang/ruby )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-selinux.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # selinux needs to be implemented
+ econf --without-selinux
+}
+
+src_compile() {
+ addpredict /usr/share/NaturalDocs/Config/Languages.txt
+ addpredict /usr/share/NaturalDocs/Config/Topics.txt
+
+ default
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}