summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-05-03 11:27:21 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-05-03 11:27:21 -0700
commit6b7092f39da47ff789915ae264373ddd59a5b72a (patch)
treec0c6d370e7351e0bcfba6e9e60e15c0e4da6bc67 /app-admin/ansible-modules-hashivault
parentdev-python/pygments-github-lexers: Revbump, eapi8, py311 (diff)
downloadgentoo-6b7092f39da47ff789915ae264373ddd59a5b72a.tar.gz
gentoo-6b7092f39da47ff789915ae264373ddd59a5b72a.tar.bz2
gentoo-6b7092f39da47ff789915ae264373ddd59a5b72a.zip
app-admin/ansible-modules-hashivault: add 5.1.0
Closes: https://bugs.gentoo.org/896458 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-admin/ansible-modules-hashivault')
-rw-r--r--app-admin/ansible-modules-hashivault/Manifest1
-rw-r--r--app-admin/ansible-modules-hashivault/ansible-modules-hashivault-5.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/ansible-modules-hashivault/Manifest b/app-admin/ansible-modules-hashivault/Manifest
index 9c81fc6469bf..dd593c9ebb12 100644
--- a/app-admin/ansible-modules-hashivault/Manifest
+++ b/app-admin/ansible-modules-hashivault/Manifest
@@ -1 +1,2 @@
DIST ansible-modules-hashivault-4.6.8.tar.gz 94253 BLAKE2B 2b6a315cfd051a2e16d889a8784a9185b86b98b3d96ba19f6bdde8b628ce94622c360b60cb59dfcae790fc822f2c41eacd5428356b48324aa2704f0048821c2d SHA512 4b3487e553e6dea5fbefbb383ce22d018ed9f83378d601574badfb2be8dd3f98c54caf975690d3116df6cca970d8e2d3932f0d0ccb1f18f7145aee0beae79f96
+DIST ansible-modules-hashivault-5.1.0.gh.tar.gz 100025 BLAKE2B 6bedb1269a5f39be777ab24e973a52a708d5871cf99f6e7018caa703bc4e8222fec9a40b6b5b980c67e2574034511fe810cba656278336dce0ca3b52f880bcb6 SHA512 cc442a80a4a15e013352202912af6db889afe793aa5baebd8056312eea42c7a819fdae32c9199ec297b9c4aa30719017bff964934d7f94571f368996328619ab
diff --git a/app-admin/ansible-modules-hashivault/ansible-modules-hashivault-5.1.0.ebuild b/app-admin/ansible-modules-hashivault/ansible-modules-hashivault-5.1.0.ebuild
new file mode 100644
index 000000000000..ac39347ecb46
--- /dev/null
+++ b/app-admin/ansible-modules-hashivault/ansible-modules-hashivault-5.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Ansible module for hashicorp vault"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/TerryHowe/ansible-modules-hashivault.git"
+else
+ SRC_URI="https://github.com/TerryHowe/ansible-modules-hashivault/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-admin/ansible-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hvac-1.0.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+# The tests require a private instance of vault
+RESTRICT="test"
+
+python_prepare_all() {
+ sed -i 's:description-file:description_file:' setup.cfg || die
+ distutils-r1_python_prepare_all
+}