summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-03 05:54:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-03 05:54:07 +0200
commitff4b89e48b16af47372a4c9a2b0f0c7eb5a6ef94 (patch)
tree277e65d0e1575f4cea24bbcf81f569c7e03ddeb4
parentdev-libs/openssl: update SRC_URI for latest releases (3.1.6/3.2.2/3.3.1) (diff)
downloadgentoo-ff4b89e48b16af47372a4c9a2b0f0c7eb5a6ef94.tar.gz
gentoo-ff4b89e48b16af47372a4c9a2b0f0c7eb5a6ef94.tar.bz2
gentoo-ff4b89e48b16af47372a4c9a2b0f0c7eb5a6ef94.zip
dev-python/botocore: Bump to 1.34.153
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.153.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c06d6269112e..a25bcfeebefc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.34.149.gh.tar.gz 13245965 BLAKE2B 6bc05c1d93eaa62fa9acb3c0e42acd
DIST botocore-1.34.150.gh.tar.gz 13246229 BLAKE2B 30b8327a8095afd514d320152b1e8088f95434805ed50704dc0304a1532a89ec9e040f98020b9bb0b2ef88a63eefed4925776f4bddf8d7c7214b6e51c7cc2c87 SHA512 1a05dd42cd0b9290c639a49457c33c02cb32d3055525f34215c25e8fe9b02351611385d7f20b2b2e94544e54634450859df5871cc8f803db1e361ba6981ed54e
DIST botocore-1.34.151.gh.tar.gz 13250953 BLAKE2B cb60a79948546aa78610441015059573dd26ba1153570ba1fda5c9f2b53488f48aa47c7b3f98323b47b143ef8cd429c0841458690f9d9bac6703dbce886454b8 SHA512 6b50ce628eb79b7a9167037d1b24cddcadd0d291ceb2bf47ba3ae90c643d77bc6aa236fa2f14605842ff1b36feee905884f6b4c5ca8e22da2a2b9d7deaf7cc4c
DIST botocore-1.34.152.gh.tar.gz 13265722 BLAKE2B 66fba18919f4a3ef3bc7680188ff154064fb06189f8ad018ac594836846064545adfcc5a40c01bc071930f8a3574dc9a21e8b944e1f7d6f2dcec464c38f59f22 SHA512 8661193d0ded3c311827193e80cbd9cf717030b662b677c53ef4cdebc748f0a26d6ec94cdb475cca0aacd09490ea165627927c7eee511feccb71a806b489844a
+DIST botocore-1.34.153.gh.tar.gz 13269606 BLAKE2B 1b2ec1af3b699c18c5761fe72b8488361f843e1b2abc5f311736e7c93a52574738a8e72708791657d0d86586d64ee3c85804514779c6dc75c6c2e37035517be1 SHA512 9a7b3359f4304bcb4d3605e2516514360e8898d7b8b1fdee8fab5dc6026a7d8197b09199da4e9aefcf1ab0b094a2e0e336ad13942ce0364f7b5ac87d86fdc4fd
diff --git a/dev-python/botocore/botocore-1.34.153.ebuild b/dev-python/botocore/botocore-1.34.153.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.153.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}