summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 09:34:03 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 09:34:03 +0000
commitf5558ef3bcbf0dcbe71be4cdd1cc4d93a945087f (patch)
tree6d3d28903e28835a22e2be56fd6172cbea6a78b1
parent2024-07-15 09:19:12 UTC (diff)
parentdev-ml/opam-core: add 2.1.5 (diff)
downloadgentoo-f5558ef3bcbf0dcbe71be4cdd1cc4d93a945087f.tar.gz
gentoo-f5558ef3bcbf0dcbe71be4cdd1cc4d93a945087f.tar.bz2
gentoo-f5558ef3bcbf0dcbe71be4cdd1cc4d93a945087f.zip
Merge updates from master
-rw-r--r--dev-ml/opam-core/Manifest1
-rw-r--r--dev-ml/opam-core/opam-core-2.1.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/opam-core/Manifest b/dev-ml/opam-core/Manifest
index d28ccf8a7142..2544ddadcd36 100644
--- a/dev-ml/opam-core/Manifest
+++ b/dev-ml/opam-core/Manifest
@@ -4,3 +4,4 @@ DIST opam-2.1.0-dose3-6.patch.xz 5896 BLAKE2B f605064ebae7d327895729962a345a3c67
DIST opam-2.1.2.tar.gz 818848 BLAKE2B ffb50f3cf1421aa9bff6877d636a3d1d1cc2c2e3961ecd60fcae8a35b069c8d22e7a36bf17cb8166533621a3c85a82195fd3fa646b2fd8dcea9e626b61d5b86c SHA512 bea6f75728a6ef25bcae4f8903dde7a297df7186208dccacb3f58bd6a0caec551c11b79e8544f0983feac038971dbe49481fc405a5962973a5f56ec811abe396
DIST opam-2.1.3.tar.gz 832450 BLAKE2B c5e50c0a41b7197bc7645eaef0d8cba79c978b4432fc824aa6a4280df65ec7d59df52a22b76877da4949c8562a5fecb8da2a179ca67bd312bf9a514961bf4444 SHA512 040e4f58f93e962ff422617ce0d35ed45dd86921a9aac3505914c33dd942d0e5e5771e7e1774046504f9aa84f32bc4fbd6ac7720fbea862d48bf1ca29e02cefc
DIST opam-2.1.4.tar.gz 833495 BLAKE2B 1969546d9cba34d33bdff221e7de0d974380c238a7b8671159c06ae55081e0ab0019d7dc27e9fefc908efc58a2f39f3b28ed11b68827743345ba721a2123ef5b SHA512 276fdbe4e114a0d23b9d4b7938d87bf39c06b4716fae601588da7d5d2d5d9b5c584855d96edfed2eb5ac8a36ee9431c4ea7d281c52acdab28b9a3bdcbf10ce57
+DIST opam-2.1.5.tar.gz 837005 BLAKE2B f2e58784959f0e47fbe5ae65112a030d8350b061d7b0d2676f40e22ec5bf62c136bc37fd3078403dab807705ce8a1c8b6bb0ecf00b68fdfbb5f3d5a9acb88c77 SHA512 4395defe7df1d03ca889718b8eafd8161ff009710475f62673f19f012e0bde8ad2a919bd9d02d7f96b4c5a9bbf38e0ba9a256531c24de15cafabd4ef11f7c8e8
diff --git a/dev-ml/opam-core/opam-core-2.1.5.ebuild b/dev-ml/opam-core/opam-core-2.1.5.ebuild
new file mode 100644
index 000000000000..0d41c1a9eb72
--- /dev/null
+++ b/dev-ml/opam-core/opam-core-2.1.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+inherit opam
+
+DESCRIPTION="Core libraries for opam"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-ml/ocamlgraph:=
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+ dev-ml/cmdliner:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9)))
+ (release
+ (flags (:standard -warn-error -3-9))))
+ EOF
+
+ # HACK: Probably bug in Makefile? Magic. See: https://bugs.gentoo.org/933845
+ touch opam-installer.install || die
+}
+
+src_compile() {
+ emake -j1 opam-installer
+ emake -j1 ${PN}.install
+}