summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-03-19 20:27:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-03-19 20:46:11 -0500
commitf139fd03948623b4d539c1cb2d8a8053b6caccf3 (patch)
tree4d67e76e2d3419b48232a10c4aa5020abc9e6e6f
parentdev-python/entrypoints: adding arm keyword for dev-python/keyring (diff)
downloadgentoo-f139fd03948623b4d539c1cb2d8a8053b6caccf3.tar.gz
gentoo-f139fd03948623b4d539c1cb2d8a8053b6caccf3.tar.bz2
gentoo-f139fd03948623b4d539c1cb2d8a8053b6caccf3.zip
dev-python/keyring: 11.1.0 and 12.0.0 bup
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-python/keyring/Manifest2
-rw-r--r--dev-python/keyring/keyring-11.1.0.ebuild40
-rw-r--r--dev-python/keyring/keyring-12.0.0.ebuild40
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 77a13cdd2af0..a01b80785667 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1,2 +1,4 @@
DIST keyring-10.6.0.tar.gz 40782 BLAKE2B acd327711a8f7deb08d172000294d5f104e2d01b65dc7412fa8ceec1c24405206982af04e75da0dfdb7a224a4f8c9ad6f8d5f37106e68eb1add637d7d5027c4f SHA512 56e9c11ac6d50d22ca74f6d677eb24da876a27c84501d8be4ad0cee44356a67213a7d255e0fdab1343411b75b55e9ab50210d0ae95879ae9f3acb8cbe73f9848
DIST keyring-11.0.0.tar.gz 40883 BLAKE2B 50ce8bf1265899a3054edf2fabef75694190e06e83a56b5de8e76b3d6c4ea460971d74c1a03d936765914d3b2a1812836bb56363911b706d20d59c158e8478f2 SHA512 d4937e84e6de18ed8fcba02d2d297ecc5a6434623c362f5608141041acbc7bc27fbf94e54a5a503a02b725df737fa8505d0d91e2c3e84298fa4044d7dc99f207
+DIST keyring-11.1.0.tar.gz 25518 BLAKE2B 8b23853a15217a4d51a30d2add4f2e4eaa9af788c37fbb821bde69081d120f4a81560d2165b067b3eb299903a35d0316d944c3889c312745609085bb6ce29cec SHA512 3fb099f8a72c705ad1e2387b67ca3b9bf18615f9253e589bc8996e3b31db4b295a925ff95ef52da861e94ecf10d080db93bde1a7420e8de12448220abe2e016e
+DIST keyring-12.0.0.tar.gz 25387 BLAKE2B 701a7c7c66761f7d096229a61ccc53b26ae0a5fcd48d62c1109aba908b83a8a0f273bacf25dc182bece1bc907a8ded6765e7d28abdf1c5aefccb37b2c9a1f1b8 SHA512 1d9a00aced4d3116eec4483513911ce338900742c005215edaa91df1839495cd102cd7454a1cf5f4a501698866efdb26cb6c5bf551cb1cb4951f1e485371fbe0
diff --git a/dev-python/keyring/keyring-11.1.0.ebuild b/dev-python/keyring/keyring-11.1.0.ebuild
new file mode 100644
index 000000000000..0dc334c090f0
--- /dev/null
+++ b/dev-python/keyring/keyring-11.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="mirror://pypi/k/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-flake8[${PYTHON_USEDEP}]
+ dev-python/collective-checkdocs[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+src_unpack() {
+ unpack $A
+ # This is an interactive test.
+ rm -f "${S}"/keyring/tests/backends/test_kwallet.py
+}
+
+python_test() {
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}
diff --git a/dev-python/keyring/keyring-12.0.0.ebuild b/dev-python/keyring/keyring-12.0.0.ebuild
new file mode 100644
index 000000000000..0dc334c090f0
--- /dev/null
+++ b/dev-python/keyring/keyring-12.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="mirror://pypi/k/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-flake8[${PYTHON_USEDEP}]
+ dev-python/collective-checkdocs[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+src_unpack() {
+ unpack $A
+ # This is an interactive test.
+ rm -f "${S}"/keyring/tests/backends/test_kwallet.py
+}
+
+python_test() {
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}