summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 05:55:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 07:21:14 +0100
commitee6ac6e0c8790851f72d80e701c2398473a2002c (patch)
treed7587df8db3b6ff19f43bf0118c84b33e7c6309b
parentdev-python/boto3: Bump to 1.26.73 (diff)
downloadgentoo-ee6ac6e0c8790851f72d80e701c2398473a2002c.tar.gz
gentoo-ee6ac6e0c8790851f72d80e701c2398473a2002c.tar.bz2
gentoo-ee6ac6e0c8790851f72d80e701c2398473a2002c.zip
app-admin/awscli: Bump to 1.27.73
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.73.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 3c6013981452..2204fd5dbad3 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.27.69.gh.tar.gz 2366011 BLAKE2B e2ac484bb6ead107d0deca6bad5b9ca4a
DIST aws-cli-1.27.70.gh.tar.gz 2366135 BLAKE2B f8feedc28ff2b94326ea81ef1c38779c709ca88033c6f36a31dd28659f9f7cfe2fe520dcf39c46534e5d91e48877e0901e212fc3316effe3e0dc5b0c4855c47d SHA512 faae6ea80047736d99d16cc652b43c4b34fe70822c3aa5a59c8c505a79bbc8b573c4b875f8551c934f20119f0ac2a4ea86a0d91614d5a3871b32a2ea0cc9139c
DIST aws-cli-1.27.71.gh.tar.gz 2366507 BLAKE2B e01193919c0f78a8e1ea0e12a2fb7c454604553d1c3d86d42aa120ba7f31f9d3e1f8cfe602da5f575a589181643ff895e2dd99b4d5dd73c2eeade1ce956c6e33 SHA512 428ca6198d13764968f50a29f38904419401f4f807bcd09a9c8e5bae62410acb1e4929acb8a3a8ff255ab21eecd78b6a68b46dc95f1f3c514a44ed13c57a6805
DIST aws-cli-1.27.72.gh.tar.gz 2367270 BLAKE2B e1df31c226a98a7f8241bac33bea402024ea7975de1d3c34e3ae2c971b4386ecd772617cdb803ac3569238ed623b7c8a11c3cdaf642d82aad89421b2f067f782 SHA512 54aaa158dd4832eeac20781a2f2c8e62123753a5b7d7273b7d1e33188d30a4c0a0991d9a7b49ebca7f682944e9fcd523412c5f6c47146c52400374d52d2524b8
+DIST aws-cli-1.27.73.gh.tar.gz 2368610 BLAKE2B 6e0a157be8eb2e87da5ca2631a955049c6a9ff35da0beb3a62b14a77b3f14cf1d91f84d77e1339dcd4ad6d5c168492c37ae41eda3175ceda7f782080c12ab9a1 SHA512 4c65581ef1bad7d063f4f3ce51b21e63aec724da707e6bc506afdd977da2c6d13501b231698acd1e677b8f0ad7133f127680b42a0b008ac0cea1aa1ca1b1d833
diff --git a/app-admin/awscli/awscli-1.27.73.ebuild b/app-admin/awscli/awscli-1.27.73.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.73.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}