summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-14 01:52:12 +0000
committerSam James <sam@gentoo.org>2022-05-14 01:52:12 +0000
commitea1b9408e8f6b22c0a1a92f0c3612008a1ea4475 (patch)
tree8503a1eb3364397421a532c6deefc15cab91fe1e
parentdev-util/android-tools: fix build with GCC 12 (diff)
downloadgentoo-ea1b9408e8f6b22c0a1a92f0c3612008a1ea4475.tar.gz
gentoo-ea1b9408e8f6b22c0a1a92f0c3612008a1ea4475.tar.bz2
gentoo-ea1b9408e8f6b22c0a1a92f0c3612008a1ea4475.zip
sys-libs/glibc: add Python 3.10 to 2.34-r13
It's been long enough and there's guides on the wiki (https://wiki.gentoo.org/wiki/User:Sam/Portage_help/Circular_dependencies#Error_mentions_default_version_not_yet_installed_.28old_install.29) if folks hit a circular dependency anyway. Needed as we're moving forward to Python 3.10 default soon and this will reduce confusion. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/glibc/glibc-2.34-r13.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.35-r3.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.35-r4.ebuild2
3 files changed, 3 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.34-r13.ebuild b/sys-libs/glibc/glibc-2.34-r13.ebuild
index bf7187eac062..2f9a3312f793 100644
--- a/sys-libs/glibc/glibc-2.34-r13.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r13.ebuild
@@ -6,10 +6,7 @@ EAPI=7
# Bumping notes: https://wiki.gentoo.org/wiki/Project:Toolchain/sys-libs/glibc
# Please read & adapt the page as necessary if obsolete.
-# We avoid Python 3.10 here _for now_ (it does work!) to avoid circular dependencies
-# on upgrades as people migrate to libxcrypt.
-# https://wiki.gentoo.org/wiki/User:Sam/Portage_help/Circular_dependencies#Python_and_libcrypt
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
TMPFILES_OPTIONAL=1
inherit python-any-r1 prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \
diff --git a/sys-libs/glibc/glibc-2.35-r3.ebuild b/sys-libs/glibc/glibc-2.35-r3.ebuild
index 7040d0738b6a..c656b1b35881 100644
--- a/sys-libs/glibc/glibc-2.35-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.35-r3.ebuild
@@ -6,7 +6,7 @@ EAPI=7
# Bumping notes: https://wiki.gentoo.org/wiki/Project:Toolchain/sys-libs/glibc
# Please read & adapt the page as necessary if obsolete.
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
TMPFILES_OPTIONAL=1
inherit python-any-r1 prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \
diff --git a/sys-libs/glibc/glibc-2.35-r4.ebuild b/sys-libs/glibc/glibc-2.35-r4.ebuild
index c67cc3205f9f..98b8484013e6 100644
--- a/sys-libs/glibc/glibc-2.35-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.35-r4.ebuild
@@ -6,7 +6,7 @@ EAPI=7
# Bumping notes: https://wiki.gentoo.org/wiki/Project:Toolchain/sys-libs/glibc
# Please read & adapt the page as necessary if obsolete.
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
TMPFILES_OPTIONAL=1
inherit python-any-r1 prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \