summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-06-20 12:23:47 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-06-20 12:23:47 +0000
commite7e8a2ed1434314257f92a62b9a7414248105ea4 (patch)
tree0fab6da754222984a49406dd6be296e286a609dc
parent2017-06-20 12:04:46 UTC (diff)
parentsys-auth/rtkit: keyword ~arm64 (diff)
downloadgentoo-e7e8a2ed1434314257f92a62b9a7414248105ea4.tar.gz
gentoo-e7e8a2ed1434314257f92a62b9a7414248105ea4.tar.bz2
gentoo-e7e8a2ed1434314257f92a62b9a7414248105ea4.zip
Merge updates from master
-rw-r--r--dev-ml/csv/Manifest1
-rw-r--r--dev-ml/csv/csv-1.7.ebuild37
-rw-r--r--media-libs/sbc/sbc-1.3.ebuild4
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.1.4-r1.ebuild2
-rw-r--r--media-sound/pulseaudio/pulseaudio-10.0.ebuild2
-rw-r--r--net-libs/libasyncns/libasyncns-0.8-r4.ebuild4
-rw-r--r--net-misc/ofono/ofono-1.20.ebuild2
-rw-r--r--sci-libs/hdf5/hdf5-1.8.18.ebuild4
-rw-r--r--sci-libs/libaec/libaec-1.0.0.ebuild2
-rw-r--r--sci-libs/szip/szip-2.1-r2.ebuild4
-rw-r--r--sys-auth/rtkit/rtkit-0.11-r2.ebuild4
-rw-r--r--virtual/szip/szip-2.1.ebuild2
12 files changed, 53 insertions, 15 deletions
diff --git a/dev-ml/csv/Manifest b/dev-ml/csv/Manifest
index 2723145ddfb1..486c7cc99784 100644
--- a/dev-ml/csv/Manifest
+++ b/dev-ml/csv/Manifest
@@ -1,2 +1,3 @@
DIST csv-1.5.tar.gz 83642 SHA256 f6307634e5f5fe3d64b90fdf8841b3f50dac80ed45b40d390ee44490c62bf58f SHA512 1c8af0ce8abd8a5710115c194eee34928399964447309ee974665cf427396def42bca4f983904bfec706f7944aea419a87bf54bc6c379cb8b7372be801be4126 WHIRLPOOL fe39114b74cb12b382da64307b8253297614f537ef4309cdcec58e9ec68ff49791d6ef90b4870200f24f6726471ceb925d0a79336853c27769af07413a3c373d
DIST csv-1.6.tar.gz 98194 SHA256 f217f00a397aa79bcd3f1a657a04cb46d08c7d00f4c3836467dad83d08ea6767 SHA512 689dae2dd57ec914ca1dd5e3d34ebd352aabb7d5da8933aa6c6fc9c6ec84dc538d1df8a1c46f3e172ab09e5917e9158be76afb2423ec8a92eef489ac5dfd5175 WHIRLPOOL 7a9c6cbb33866e6d2e694e1d19ff8c5e9cdb5a5ad4ee2bc7252007a76a22863dda4a34bbaa45579e6487a6b25e5b8afe44e40a067af835d3aca59dac491acd20
+DIST csv-1.7.tar.gz 45160 SHA256 7f84e8b96bc0a9bdf5bfb298fcd0e652168aec7ee33634ec79b856193afd7748 SHA512 cbe3d316e6f99318b3958bbfba3308225e709afb481a333d314adb66c20683171c23ac0565fc8d8e936b9dad13b9330b5208340b9fc671b4ccddf3a7d8b82b3e WHIRLPOOL 23e0903c33d19acd9e05e53d61cad40e3af3256013f4241fa07841dce2997845abedd15198058746358f940af26f06405c8480d2676bb63096572af450bdf092
diff --git a/dev-ml/csv/csv-1.7.ebuild b/dev-ml/csv/csv-1.7.ebuild
new file mode 100644
index 000000000000..817e095edb27
--- /dev/null
+++ b/dev-ml/csv/csv-1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml library to read and write CSV files"
+HOMEPAGE="https://github.com/Chris00/ocaml-csv"
+SRC_URI="https://github.com/Chris00/ocaml-csv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt"
+
+DEPEND="lwt? ( dev-ml/lwt:= )"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/oasis"
+
+DOCS=( "README.txt" "AUTHORS.txt" )
+
+S="${WORKDIR}/ocaml-${P}"
+
+src_prepare() {
+ default
+ oasis setup || die
+}
+
+src_configure() {
+ oasis_configure_opts="$(use_enable lwt)" \
+ oasis_src_configure
+}
diff --git a/media-libs/sbc/sbc-1.3.ebuild b/media-libs/sbc/sbc-1.3.ebuild
index 1c50fea714b9..b753ddb7ee6f 100644
--- a/media-libs/sbc/sbc-1.3.ebuild
+++ b/media-libs/sbc/sbc-1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
IUSE="static-libs"
# --enable-tester is building src/sbctester but the tarball is missing required
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.1.4-r1.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.1.4-r1.ebuild
index 37c69ac49c8e..28a0efe54381 100644
--- a/media-plugins/alsa-plugins/alsa-plugins-1.1.4-r1.ebuild
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.1.4-r1.ebuild
@@ -10,7 +10,7 @@ SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
IUSE="debug ffmpeg jack libav libsamplerate pulseaudio speex"
RDEPEND="
diff --git a/media-sound/pulseaudio/pulseaudio-10.0.ebuild b/media-sound/pulseaudio/pulseaudio-10.0.ebuild
index 26090f8fd279..b0197dca3767 100644
--- a/media-sound/pulseaudio/pulseaudio-10.0.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-10.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz"
LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 ) equalizer? ( AGPL-3+ )"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
# +alsa-plugin as discussed in bug #519530
IUSE="+alsa +alsa-plugin +asyncns bluetooth +caps dbus doc equalizer +gdbm +glib
diff --git a/net-libs/libasyncns/libasyncns-0.8-r4.ebuild b/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
index c19ac52dc71a..73535f3dd2b4 100644
--- a/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
+++ b/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,7 +11,7 @@ SRC_URI="http://0pointer.de/lennart/projects/libasyncns/${P}.tar.gz"
SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
IUSE="doc debug"
diff --git a/net-misc/ofono/ofono-1.20.ebuild b/net-misc/ofono/ofono-1.20.ebuild
index af59f3820ac1..8341f7b8b2cc 100644
--- a/net-misc/ofono/ofono-1.20.ebuild
+++ b/net-misc/ofono/ofono-1.20.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem threads tools +udev upower"
REQUIRED_USE="dundee? ( bluetooth )"
diff --git a/sci-libs/hdf5/hdf5-1.8.18.ebuild b/sci-libs/hdf5/hdf5-1.8.18.ebuild
index 2ed23497e51c..4057134a614e 100644
--- a/sci-libs/hdf5/hdf5-1.8.18.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -18,7 +18,7 @@ SRC_URI="https://support.hdfgroup.org/ftp/HDF5/current18/src/${MY_P}.tar.bz2"
LICENSE="NCSA-HDF"
SLOT="0/${PV%%_p*}"
-KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="alpha amd64 ~arm ~arm64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="cxx debug examples fortran fortran2003 +hl mpi static-libs szip threads zlib"
REQUIRED_USE="
diff --git a/sci-libs/libaec/libaec-1.0.0.ebuild b/sci-libs/libaec/libaec-1.0.0.ebuild
index 313409c2af64..f1d47bb32d3f 100644
--- a/sci-libs/libaec/libaec-1.0.0.ebuild
+++ b/sci-libs/libaec/libaec-1.0.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="${HOMEPAGE}/uploads/${PID}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/2"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs +szip"
DEPEND=""
diff --git a/sci-libs/szip/szip-2.1-r2.ebuild b/sci-libs/szip/szip-2.1-r2.ebuild
index 810012aaac8a..86f9bc1b2151 100644
--- a/sci-libs/szip/szip-2.1-r2.ebuild
+++ b/sci-libs/szip/szip-2.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.hdfgroup.org/lib-external/${PN}/${PV}/src/${P}.tar.gz"
LICENSE="szip"
SLOT="0/2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="static-libs"
RDEPEND="!sci-libs/libaec[szip]"
diff --git a/sys-auth/rtkit/rtkit-0.11-r2.ebuild b/sys-auth/rtkit/rtkit-0.11-r2.ebuild
index 716b81c9bc7b..a00e0827311f 100644
--- a/sys-auth/rtkit/rtkit-0.11-r2.ebuild
+++ b/sys-auth/rtkit/rtkit-0.11-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ SRC_URI="http://0pointer.de/public/${P}.tar.xz"
LICENSE="GPL-3 BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
IUSE=""
RDEPEND="
diff --git a/virtual/szip/szip-2.1.ebuild b/virtual/szip/szip-2.1.ebuild
index b03a81798bba..5aff5031c1b0 100644
--- a/virtual/szip/szip-2.1.ebuild
+++ b/virtual/szip/szip-2.1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
DESCRIPTION="Virtual for szip compression drop-in replacements"
SLOT="0/2"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="|| (
sci-libs/libaec[szip]