summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-11-28 22:25:52 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-11-28 22:25:52 +0000
commitd775b981174b0e88d860ea5cd93092b29c2ff419 (patch)
treed74a548e15922df97963f920fb5586ab0442eedc
parent2019-11-28 22:06:22 UTC (diff)
parentwww-apps/zeppelin-bin: version bump. (diff)
downloadgentoo-d775b981174b0e88d860ea5cd93092b29c2ff419.tar.gz
gentoo-d775b981174b0e88d860ea5cd93092b29c2ff419.tar.bz2
gentoo-d775b981174b0e88d860ea5cd93092b29c2ff419.zip
Merge updates from master
-rw-r--r--app-emulation/nemu/Manifest1
-rw-r--r--app-emulation/nemu/nemu-2.2.1.ebuild73
-rw-r--r--app-shells/hstr/files/hstr-2.0-fix-ncurses-configure.patch81
-rw-r--r--app-shells/hstr/hstr-2.0.ebuild2
-rw-r--r--www-apps/zeppelin-bin/Manifest1
-rw-r--r--www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild4
-rw-r--r--www-apps/zeppelin-bin/zeppelin-bin-0.8.2.ebuild40
7 files changed, 200 insertions, 2 deletions
diff --git a/app-emulation/nemu/Manifest b/app-emulation/nemu/Manifest
index bf2b6da8d280..2655f742bf8f 100644
--- a/app-emulation/nemu/Manifest
+++ b/app-emulation/nemu/Manifest
@@ -1,2 +1,3 @@
DIST nemu-2.1.0.tar.gz 89117 BLAKE2B a44bf67990d79af0b73caf077266c4775f302ffc81d2394993da45870a72f462d487a92d63abdbe875c382d11b8d691f446a5e0b7270355770838ea86328fb1d SHA512 7e655227e22f5e2dd5ec1f77ef1635f1aaab2e57e417fb33d83d35cc67d7b802c35fa9174cf4282287213a1a825714743773260b96b452a382a8248fbef238bf
DIST nemu-2.2.0.tar.gz 94061 BLAKE2B 95304e8834f1d5c1e31065728363de5d797ae79554733dd3fecd90388b2766bc8907acfeded36676272967153eed5a7f30baba9ef2384fca67d19f3519461fa6 SHA512 2f427a560ea5ac4112b7d5cdd8524366521ca3d185676a4faa9bc480331c3381b7a362aed20025dc1acc0f576f07fb627b03137e1998926761a169c5be0eaf97
+DIST nemu-2.2.1.tar.gz 94600 BLAKE2B 16060ee1ed00f97a442d9f6b9a3f940d9777d24dea70336e382071ce7e9f7e077d58827110f4b0d64091c5777d516e95968ed0e1d4886b9fe2a3709fb466229d SHA512 e6f244c01582351f9e0f61a0a6848937a68b8d077500d0f8095784b871e9c9809bf5830c27918e84a77a64fcee3d6f81d8a06a031160f0beddc48614eb86624a
diff --git a/app-emulation/nemu/nemu-2.2.1.ebuild b/app-emulation/nemu/nemu-2.2.1.ebuild
new file mode 100644
index 000000000000..7b885f4f50c6
--- /dev/null
+++ b/app-emulation/nemu/nemu-2.2.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="ncurses interface for QEMU"
+HOMEPAGE="https://lib.void.so/nemu/ https://bitbucket.org/PascalRD/nemu/"
+SRC_URI="https://lib.void.so/src/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug network-map +ovf savevm spice +vnc-client"
+
+RDEPEND="app-emulation/qemu[vnc,virtfs,spice?]
+ dev-db/sqlite:3=
+ sys-libs/ncurses:0=[unicode]
+ virtual/libusb:1
+ virtual/libudev:=
+ network-map? ( media-gfx/graphviz )
+ ovf? (
+
+ dev-libs/libxml2:2
+ app-arch/libarchive
+
+ )
+ vnc-client? ( net-misc/tigervnc )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="sys-devel/gettext"
+
+pkg_pretend() {
+ if use kernel_linux; then
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel"
+ else
+ CONFIG_CHECK="~VETH ~MACVTAP"
+ ERROR_VETH="You will need the Virtual ethernet pair device driver compiled"
+ ERROR_VETH+=" into your kernel or loaded as a module to use the"
+ ERROR_VETH+=" local network settings feature."
+ ERROR_MACVTAP="You will also need support for MAC-VLAN based tap driver."
+
+ check_extra_config
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DNM_DEBUG=$(usex debug)
+ -DNM_WITH_NETWORK_MAP=$(usex network-map)
+ -DNM_WITH_OVF_SUPPORT=$(usex ovf)
+ -DNM_SAVEVM_SNAPSHOTS=$(usex savevm)
+ -DNM_WITH_SPICE=$(usex spice)
+ -DNM_WITH_VNC_CLIENT=$(usex vnc-client)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "For non-root usage execute script:"
+ elog "/usr/share/nemu/scripts/setup_nemu_nonroot.sh linux <username>"
+ elog "and add udev rule:"
+ elog "cp /usr/share/nemu/scripts/42-net-macvtap-perm.rules /lib/udev/rules.d"
+ if use savevm; then
+ elog ""
+ elog "QEMU must be patched with qemu-qmp-savevm-VERSION.patch"
+ elog "Get this patch from nEMU repository"
+ fi
+}
diff --git a/app-shells/hstr/files/hstr-2.0-fix-ncurses-configure.patch b/app-shells/hstr/files/hstr-2.0-fix-ncurses-configure.patch
new file mode 100644
index 000000000000..215fd5cedfc9
--- /dev/null
+++ b/app-shells/hstr/files/hstr-2.0-fix-ncurses-configure.patch
@@ -0,0 +1,81 @@
+diff --git a/configure.ac b/configure.ac
+index 1676ec8..73c8be5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,39 +47,33 @@ then
+ fi
+
+ # PKG_CHECK_MODULES macro is NOT used to avoid confusing syntax errors in case that pkg-config is NOT installed
+-AC_CHECK_LIB(ncursesw, killwchar, [],
+-[
+- AC_CHECK_LIB(ncurses, killwchar, [],
+- [
+- AC_SUBST([NCURSESW_CFLAGS])
+- AC_SUBST([NCURSESW_LIBS])
+- if pkg-config --exists ncursesw
+- then
+- AC_MSG_NOTICE([Module ncursesw found])
+- NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
+- NCURSESW_LIBS=`pkg-config --libs ncursesw`
+- else
+- if pkg-config --exists ncurses
+- then
+- AC_MSG_NOTICE([Module ncurses found])
+- NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
+- NCURSESW_LIBS=`pkg-config --libs ncurses`
+- else
+- AS_CASE([$host_os],
+- [darwin*],
+- [
+- AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
+- AC_CHECK_HEADER(curses.h)
+- ],
+- [
+- AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
+- AC_CHECK_HEADER(ncursesw/curses.h)
+- ]
+- )
+- fi
+- fi
+- ]) # FAIL of ncurses
+-]) # FAIL of ncursesw
++AC_SUBST([NCURSESW_CFLAGS])
++AC_SUBST([NCURSESW_LIBS])
++if pkg-config --exists ncursesw
++then
++ AC_MSG_NOTICE([Module ncursesw found])
++ NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
++ NCURSESW_LIBS=`pkg-config --libs ncursesw`
++else
++ if pkg-config --exists ncurses
++ then
++ AC_MSG_NOTICE([Module ncurses found])
++ NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
++ NCURSESW_LIBS=`pkg-config --libs ncurses`
++ else
++ AS_CASE([$host_os],
++ [darwin*],
++ [
++ AC_CHECK_LIB(ncurses, killwchar, [], [AC_MSG_ERROR([Could not find ncurses library])])
++ AC_CHECK_HEADER(curses.h)
++ ],
++ [
++ AC_CHECK_LIB(ncursesw, killwchar, [], [AC_MSG_ERROR([Could not find ncursesw library])])
++ AC_CHECK_HEADER(ncursesw/curses.h)
++ ]
++ )
++ fi
++fi
+
+
+ # Checks for libraries.
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 7640d21..17a82b7 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -37,4 +37,4 @@ hstr_SOURCES = \
+ install-exec-hook:
+ ln $(DESTDIR)$(bindir)/hstr$(EXEEXT) $(DESTDIR)$(bindir)/hh$(EXEEXT)
+
+-hstr_LDADD = $(NCURSES_LIBS)
++hstr_LDADD = $(NCURSESW_LIBS)
diff --git a/app-shells/hstr/hstr-2.0.ebuild b/app-shells/hstr/hstr-2.0.ebuild
index 206760fd98b8..b2332147a9b4 100644
--- a/app-shells/hstr/hstr-2.0.ebuild
+++ b/app-shells/hstr/hstr-2.0.ebuild
@@ -22,6 +22,8 @@ DEPEND="
DOCS=( CONFIGURATION.md README.md )
+PATCHES=( ${FILESDIR}/${P}-fix-ncurses-configure.patch )
+
src_prepare() {
default
sed \
diff --git a/www-apps/zeppelin-bin/Manifest b/www-apps/zeppelin-bin/Manifest
index ae449ef71b1e..1c242e0db077 100644
--- a/www-apps/zeppelin-bin/Manifest
+++ b/www-apps/zeppelin-bin/Manifest
@@ -1 +1,2 @@
DIST zeppelin-bin-0.8.1.tgz 992975720 BLAKE2B 13bae89054a5be0570d0550cfc875d989de66dcdc6fe2aa3c8b71b452782d8cf2c8f6cf030b47f1b9050899912f75136cef7d9ef1b80c8957ad8a260fc7050c5 SHA512 b8302b36acc5cc8859f4341329bcb4d038bbb91d4493be191606df94da08a2fa37940958ceae507e6cdbe22fc338111ac9bee580cb41ee74198911469552df02
+DIST zeppelin-bin-0.8.2.tgz 998508624 BLAKE2B cccfa95426d8d0407d7a226f5d71c15ca55da8893a7fff9e3a612c63034ab1838f8f7d5a529bb393b825c6c3bd19e197f4e913c2c5b8dd04fb282affc43788ab SHA512 91a785153bc47b087f90fac0f83066fdede041d5193506b231af1b6855b150307873c92cea462c6dd48ef6d38caa37934591a08542199ac4b02d9493298fbd43
diff --git a/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild b/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild
index 6b80c178e624..020e6bdd140b 100644
--- a/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild
+++ b/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://zeppelin.apache.org"
SRC_URI="mirror://apache/zeppelin/${MY_PN}-${PV}/${MY_P}.tgz -> ${P}.tgz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
DEPEND=">=virtual/jdk-1.8"
RDEPEND=">=virtual/jre-1.8"
@@ -35,6 +35,6 @@ src_install() {
dodir "${INSTALL_DIR}"
cp -pRP * "${ED}/${INSTALL_DIR}" || die
- dosym "${ED}/${INSTALL_DIR}" /opt/zeppelin
+ dosym "${P}" /opt/zeppelin
fowners -R zeppelin:zeppelin "${INSTALL_DIR}"
}
diff --git a/www-apps/zeppelin-bin/zeppelin-bin-0.8.2.ebuild b/www-apps/zeppelin-bin/zeppelin-bin-0.8.2.ebuild
new file mode 100644
index 000000000000..8423abc2db72
--- /dev/null
+++ b/www-apps/zeppelin-bin/zeppelin-bin-0.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 user
+
+MY_PN="zeppelin"
+MY_P="${MY_PN}-${PV}-bin-all"
+
+DESCRIPTION="Web-based interactive data analytics notebook launcher"
+HOMEPAGE="https://zeppelin.apache.org"
+SRC_URI="mirror://apache/zeppelin/${MY_PN}-${PV}/${MY_P}.tgz -> ${P}.tgz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+INSTALL_DIR="/opt/${P}"
+
+pkg_setup() {
+ enewgroup zeppelin
+ enewuser zeppelin -1 /bin/sh /home/zeppelin zeppelin
+}
+
+src_install() {
+ keepdir /var/log/zeppelin
+ fowners -R zeppelin:zeppelin /var/log/zeppelin
+
+ newinitd "${FILESDIR}/zeppelin.init.d" zeppelin
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP * "${ED}/${INSTALL_DIR}" || die
+ dosym "${P}" /opt/zeppelin
+ fowners -R zeppelin:zeppelin "${INSTALL_DIR}"
+}