summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-05-11 18:02:43 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-05-11 18:02:43 +0000
commitc55f2ca4febe292dbd1bef984e78f00b30db2747 (patch)
tree387a184606951735aa834da8e14e5d802b08b1a4
parent2016-05-11 17:46:10 UTC (diff)
parentx11-libs/qtermwidget: remove old (diff)
downloadgentoo-c55f2ca4febe292dbd1bef984e78f00b30db2747.tar.gz
gentoo-c55f2ca4febe292dbd1bef984e78f00b30db2747.tar.bz2
gentoo-c55f2ca4febe292dbd1bef984e78f00b30db2747.zip
Merge updates from master
-rw-r--r--net-fs/netatalk/files/netatalk-3.1.8-disable-ld-library-path.patch34
-rw-r--r--net-fs/netatalk/netatalk-3.1.8.ebuild10
-rw-r--r--x11-libs/qtermwidget/qtermwidget-0.6.0-r1.ebuild4
-rw-r--r--x11-libs/qtermwidget/qtermwidget-0.6.0.ebuild33
4 files changed, 39 insertions, 42 deletions
diff --git a/net-fs/netatalk/files/netatalk-3.1.8-disable-ld-library-path.patch b/net-fs/netatalk/files/netatalk-3.1.8-disable-ld-library-path.patch
new file mode 100644
index 000000000000..0335366b23b5
--- /dev/null
+++ b/net-fs/netatalk/files/netatalk-3.1.8-disable-ld-library-path.patch
@@ -0,0 +1,34 @@
+there's no need to set LD_LIBRARY_PATH in order to perform link tests, and
+it's actually undesirable as it'll cause the toolchain to search a different
+path than the ones it's configured to (host lib wise).
+
+https://bugs.gentoo.org/564350
+
+--- a/macros/db3-check.m4
++++ b/macros/db3-check.m4
+@@ -142,15 +142,7 @@ if test "x$bdb_required" = "xyes"; then
+ CPPFLAGS="-I${bdbdir}/include${subdir} $CPPFLAGS"
+ LDFLAGS="-L$bdblibdir $LDFLAGS"
+
+- dnl -- Uses version set by NETATALK_BDB_HEADER to try to run
+- dnl -- a conftest that checks that header/lib version match
+- dnl -- $shlibpath_var is set by LIBTOOL, its value is
+- dnl -- LD_LIBRARY_PATH on many platforms. This will be fairly
+- dnl -- portable hopefully. Reference:
+- dnl -- http://lists.gnu.org/archive/html/autoconf/2009-03/msg00040.html
+- eval export $shlibpath_var=$bdblibdir
+ NETATALK_BDB_TRY_LINK
+- eval export $shlibpath_var=$saved_shlibpath_var
+
+ if test x"${atalk_cv_bdb_version}" = x"yes"; then
+ BDB_CFLAGS="-I${bdbdir}/include${subdir}"
+@@ -174,9 +166,7 @@ if test "x$bdb_required" = "xyes"; then
+ CPPFLAGS="-I${bdbdir}/include${subdir} $CPPFLAGS"
+ LDFLAGS="-L$bdblibdir $LDFLAGS"
+
+- eval export $shlibpath_var=$bdblibdir
+ NETATALK_BDB_TRY_LINK
+- eval export $shlibpath_var=$saved_shlibpath_var
+
+ if test x"${atalk_cv_bdb_version}" = x"yes"; then
+ BDB_CFLAGS="-I${bdbdir}/include${subdir}"
diff --git a/net-fs/netatalk/netatalk-3.1.8.ebuild b/net-fs/netatalk/netatalk-3.1.8.ebuild
index b99120c5cdf5..3416b1c570e0 100644
--- a/net-fs/netatalk/netatalk-3.1.8.ebuild
+++ b/net-fs/netatalk/netatalk-3.1.8.ebuild
@@ -58,6 +58,7 @@ REQUIRED_USE="
PATCHES=(
"${FILESDIR}"/${PN}-3.1.7-gentoo.patch
+ "${FILESDIR}"/${PN}-3.1.8-disable-ld-library-path.patch #564350
)
src_prepare() {
@@ -74,18 +75,11 @@ src_configure() {
append-flags -fno-strict-aliasing
- if use acl; then
- myeconfargs+=( --with-acls $(use_with ldap) )
- else
- myeconfargs+=( --without-acls --without-ldap )
- fi
-
# Ignore --with-init-style=gentoo, we install the init.d by hand and we avoid having
# to sed the Makefiles to not do rc-update.
# TODO:
# systemd : --with-init-style=systemd
myeconfargs+=(
- --disable-silent-rules
$(use_enable avahi zeroconf)
$(use_enable debug)
$(use_enable debug debugging)
@@ -94,8 +88,10 @@ src_configure() {
$(use_enable kerberos krbV-uam)
$(use_enable quota)
$(use_enable tcpd tcp-wrappers)
+ $(use_with acl acls)
$(use_with cracklib)
$(use_with dbus afpstats)
+ $(use_with ldap)
$(use_with pam)
$(use_with samba smbsharemodes)
$(use_with shadow)
diff --git a/x11-libs/qtermwidget/qtermwidget-0.6.0-r1.ebuild b/x11-libs/qtermwidget/qtermwidget-0.6.0-r1.ebuild
index e8cc0ec530fa..650c011b5b9b 100644
--- a/x11-libs/qtermwidget/qtermwidget-0.6.0-r1.ebuild
+++ b/x11-libs/qtermwidget/qtermwidget-0.6.0-r1.ebuild
@@ -11,8 +11,8 @@ SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="debug qt4 qt5"
+KEYWORDS="amd64 ~arm ~x86"
+IUSE="qt4 qt5"
REQUIRED_USE="|| ( qt4 qt5 )"
DEPEND="
diff --git a/x11-libs/qtermwidget/qtermwidget-0.6.0.ebuild b/x11-libs/qtermwidget/qtermwidget-0.6.0.ebuild
deleted file mode 100644
index 49131dacca15..000000000000
--- a/x11-libs/qtermwidget/qtermwidget-0.6.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils
-
-DESCRIPTION="Qt terminal emulator widget"
-HOMEPAGE="https://github.com/lxde/qtermwidget"
-SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~x86"
-IUSE="debug qt4 qt5"
-REQUIRED_USE="^^ ( qt4 qt5 )"
-
-DEPEND="
- qt4? ( dev-qt/designer:4
- dev-qt/qtcore:4
- dev-qt/qtgui:4 )
- qt5? ( dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5 )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_use qt5)
- $(cmake-utils_use_build qt4 DESIGNER_PLUGIN)
- )
- cmake-utils_src_configure
-}