summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-05-26 09:41:52 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-05-26 09:41:52 +0000
commitc2c5fb97b79277de1ab911273af6fb3ebf47c513 (patch)
tree59ea2d275768ffb8f75b6fe52ac24ef3fa8c9cdf
parent2017-05-26 09:22:17 UTC (diff)
parentgames-arcade/tuxanci: Port to EAPI 6 (diff)
downloadgentoo-c2c5fb97b79277de1ab911273af6fb3ebf47c513.tar.gz
gentoo-c2c5fb97b79277de1ab911273af6fb3ebf47c513.tar.bz2
gentoo-c2c5fb97b79277de1ab911273af6fb3ebf47c513.zip
Merge updates from master
-rw-r--r--dev-perl/gnome2-vfs-perl/Manifest1
-rw-r--r--dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.83.0.ebuild23
-rw-r--r--games-arcade/tuxanci/tuxanci-20110429-r1.ebuild59
-rw-r--r--games-arcade/tuxanci/tuxanci-20110429.ebuild72
-rw-r--r--games-arcade/tuxanci/tuxanci-99999999.ebuild59
-rw-r--r--profiles/arch/ia64/package.mask50
-rw-r--r--profiles/arch/sparc/package.mask50
7 files changed, 106 insertions, 208 deletions
diff --git a/dev-perl/gnome2-vfs-perl/Manifest b/dev-perl/gnome2-vfs-perl/Manifest
index 28d79038765b..887ebd137089 100644
--- a/dev-perl/gnome2-vfs-perl/Manifest
+++ b/dev-perl/gnome2-vfs-perl/Manifest
@@ -1 +1,2 @@
DIST Gnome2-VFS-1.081.tar.gz 59061 SHA256 54f5d5406285f16ff68a3013980102e7ddd651f2523b296c1021ebf27c4e7a78 SHA512 4a2e675af01e6d6bfe6ac75d1c2b2e21b28bae284c9fd9ecb60786ed8f9bb9c54113db6edb30039dad4cda522fa15ae22c1364f04421397c2adb1d558d1217f5 WHIRLPOOL 83d1dae950a26fe7c468f47e5e39e9d1f9960d813a27bd8fd783a00d7a9ffc4a94698e73dcccc24dcab3c3b78c29aaeb5245e3dad0a0422101ecef376fa1cd0d
+DIST Gnome2-VFS-1.083.tar.gz 59109 SHA256 eca974669df4e7f21b4fcedb96c8a328422369c68b8c2cd99b9ce9cc5d7a7979 SHA512 385bf402ea6493ec3d558e146f5bad754bb17e0c76960336352ed8e928e2fc163077cfd081c11fceae4750eab8d1f60fb532eb25b83a88c0fd93cb9268e9a252 WHIRLPOOL 96fe74406f4fee97802dda59714cdd067ffc89804325eec3a2f9d86ca422059846fed1f08926da2675404d5c51bc8323575d613c4af308f13558e02985fd00ce
diff --git a/dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.83.0.ebuild b/dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.83.0.ebuild
new file mode 100644
index 000000000000..442904d7bf35
--- /dev/null
+++ b/dev-perl/gnome2-vfs-perl/gnome2-vfs-perl-1.83.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_NAME=Gnome2-VFS
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.083
+inherit perl-module
+
+DESCRIPTION="Perl interface to the 2.x series of the Gnome Virtual File System libraries"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=gnome-base/gnome-vfs-2
+ >=dev-perl/glib-perl-1.120"
+DEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.200.0
+ >=dev-perl/ExtUtils-PkgConfig-1.03
+ virtual/pkgconfig"
diff --git a/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild b/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild
new file mode 100644
index 000000000000..3d55994e39ee
--- /dev/null
+++ b/games-arcade/tuxanci/tuxanci-20110429-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci"
+HOMEPAGE="http://www.tuxanci.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
+else
+ SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
+
+# >=x11-libs/cairo-1.8.8[X,svg]
+RDEPEND="
+ !dedicated? (
+ >=media-libs/fontconfig-2.7.0
+ media-libs/libsdl[X,opengl?]
+ media-libs/sdl-ttf[X]
+ >=media-libs/sdl-image-1.2.10[png]
+ sound? (
+ >=media-libs/sdl-mixer-1.2.11[vorbis]
+ )
+ )
+ physfs? ( dev-games/physfs[zip] )
+ !physfs? ( >=dev-libs/libzip-0.9 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AUDIO=$(usex sound)
+ -DBUILD_SERVER=$(usex dedicated)
+ -DWITH_NLS=$(usex nls)
+ -DWITH_PHYSFS=$(usex physfs)
+ -DWITH_OPENGL=$(usex opengl)
+ -DENABLE_IPV6=$(usex ipv6)
+ -DDEVELOPER=$(usex debug)
+ -DCMAKE_INSTALL_ICONDIR="${EPREFIX}"/usr/pixmaps/
+ -DCMAKE_INSTALL_DESKTOPDIR="${EPREFIX}"/usr/applications/
+ -DCMAKE_DATA_PATH="${EPREFIX}"/usr/share/
+ -DCMAKE_LOCALE_PATH="${EPREFIX}"/usr/share/locale/
+ -DCMAKE_DOC_PATH="${EPREFIX}"/usr/share/doc/${PF}
+ -DCMAKE_CONF_PATH="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}
diff --git a/games-arcade/tuxanci/tuxanci-20110429.ebuild b/games-arcade/tuxanci/tuxanci-20110429.ebuild
deleted file mode 100644
index 0a18633e815e..000000000000
--- a/games-arcade/tuxanci/tuxanci-20110429.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-[[ ${PV} = 9999* ]] && GIT="git-2"
-EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
-
-inherit games cmake-utils ${GIT}
-
-DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci"
-HOMEPAGE="http://www.tuxanci.org/"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
- KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-fi
-LICENSE="GPL-2"
-
-SLOT="0"
-IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
-
-# >=x11-libs/cairo-1.8.8[X,svg]
-RDEPEND="
- !dedicated? (
- >=media-libs/fontconfig-2.7.0
- media-libs/libsdl[X,opengl?]
- media-libs/sdl-ttf[X]
- >=media-libs/sdl-image-1.2.10[png]
- sound? (
- >=media-libs/sdl-mixer-1.2.11[vorbis]
- )
- )
- physfs? ( dev-games/physfs[zip] )
- !physfs? ( >=dev-libs/libzip-0.9 )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-src_configure() {
- local mycmakeargs+=(
- $(cmake-utils_use_with sound AUDIO)
- $(cmake-utils_use_build dedicated SERVER)
- $(cmake-utils_use_with nls)
- $(cmake-utils_use_with physfs)
- $(cmake-utils_use_with opengl)
- $(cmake-utils_use_enable ipv6)
- $(cmake-utils_use debug DEVELOPER)
- )
-
- mycmakeargs+=(
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
- "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
- "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
- "-DCMAKE_LOCALE_PATH=${GAMES_DATADIR_BASE}/locale/"
- "-DCMAKE_DOC_PATH=${GAMES_DATADIR_BASE}/doc/${PF}"
- "-DCMAKE_CONF_PATH=${GAMES_SYSCONFDIR}"
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- prepgamesdirs
-}
diff --git a/games-arcade/tuxanci/tuxanci-99999999.ebuild b/games-arcade/tuxanci/tuxanci-99999999.ebuild
index 8d85ddeeebb7..3d55994e39ee 100644
--- a/games-arcade/tuxanci/tuxanci-99999999.ebuild
+++ b/games-arcade/tuxanci/tuxanci-99999999.ebuild
@@ -1,24 +1,22 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-[[ ${PV} = 9999* ]] && GIT="git-2"
-EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
-
-inherit games cmake-utils ${GIT}
+inherit cmake-utils
DESCRIPTION="Tuxanci is first tux shooter inspired by game Bulanci"
HOMEPAGE="http://www.tuxanci.org/"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://repo.or.cz/tuxanci.git"
else
- SRC_URI="http://download.${PN}.org/${P}.tar.bz2"
+ SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
fi
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
IUSE="debug dedicated +ipv6 nls opengl physfs +sound"
@@ -42,31 +40,20 @@ DEPEND="${RDEPEND}
"
src_configure() {
- local mycmakeargs+=(
- $(cmake-utils_use_with sound AUDIO)
- $(cmake-utils_use_build dedicated SERVER)
- $(cmake-utils_use_with nls)
- $(cmake-utils_use_with physfs)
- $(cmake-utils_use_with opengl)
- $(cmake-utils_use_enable ipv6)
- $(cmake-utils_use debug DEVELOPER)
- )
-
- mycmakeargs+=(
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
- "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
- "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
- "-DCMAKE_LOCALE_PATH=${GAMES_DATADIR_BASE}/locale/"
- "-DCMAKE_DOC_PATH=${GAMES_DATADIR_BASE}/doc/${PF}"
- "-DCMAKE_CONF_PATH=${GAMES_SYSCONFDIR}"
+ local mycmakeargs=(
+ -DWITH_AUDIO=$(usex sound)
+ -DBUILD_SERVER=$(usex dedicated)
+ -DWITH_NLS=$(usex nls)
+ -DWITH_PHYSFS=$(usex physfs)
+ -DWITH_OPENGL=$(usex opengl)
+ -DENABLE_IPV6=$(usex ipv6)
+ -DDEVELOPER=$(usex debug)
+ -DCMAKE_INSTALL_ICONDIR="${EPREFIX}"/usr/pixmaps/
+ -DCMAKE_INSTALL_DESKTOPDIR="${EPREFIX}"/usr/applications/
+ -DCMAKE_DATA_PATH="${EPREFIX}"/usr/share/
+ -DCMAKE_LOCALE_PATH="${EPREFIX}"/usr/share/locale/
+ -DCMAKE_DOC_PATH="${EPREFIX}"/usr/share/doc/${PF}
+ -DCMAKE_CONF_PATH="${EPREFIX}"/etc
)
-
cmake-utils_src_configure
}
-
-src_install() {
- cmake-utils_src_install
-
- prepgamesdirs
-}
diff --git a/profiles/arch/ia64/package.mask b/profiles/arch/ia64/package.mask
index 862b1c016390..d6cde39bbece 100644
--- a/profiles/arch/ia64/package.mask
+++ b/profiles/arch/ia64/package.mask
@@ -1,56 +1,6 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# Alexis Ballier <aballier@gentoo.org> (27 Jun 2013)
-# TeX Live 2013 mask.
-# kpathsea should be there because it has config files without /usr/share/texmf
-# and thus will break anything before TeX Live 2013.
->=app-text/texlive-core-2013
->=dev-tex/luatex-0.74
->=app-text/texlive-2013
->=dev-tex/bibtexu-3.71_p20130530
->=dev-texlive/texlive-fontsextra-2013
->=dev-texlive/texlive-langother-2013
->=dev-texlive/texlive-latexrecommended-2013
->=dev-texlive/texlive-formatsextra-2013
->=dev-texlive/texlive-games-2013
->=dev-texlive/texlive-langcyrillic-2013
->=dev-texlive/texlive-pstricks-2013
->=dev-texlive/texlive-langportuguese-2013
->=dev-texlive/texlive-omega-2013
->=dev-texlive/texlive-langspanish-2013
->=dev-texlive/texlive-langczechslovak-2013
->=dev-texlive/texlive-basic-2013
->=dev-texlive/texlive-langindic-2013
->=dev-texlive/texlive-langpolish-2013
->=dev-texlive/texlive-luatex-2013
->=dev-texlive/texlive-plainextra-2013
->=dev-texlive/texlive-langafrican-2013
->=dev-texlive/texlive-fontutils-2013
->=dev-texlive/texlive-genericextra-2013
->=dev-texlive/texlive-latexextra-2013
->=dev-texlive/texlive-latex-2013
->=dev-texlive/texlive-mathextra-2013
->=dev-texlive/texlive-langgreek-2013
->=dev-texlive/texlive-langenglish-2013
->=dev-texlive/texlive-fontsrecommended-2013
->=dev-texlive/texlive-science-2013
->=dev-texlive/texlive-langarabic-2013
->=dev-texlive/texlive-metapost-2013
->=dev-texlive/texlive-xetex-2013
->=dev-texlive/texlive-langgerman-2013
->=dev-texlive/texlive-music-2013
->=dev-texlive/texlive-langitalian-2013
->=dev-texlive/texlive-langcjk-2013
->=dev-texlive/texlive-langeuropean-2013
->=dev-texlive/texlive-langfrench-2013
->=dev-texlive/texlive-bibtexextra-2013
->=dev-texlive/texlive-humanities-2013
->=dev-texlive/texlive-context-2013
->=dev-texlive/texlive-pictures-2013
->=dev-texlive/texlive-genericrecommended-2013
->=dev-texlive/texlive-publishers-2013
-
# Zac Medico <zmedico@gentoo.org> (09 Aug 2011)
# Bug #377907 - Use package.mask for compatibility with PMS section 5.2.7, and
# future versions of sys-apps/portage.
diff --git a/profiles/arch/sparc/package.mask b/profiles/arch/sparc/package.mask
index c804094c710f..2c683288e66c 100644
--- a/profiles/arch/sparc/package.mask
+++ b/profiles/arch/sparc/package.mask
@@ -9,53 +9,3 @@ mail-mta/postfix
# Raúl Porcel <armin76@gentoo.org> (17 Nov 2014)
# Mask sys-devel/kgcc64 since >=gcc-4.4 can build 64bit kernels
sys-devel/kgcc64
-
-# Alexis Ballier <aballier@gentoo.org> (27 Jun 2013)
-# TeX Live 2013 mask.
-# kpathsea should be there because it has config files without /usr/share/texmf
-# and thus will break anything before TeX Live 2013.
->=app-text/texlive-core-2013
->=dev-tex/luatex-0.74
->=app-text/texlive-2013
->=dev-tex/bibtexu-3.71_p20130530
->=dev-texlive/texlive-fontsextra-2013
->=dev-texlive/texlive-langother-2013
->=dev-texlive/texlive-latexrecommended-2013
->=dev-texlive/texlive-formatsextra-2013
->=dev-texlive/texlive-games-2013
->=dev-texlive/texlive-langcyrillic-2013
->=dev-texlive/texlive-pstricks-2013
->=dev-texlive/texlive-langportuguese-2013
->=dev-texlive/texlive-omega-2013
->=dev-texlive/texlive-langspanish-2013
->=dev-texlive/texlive-langczechslovak-2013
->=dev-texlive/texlive-basic-2013
->=dev-texlive/texlive-langindic-2013
->=dev-texlive/texlive-langpolish-2013
->=dev-texlive/texlive-luatex-2013
->=dev-texlive/texlive-plainextra-2013
->=dev-texlive/texlive-langafrican-2013
->=dev-texlive/texlive-fontutils-2013
->=dev-texlive/texlive-genericextra-2013
->=dev-texlive/texlive-latexextra-2013
->=dev-texlive/texlive-latex-2013
->=dev-texlive/texlive-mathextra-2013
->=dev-texlive/texlive-langgreek-2013
->=dev-texlive/texlive-langenglish-2013
->=dev-texlive/texlive-fontsrecommended-2013
->=dev-texlive/texlive-science-2013
->=dev-texlive/texlive-langarabic-2013
->=dev-texlive/texlive-metapost-2013
->=dev-texlive/texlive-xetex-2013
->=dev-texlive/texlive-langgerman-2013
->=dev-texlive/texlive-music-2013
->=dev-texlive/texlive-langitalian-2013
->=dev-texlive/texlive-langcjk-2013
->=dev-texlive/texlive-langeuropean-2013
->=dev-texlive/texlive-langfrench-2013
->=dev-texlive/texlive-bibtexextra-2013
->=dev-texlive/texlive-humanities-2013
->=dev-texlive/texlive-context-2013
->=dev-texlive/texlive-pictures-2013
->=dev-texlive/texlive-genericrecommended-2013
->=dev-texlive/texlive-publishers-2013