summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-18 19:04:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-18 20:04:37 +0100
commitbe2e1a24cd6c969690ca7a2bc40d98203fbee551 (patch)
tree6f7a7dce9afd2455aa72ae96bc3b840da045e105
parentkde-plasma/powerdevil: Drop 5.14.3 (r0) (diff)
downloadgentoo-be2e1a24cd6c969690ca7a2bc40d98203fbee551.tar.gz
gentoo-be2e1a24cd6c969690ca7a2bc40d98203fbee551.tar.bz2
gentoo-be2e1a24cd6c969690ca7a2bc40d98203fbee551.zip
kde-apps/konqueror: Switch USE tidy to app-text/tidy-html5
Bug: https://bugs.gentoo.org/671450 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/konqueror/files/konqueror-18.08.3-tidyhtml5.patch46
-rw-r--r--kde-apps/konqueror/konqueror-18.08.3-r1.ebuild113
2 files changed, 159 insertions, 0 deletions
diff --git a/kde-apps/konqueror/files/konqueror-18.08.3-tidyhtml5.patch b/kde-apps/konqueror/files/konqueror-18.08.3-tidyhtml5.patch
new file mode 100644
index 000000000000..dae1486d5807
--- /dev/null
+++ b/kde-apps/konqueror/files/konqueror-18.08.3-tidyhtml5.patch
@@ -0,0 +1,46 @@
+From 29955abce07526d01f3298da9d2f15bd9eb5e6f4 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 18 Nov 2018 18:07:32 +0100
+Subject: [PATCH] Switch to tidy-html5 and use tidybuffio.h instead of buffio.h
+
+Summary: Header was renamed a few years ago.
+
+Test Plan: Builds and validates fine.
+
+Reviewers: #konqueror
+
+Differential Revision: https://phabricator.kde.org/D16982
+---
+ plugins/validators/CMakeLists.txt | 2 +-
+ plugins/validators/tidy_validator.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/plugins/validators/CMakeLists.txt b/plugins/validators/CMakeLists.txt
+index cf3b70694..7f6060e9c 100644
+--- a/plugins/validators/CMakeLists.txt
++++ b/plugins/validators/CMakeLists.txt
+@@ -4,7 +4,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR})
+ find_package(LibTidy)
+ find_package(KF5 REQUIRED KHtml WidgetsAddons IconThemes)
+ set_package_properties(LibTidy PROPERTIES DESCRIPTION "HTML Tidy"
+- URL "http://tidy.sourceforge.net"
++ URL "http://www.html-tidy.org/"
+ TYPE OPTIONAL
+ PURPOSE "Gives the Konqueror validators plugin the ability to validate HTML"
+ )
+diff --git a/plugins/validators/tidy_validator.cpp b/plugins/validators/tidy_validator.cpp
+index 3247199f9..ac22429d0 100644
+--- a/plugins/validators/tidy_validator.cpp
++++ b/plugins/validators/tidy_validator.cpp
+@@ -25,7 +25,7 @@
+
+ #include <kdebug.h>
+
+-#include <buffio.h>
++#include <tidybuffio.h>
+ #include <tidy.h>
+
+ #include <config-konq-validator.h>
+--
+2.19.1
+
diff --git a/kde-apps/konqueror/konqueror-18.08.3-r1.ebuild b/kde-apps/konqueror/konqueror-18.08.3-r1.ebuild
new file mode 100644
index 000000000000..c84260236ac0
--- /dev/null
+++ b/kde-apps/konqueror/konqueror-18.08.3-r1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional" # not optional until !kdelibs4support
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit flag-o-matic kde5
+
+DESCRIPTION="Web browser and file manager based on KDE Frameworks"
+HOMEPAGE="
+ https://www.kde.org/applications/internet/konqueror/
+ https://konqueror.org/
+"
+KEYWORDS="~amd64 ~x86"
+IUSE="activities speech tidy +webengine X"
+# 4 of 4 tests fail. Last checked for 4.0.3
+RESTRICT+=" test"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kdesu)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ sys-libs/zlib
+ speech? ( $(add_qt_dep qtspeech) )
+ tidy? ( app-text/tidy-html5 )
+ webengine? ( $(add_qt_dep qtwebengine 'widgets') )
+ X? ( $(add_qt_dep qtx11extras) )
+"
+DEPEND="${COMMON_DEPEND}
+ activities? ( $(add_frameworks_dep kactivities) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kfmclient:4
+ !kde-apps/konq-plugins
+ !kde-apps/libkonq:5
+ $(add_kdeapps_dep kfind)
+ $(add_plasma_dep kde-cli-tools)
+ !webengine? ( kde-misc/kwebkitpart:5 )
+"
+
+PATCHES=( "${FILESDIR}/${P}-tidyhtml5.patch" )
+
+src_prepare() {
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags -lmalloc
+
+ if ! use webengine; then
+ punt_bogus_dep Qt5 WebEngineWidgets
+ cmake_comment_add_subdirectory webenginepart
+ fi
+
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package activities KF5Activities)
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ $(cmake-utils_use_find_package tidy LibTidy)
+ $(cmake-utils_use_find_package X X11)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version kde-apps/keditbookmarks:${SLOT} ; then
+ elog "For bookmarks support, install keditbookmarks:"
+ elog "kde-apps/keditbookmarks:${SLOT}"
+ fi
+
+ if ! has_version kde-apps/dolphin:${SLOT} ; then
+ elog "If you want to use konqueror as a filemanager, install the dolphin kpart:"
+ elog "kde-apps/dolphin:${SLOT}"
+ fi
+
+ if ! has_version kde-apps/svg:${SLOT} ; then
+ elog "For konqueror to view SVGs, install the svg kpart:"
+ elog "kde-apps/svgpart:${SLOT}"
+ fi
+
+ if ! has_version virtual/jre ; then
+ elog "To use Java on webpages install virtual/jre."
+ fi
+}