summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-11-09 14:37:05 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-11-09 14:37:05 +0000
commitbaefc276dac294ac1892b0c783cb7c93d1b7597e (patch)
tree845cd59259bfdb0040ea60dc363cf0528555ce43
parent2019-11-09 13:26:04 UTC (diff)
parentapp-misc/mc: RESTRICT="!test? ( test )" (diff)
downloadgentoo-baefc276dac294ac1892b0c783cb7c93d1b7597e.tar.gz
gentoo-baefc276dac294ac1892b0c783cb7c93d1b7597e.tar.bz2
gentoo-baefc276dac294ac1892b0c783cb7c93d1b7597e.zip
Merge updates from master
-rw-r--r--app-misc/mc/mc-4.8.22.ebuild2
-rw-r--r--app-misc/mc/mc-4.8.23-r1.ebuild2
-rw-r--r--app-misc/mc/mc-4.8.23.ebuild2
-rw-r--r--app-misc/mc/mc-9999.ebuild2
-rw-r--r--eclass/toolchain-binutils.eclass3
-rw-r--r--net-nds/led/led-1.111.ebuild16
-rw-r--r--net-proxy/piper/piper-1.14.ebuild7
-rw-r--r--net-vpn/nstx/nstx-1.1_beta6-r3.ebuild58
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.30-r4.ebuild5
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.31.1-r6.ebuild2
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.32-r1.ebuild2
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.33.1.ebuild2
-rw-r--r--sys-devel/binutils/binutils-2.30-r4.ebuild5
-rw-r--r--sys-devel/binutils/binutils-2.31.1-r6.ebuild2
-rw-r--r--sys-devel/binutils/binutils-2.32-r1.ebuild2
-rw-r--r--sys-devel/binutils/binutils-2.33.1.ebuild2
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild2
17 files changed, 72 insertions, 44 deletions
diff --git a/app-misc/mc/mc-4.8.22.ebuild b/app-misc/mc/mc-4.8.22.ebuild
index a246a79ffb5a..256d07fc143e 100644
--- a/app-misc/mc/mc-4.8.22.ebuild
+++ b/app-misc/mc/mc-4.8.22.ebuild
@@ -38,6 +38,8 @@ DEPEND="${RDEPEND}
test? ( dev-libs/check )
"
+RESTRICT="!test? ( test )"
+
S=${WORKDIR}/${MY_P}
pkg_pretend() {
diff --git a/app-misc/mc/mc-4.8.23-r1.ebuild b/app-misc/mc/mc-4.8.23-r1.ebuild
index 9f58fc202682..7791376a19da 100644
--- a/app-misc/mc/mc-4.8.23-r1.ebuild
+++ b/app-misc/mc/mc-4.8.23-r1.ebuild
@@ -38,6 +38,8 @@ DEPEND="${RDEPEND}
test? ( dev-libs/check )
"
+RESTRICT="!test? ( test )"
+
S=${WORKDIR}/${MY_P}
PATCHES=(
diff --git a/app-misc/mc/mc-4.8.23.ebuild b/app-misc/mc/mc-4.8.23.ebuild
index 32597904a63f..b4513ee07fb6 100644
--- a/app-misc/mc/mc-4.8.23.ebuild
+++ b/app-misc/mc/mc-4.8.23.ebuild
@@ -38,6 +38,8 @@ DEPEND="${RDEPEND}
test? ( dev-libs/check )
"
+RESTRICT="!test? ( test )"
+
S=${WORKDIR}/${MY_P}
pkg_pretend() {
diff --git a/app-misc/mc/mc-9999.ebuild b/app-misc/mc/mc-9999.ebuild
index 14377f18812e..336a555d2aba 100644
--- a/app-misc/mc/mc-9999.ebuild
+++ b/app-misc/mc/mc-9999.ebuild
@@ -47,6 +47,8 @@ DEPEND="${RDEPEND}
test? ( dev-libs/check )
"
+RESTRICT="!test? ( test )"
+
pkg_pretend() {
if use slang && use unicode ; then
ewarn "\"unicode\" USE flag only takes effect when the \"slang\" USE flag is disabled."
diff --git a/eclass/toolchain-binutils.eclass b/eclass/toolchain-binutils.eclass
index 0b691d822762..303eeb4092fd 100644
--- a/eclass/toolchain-binutils.eclass
+++ b/eclass/toolchain-binutils.eclass
@@ -99,6 +99,9 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
sys-devel/flex
virtual/yacc"
+
+RESTRICT="!test? ( test )"
+
if is_cross ; then
# The build assumes the host has libiberty and such when cross-compiling
# its build tools. We should probably make binutils itself build a local
diff --git a/net-nds/led/led-1.111.ebuild b/net-nds/led/led-1.111.ebuild
index dbd214b97ef8..441a72ed409c 100644
--- a/net-nds/led/led-1.111.ebuild
+++ b/net-nds/led/led-1.111.ebuild
@@ -1,26 +1,30 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils
-DESCRIPTION="led is a general purpose LDAP editor"
+DESCRIPTION="A general purpose LDAP editor"
HOMEPAGE="http://led.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=">=dev-lang/perl-5.6.1
+RDEPEND=">=dev-lang/perl-5.6.1
dev-perl/perl-ldap
dev-perl/URI
virtual/perl-Digest-MD5
dev-perl/Authen-SASL"
+DEPEND=${RDEPEND}
-src_compile() {
+src_configure() {
# non-standard configure system!
- perl Configure --prefix=/usr --generic --rfc2307 --shadow --iplanet
+ perl Configure --prefix=/usr --generic --rfc2307 --shadow --iplanet || die
+}
+
+src_compile() {
# parallel make bad
emake -j1
}
diff --git a/net-proxy/piper/piper-1.14.ebuild b/net-proxy/piper/piper-1.14.ebuild
index 1c3e950d7eff..7312876bd3dc 100644
--- a/net-proxy/piper/piper-1.14.ebuild
+++ b/net-proxy/piper/piper-1.14.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit flag-o-matic toolchain-funcs
-DESCRIPTION="Piper (a tool for manipulating SOCKS5 servers)"
+DESCRIPTION="A tool for manipulating SOCKS5 servers"
HOMEPAGE="http://www.qwirx.com/"
SRC_URI="http://www.qwirx.com/piper/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=""
-#RDEPEND=""
src_compile() {
append-flags -g -Wall
diff --git a/net-vpn/nstx/nstx-1.1_beta6-r3.ebuild b/net-vpn/nstx/nstx-1.1_beta6-r3.ebuild
index 2da45c3bb953..1bdf06b40b90 100644
--- a/net-vpn/nstx/nstx-1.1_beta6-r3.ebuild
+++ b/net-vpn/nstx/nstx-1.1_beta6-r3.ebuild
@@ -1,56 +1,50 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit versionator toolchain-funcs eutils linux-info
+inherit toolchain-funcs linux-info
-MY_PV=$(replace_version_separator 2 - "${PV}")
-MY_P="${PN}-${MY_PV}"
+MY_P="${PN}-${PV/_/-}"
DEBIAN_PV="5"
-DEBIAN_A="${PN}_${MY_PV}-${DEBIAN_PV}.diff.gz"
+DEBIAN_A="${MY_P/-/_}-${DEBIAN_PV}.diff.gz"
DESCRIPTION="IP over DNS tunnel"
-SRC_URI="http://dereference.de/nstx/${MY_P}.tgz
- mirror://debian/pool/main/${PN:0:1}/${PN}/${DEBIAN_A}"
HOMEPAGE="http://dereference.de/nstx/"
-DEPEND="virtual/os-headers"
+SRC_URI="http://dereference.de/nstx/${MY_P}.tgz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${DEBIAN_A}"
+S="${WORKDIR}/${MY_P}"
+
KEYWORDS="amd64 x86"
-IUSE=""
-LICENSE="GPL-2"
SLOT="0"
-S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-2+"
+IUSE=""
+
+DEPEND="virtual/os-headers"
CONFIG_CHECK="~TUN"
-src_unpack() {
- unpack "${MY_P}.tgz"
- epatch "${DISTDIR}"/${DEBIAN_A} \
- "${FILESDIR}"/${PN}-1.1_beta6_00-linux-tuntap.patch \
- "${FILESDIR}"/${PN}-1.1_beta6_01-bind-interface-name.patch \
- "${FILESDIR}"/${PN}-1.1_beta6_02-warn-on-frag.patch \
- "${FILESDIR}"/${PN}-1.1_beta6_03-delete-dwrite.patch \
- "${FILESDIR}"/${PN}-1.1_beta6_04-delete-werror.patch \
- "${FILESDIR}"/${PN}-1.1_beta6_05-respect-ldflags.patch
-}
+PATCHES=(
+ "${WORKDIR}"/${DEBIAN_A%.gz}
+ "${FILESDIR}"/${PN}-1.1_beta6_00-linux-tuntap.patch
+ "${FILESDIR}"/${PN}-1.1_beta6_01-bind-interface-name.patch
+ "${FILESDIR}"/${PN}-1.1_beta6_02-warn-on-frag.patch
+ "${FILESDIR}"/${PN}-1.1_beta6_03-delete-dwrite.patch
+ "${FILESDIR}"/${PN}-1.1_beta6_04-delete-werror.patch
+ "${FILESDIR}"/${PN}-1.1_beta6_05-respect-ldflags.patch
+)
src_compile() {
- emake CC="$(tc-getCC)" || die
+ emake CC="$(tc-getCC)"
}
src_install() {
- into /usr
- dosbin nstxcd nstxd || die
- dodoc README Changelog || die
- doman *.8 || die
+ dosbin nstxcd nstxd
+ dodoc README Changelog
+ doman *.8
newinitd "${FILESDIR}"/nstxd.init nstxd
newconfd "${FILESDIR}"/nstxd.conf nstxd
newinitd "${FILESDIR}"/nstxcd.init nstxcd
newconfd "${FILESDIR}"/nstxcd.conf nstxcd
}
-
-pkg_postinst() {
- einfo "Please read the documentation provided in"
- einfo " `find /usr/share/doc/${PF}/ -name 'README*'`"
-}
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.30-r4.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.30-r4.ebuild
index d4e225fa71d0..400a9dd6eaad 100644
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.30-r4.ebuild
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.30-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -73,6 +73,9 @@ DEPEND="${RDEPEND}
sys-devel/flex
virtual/yacc
"
+
+RESTRICT="!test? ( test )"
+
if is_cross ; then
# The build assumes the host has libiberty and such when cross-compiling
# its build tools. We should probably make binutils itself build a local
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.31.1-r6.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.31.1-r6.ebuild
index 79a2e1f7bd4a..0d7844e47004 100644
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.31.1-r6.ebuild
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.31.1-r6.ebuild
@@ -87,6 +87,8 @@ DEPEND="${RDEPEND}
virtual/yacc
"
+RESTRICT="!test? ( test )"
+
MY_BUILDDIR=${WORKDIR}/build
S=${WORKDIR}/${P/-hppa64/}
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.32-r1.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.32-r1.ebuild
index e2366d3c123f..9cea689fb6a9 100644
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.32-r1.ebuild
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.32-r1.ebuild
@@ -86,6 +86,8 @@ DEPEND="${RDEPEND}
virtual/yacc
"
+RESTRICT="!test? ( test )"
+
MY_BUILDDIR=${WORKDIR}/build
S=${WORKDIR}/${P/-hppa64/}
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.33.1.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.33.1.ebuild
index c635fcbef7b7..9c1e764963b4 100644
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.33.1.ebuild
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.33.1.ebuild
@@ -83,6 +83,8 @@ DEPEND="${RDEPEND}
virtual/yacc
"
+RESTRICT="!test? ( test )"
+
MY_BUILDDIR=${WORKDIR}/build
S=${WORKDIR}/${P/-hppa64/}
diff --git a/sys-devel/binutils/binutils-2.30-r4.ebuild b/sys-devel/binutils/binutils-2.30-r4.ebuild
index a64424ccd022..e57b8ed86e04 100644
--- a/sys-devel/binutils/binutils-2.30-r4.ebuild
+++ b/sys-devel/binutils/binutils-2.30-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -71,6 +71,9 @@ DEPEND="${RDEPEND}
sys-devel/flex
virtual/yacc
"
+
+RESTRICT="!test? ( test )"
+
if is_cross ; then
# The build assumes the host has libiberty and such when cross-compiling
# its build tools. We should probably make binutils itself build a local
diff --git a/sys-devel/binutils/binutils-2.31.1-r6.ebuild b/sys-devel/binutils/binutils-2.31.1-r6.ebuild
index 511d497ac38e..537b7b8ea786 100644
--- a/sys-devel/binutils/binutils-2.31.1-r6.ebuild
+++ b/sys-devel/binutils/binutils-2.31.1-r6.ebuild
@@ -87,6 +87,8 @@ DEPEND="${RDEPEND}
virtual/yacc
"
+RESTRICT="!test? ( test )"
+
MY_BUILDDIR=${WORKDIR}/build
src_unpack() {
diff --git a/sys-devel/binutils/binutils-2.32-r1.ebuild b/sys-devel/binutils/binutils-2.32-r1.ebuild
index ac19c27ce3ed..682714c5e9d1 100644
--- a/sys-devel/binutils/binutils-2.32-r1.ebuild
+++ b/sys-devel/binutils/binutils-2.32-r1.ebuild
@@ -87,6 +87,8 @@ DEPEND="${RDEPEND}
virtual/yacc
"
+RESTRICT="!test? ( test )"
+
MY_BUILDDIR=${WORKDIR}/build
src_unpack() {
diff --git a/sys-devel/binutils/binutils-2.33.1.ebuild b/sys-devel/binutils/binutils-2.33.1.ebuild
index 7d29c078994e..9a1640aa4078 100644
--- a/sys-devel/binutils/binutils-2.33.1.ebuild
+++ b/sys-devel/binutils/binutils-2.33.1.ebuild
@@ -81,6 +81,8 @@ DEPEND="${RDEPEND}
virtual/yacc
"
+RESTRICT="!test? ( test )"
+
MY_BUILDDIR=${WORKDIR}/build
src_unpack() {
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index b6fa9a073295..ffc9ebbec142 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -82,6 +82,8 @@ DEPEND="${RDEPEND}
virtual/yacc
"
+RESTRICT="!test? ( test )"
+
MY_BUILDDIR=${WORKDIR}/build
src_unpack() {