summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-12-15 22:51:08 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-12-15 22:51:08 +0000
commitb96e59c484d92a3ba0332ff372732c1fd966cf12 (patch)
tree1af0eaf0d52c1a820a4758130299a7afe538c78a
parent2017-12-15 21:25:09 UTC (diff)
parentsys-fs/cryptsetup: Enable argon2 USE flag by default. (diff)
downloadgentoo-b96e59c484d92a3ba0332ff372732c1fd966cf12.tar.gz
gentoo-b96e59c484d92a3ba0332ff372732c1fd966cf12.tar.bz2
gentoo-b96e59c484d92a3ba0332ff372732c1fd966cf12.zip
Merge updates from master
-rw-r--r--eclass/flag-o-matic.eclass2
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.0.0-r1.ebuild128
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild2
-rw-r--r--sys-libs/glibc/metadata.xml2
-rw-r--r--www-client/google-chrome-beta/Manifest2
-rw-r--r--www-client/google-chrome-beta/google-chrome-beta-64.0.3282.24.ebuild (renamed from www-client/google-chrome-beta/google-chrome-beta-63.0.3239.90.ebuild)2
-rw-r--r--www-client/google-chrome-unstable/Manifest2
-rw-r--r--www-client/google-chrome-unstable/google-chrome-unstable-65.0.3294.5.ebuild (renamed from www-client/google-chrome-unstable/google-chrome-unstable-64.0.3282.24.ebuild)0
-rw-r--r--www-client/google-chrome/Manifest2
-rw-r--r--www-client/google-chrome/google-chrome-63.0.3239.108.ebuild (renamed from www-client/google-chrome/google-chrome-63.0.3239.84.ebuild)0
-rw-r--r--www-plugins/chrome-binary-plugins/Manifest6
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-63.0.3239.108.ebuild (renamed from www-plugins/chrome-binary-plugins/chrome-binary-plugins-63.0.3239.84.ebuild)0
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-64.0.3282.24_beta.ebuild (renamed from www-plugins/chrome-binary-plugins/chrome-binary-plugins-63.0.3239.90_beta.ebuild)0
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-65.0.3294.5_alpha.ebuild (renamed from www-plugins/chrome-binary-plugins/chrome-binary-plugins-64.0.3282.24_alpha.ebuild)0
14 files changed, 138 insertions, 10 deletions
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index d14221624d6d..14b84fbdbebe 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -27,7 +27,7 @@ setup-allowed-flags() {
'-fstack-protector*' '-fsanitize*' '-fstack-check*' -fno-stack-check
-fbounds-check -fbounds-checking -fno-strict-overflow
-fno-PIE -fno-pie -nopie -no-pie -fno-unit-at-a-time
- -g '-g[0-9]' -ggdb '-ggdb[0-9]' '-gdwarf-*' gstabs -gstabs+
+ -g '-g[0-9]' -ggdb '-ggdb[0-9]' '-gdwarf-*' gstabs -gstabs+ -gz
-fno-ident -fpermissive -frecord-gcc-switches
'-fdiagnostics*' '-fplugin*'
'-W*' -w
diff --git a/sys-fs/cryptsetup/cryptsetup-2.0.0-r1.ebuild b/sys-fs/cryptsetup/cryptsetup-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..a3b51cfccd47
--- /dev/null
+++ b/sys-fs/cryptsetup/cryptsetup-2.0.0-r1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit autotools python-single-r1 linux-info libtool ltprune versionator
+
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="https://gitlab.com/cryptsetup/cryptsetup/blob/master/README.md"
+SRC_URI="mirror://kernel/linux/utils/${PN}/v$(get_version_component_range 1-2)/${P/_/-}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/12" # libcryptsetup.so version
+[[ ${PV} != *_rc* ]] && \
+KEYWORDS="~amd64 ~arm64 ~mips ~s390 ~sh ~sparc ~x86"
+CRYPTO_BACKENDS="+gcrypt kernel nettle openssl"
+# we don't support nss since it doesn't allow cryptsetup to be built statically
+# and it's missing ripemd160 support so it can't provide full backward compatibility
+IUSE="${CRYPTO_BACKENDS} argon2 libressl nls pwquality python reencrypt static static-libs udev urandom"
+REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ static? ( !gcrypt )" #496612
+
+LIB_DEPEND="
+ dev-libs/json-c[static-libs(+)]
+ dev-libs/libgpg-error[static-libs(+)]
+ dev-libs/popt[static-libs(+)]
+ sys-apps/util-linux[static-libs(+)]
+ argon2? ( app-crypt/argon2[static-libs(+)] )
+ gcrypt? ( dev-libs/libgcrypt:0=[static-libs(+)] )
+ nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
+ openssl? (
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
+ libressl? ( dev-libs/libressl:=[static-libs(+)] )
+ )
+ pwquality? ( dev-libs/libpwquality[static-libs(+)] )
+ sys-fs/lvm2[static-libs(+)]
+ udev? ( virtual/libudev[static-libs(+)] )"
+# We have to always depend on ${LIB_DEPEND} rather than put behind
+# !static? () because we provide a shared library which links against
+# these other packages. #414665
+RDEPEND="static-libs? ( ${LIB_DEPEND} )
+ ${LIB_DEPEND//\[static-libs\(+\)\]}
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+S="${WORKDIR}/${P/_/-}"
+
+#PATCHES=( )
+
+pkg_setup() {
+ local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC ~CRYPTO_SHA256"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
+ local WARNING_CRYPTO_SHA256="CONFIG_CRYPTO_SHA256:\tis not set (required for cryptsetup)\n"
+ local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
+ check_extra_config
+}
+
+src_prepare() {
+ sed -i '/^LOOPDEV=/s:$: || exit 0:' tests/{compat,mode}-test || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use kernel ; then
+ ewarn "Note that kernel backend is very slow for this type of operation"
+ ewarn "and is provided mainly for embedded systems wanting to avoid"
+ ewarn "userspace crypto libraries."
+ fi
+
+ use python && python_setup
+
+ # We disable autotool python integration so we can use eclasses
+ # for proper integration with multiple python versions.
+ local myeconfargs=(
+ --disable-internal-argon2
+ --enable-shared
+ --sbindir=/sbin
+ --with-tmpfilesdir="${EPREFIX%/}/usr/lib/tmpfiles.d"
+ --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
+ $(use_enable argon2 libargon2)
+ $(use_enable nls)
+ $(use_enable pwquality)
+ $(use_enable python)
+ $(use_enable reencrypt cryptsetup-reencrypt)
+ $(use_enable static static-cryptsetup)
+ $(use_enable static-libs static)
+ $(use_enable udev)
+ $(use_enable !urandom dev-random)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if [[ ! -e /dev/mapper/control ]] ; then
+ ewarn "No /dev/mapper/control found -- skipping tests"
+ return 0
+ fi
+
+ local p
+ for p in /dev/mapper /dev/loop* ; do
+ addwrite ${p}
+ done
+
+ default
+}
+
+src_install() {
+ default
+
+ if use static ; then
+ mv "${ED%}"/sbin/cryptsetup{.static,} || die
+ mv "${ED%}"/sbin/veritysetup{.static,} || die
+ use reencrypt && { mv "${ED%}"/sbin/cryptsetup-reencrypt{.static,} || die ; }
+ fi
+ prune_libtool_files --modules
+
+ dodoc docs/v*ReleaseNotes
+
+ newconfd "${FILESDIR}"/1.6.7-dmcrypt.confd dmcrypt
+ newinitd "${FILESDIR}"/1.6.7-dmcrypt.rc dmcrypt
+}
diff --git a/sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild b/sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild
index ecdf5fbd105f..3d7adacf8e2b 100644
--- a/sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-2.0.0.ebuild
@@ -19,7 +19,7 @@ KEYWORDS="~amd64 ~arm64 ~mips ~s390 ~sh ~sparc ~x86"
CRYPTO_BACKENDS="+gcrypt kernel nettle openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
-IUSE="${CRYPTO_BACKENDS} argon2 libressl nls pwquality python reencrypt static static-libs udev urandom"
+IUSE="${CRYPTO_BACKENDS} +argon2 libressl nls pwquality python reencrypt static static-libs udev urandom"
REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
python? ( ${PYTHON_REQUIRED_USE} )
static? ( !gcrypt )" #496612
diff --git a/sys-libs/glibc/metadata.xml b/sys-libs/glibc/metadata.xml
index b32c212616a7..a9538704369e 100644
--- a/sys-libs/glibc/metadata.xml
+++ b/sys-libs/glibc/metadata.xml
@@ -10,7 +10,7 @@
<flag name="debug">When USE=hardened, allow fortify/stack violations to dump core (SIGABRT) and not kill self (SIGKILL)</flag>
<flag name="gd">build memusage and memusagestat tools</flag>
<flag name="nscd">Build, and enable support for, the Name Service Cache Daemon</flag>
- <flag name="rpc">Enable obsolete RPC/NIS layers (disabling is experimental -- see bug 381391)</flag>
+ <flag name="rpc">Enable obsolete RPC/NIS layers</flag>
<flag name="suid">Make internal pt_chown helper setuid -- not needed if using Linux and have /dev/pts mounted with gid=5</flag>
<flag name="systemtap">enable systemtap static probe points</flag>
</use>
diff --git a/www-client/google-chrome-beta/Manifest b/www-client/google-chrome-beta/Manifest
index 53abc879c5bf..6782e8e2b9e7 100644
--- a/www-client/google-chrome-beta/Manifest
+++ b/www-client/google-chrome-beta/Manifest
@@ -1 +1 @@
-DIST google-chrome-beta_63.0.3239.90-1_amd64.deb 50131080 BLAKE2B 7363869e12612e3a0c7805e5fc08a9d057903152aa440c47b3fbf33917d0ee1ff1483b194bb15a1d04bf6c54e754cc2d0ba9fea4622a3bf77f2d26c8309d4941 SHA512 381551f1c0504e7073a43a78e069f330cb699155cb5f74ec372667361b7a85db33f1b9a070aa2b6c373a47bd9d855fedba06a95dba5052f085e204507c825e55
+DIST google-chrome-beta_64.0.3282.24-1_amd64.deb 52994522 BLAKE2B 9dd60e6bdf6977ced00ba47bc647e0cfe29f45fe30b81d5bfbc0406604c60245d28476da4b74210daf610e1c73ba8115e380a9fd3881f1f89afaa591ff97ebb5 SHA512 89c79bb3d1ee6eae8ed0823f79d6f90c644bb3032610f5b83ab1c8433755ca130e7e6455a479c1afdee70343095c891a0c0b10356a13c95b78b9f4411abf3660
diff --git a/www-client/google-chrome-beta/google-chrome-beta-63.0.3239.90.ebuild b/www-client/google-chrome-beta/google-chrome-beta-64.0.3282.24.ebuild
index 15a697bab362..266639cc2941 100644
--- a/www-client/google-chrome-beta/google-chrome-beta-63.0.3239.90.ebuild
+++ b/www-client/google-chrome-beta/google-chrome-beta-64.0.3282.24.ebuild
@@ -130,7 +130,7 @@ src_install() {
local size
for size in 16 22 24 32 48 64 128 256 ; do
- newicon -s ${size} "${CHROME_HOME}/product_logo_${size}.png" ${PN}.png
+ newicon -s ${size} "${CHROME_HOME}/product_logo_${size}_beta.png" ${PN}.png
done
pax-mark m "${CHROME_HOME}/chrome"
diff --git a/www-client/google-chrome-unstable/Manifest b/www-client/google-chrome-unstable/Manifest
index b254f2e401ba..f65d220a7a22 100644
--- a/www-client/google-chrome-unstable/Manifest
+++ b/www-client/google-chrome-unstable/Manifest
@@ -1 +1 @@
-DIST google-chrome-unstable_64.0.3282.24-1_amd64.deb 52944420 BLAKE2B 72b9171eb159471e9f690721f3e9c262e5205f208be72363b82c2311fd04f652fadaeb1bbc6b704d864bb67c69da4556e52577d082ef757005668beca54ab90b SHA512 23ef5ab9f72e78123739deed3f7a671e794b55c7ea28afa8d87bb3b2589611942d08ac713618348857ad3841dc94b692acd1e3494a2cf63f9918a03418926e5e
+DIST google-chrome-unstable_65.0.3294.5-1_amd64.deb 53115364 BLAKE2B ece7e4f82aca38bca313abe9896393876a73aa2256166bddca407ca1f7dde99d6d8cecd8f8c94c03ce4425cc3b9cba77a10e7dba476f49b17abda05dcc072881 SHA512 3c1eee8e477df2dbed1540af818f76ece0454125cc22ecb8dcf57fad6c499fe4972da61bfdb5e0e77ee15b060db196461bebe183b6b3fb813629a28a997286eb
diff --git a/www-client/google-chrome-unstable/google-chrome-unstable-64.0.3282.24.ebuild b/www-client/google-chrome-unstable/google-chrome-unstable-65.0.3294.5.ebuild
index 4c187d4a1953..4c187d4a1953 100644
--- a/www-client/google-chrome-unstable/google-chrome-unstable-64.0.3282.24.ebuild
+++ b/www-client/google-chrome-unstable/google-chrome-unstable-65.0.3294.5.ebuild
diff --git a/www-client/google-chrome/Manifest b/www-client/google-chrome/Manifest
index 23817669840b..5ef16fbc3b80 100644
--- a/www-client/google-chrome/Manifest
+++ b/www-client/google-chrome/Manifest
@@ -1 +1 @@
-DIST google-chrome-stable_63.0.3239.84-1_amd64.deb 49564190 BLAKE2B f9fb79c5e5f70bdbd197bf83a271d639a607693ffad9f507464990ee524bd51ec84a8f8e5542ab358df40bd654652ac5ab1f1c9eb5dfb2ba21415f9dcb2c1235 SHA512 2e7bb6a89c1f5eaa2017ab0e660351edf7c85bb579bf2b63e88e05aba789f968f594931c99189d34eacc116dc9b9c4a14f0676b8eb196e9e02abe0b2bb0f07cf
+DIST google-chrome-stable_63.0.3239.108-1_amd64.deb 49035482 BLAKE2B 9bf364e69232f6b6a9888e5525fcbda476e5e8bbe1bd138c3b78fdc6e8e88412fbc5a10d625139e4155d822983bac75be16d7682214f28470c6e9d9891a84703 SHA512 50a0eb154d550db3473f255f27b8297522660654ed344477c967f84926103056552f404ce411a8aa4041c1aa8142c7ab929097904236d8696eb37347abecfb74
diff --git a/www-client/google-chrome/google-chrome-63.0.3239.84.ebuild b/www-client/google-chrome/google-chrome-63.0.3239.108.ebuild
index eb98674ec422..eb98674ec422 100644
--- a/www-client/google-chrome/google-chrome-63.0.3239.84.ebuild
+++ b/www-client/google-chrome/google-chrome-63.0.3239.108.ebuild
diff --git a/www-plugins/chrome-binary-plugins/Manifest b/www-plugins/chrome-binary-plugins/Manifest
index 239a572d8a2b..5240c2fe69c8 100644
--- a/www-plugins/chrome-binary-plugins/Manifest
+++ b/www-plugins/chrome-binary-plugins/Manifest
@@ -1,3 +1,3 @@
-DIST google-chrome-beta_63.0.3239.90-1_amd64.deb 50131080 BLAKE2B 7363869e12612e3a0c7805e5fc08a9d057903152aa440c47b3fbf33917d0ee1ff1483b194bb15a1d04bf6c54e754cc2d0ba9fea4622a3bf77f2d26c8309d4941 SHA512 381551f1c0504e7073a43a78e069f330cb699155cb5f74ec372667361b7a85db33f1b9a070aa2b6c373a47bd9d855fedba06a95dba5052f085e204507c825e55
-DIST google-chrome-stable_63.0.3239.84-1_amd64.deb 49564190 BLAKE2B f9fb79c5e5f70bdbd197bf83a271d639a607693ffad9f507464990ee524bd51ec84a8f8e5542ab358df40bd654652ac5ab1f1c9eb5dfb2ba21415f9dcb2c1235 SHA512 2e7bb6a89c1f5eaa2017ab0e660351edf7c85bb579bf2b63e88e05aba789f968f594931c99189d34eacc116dc9b9c4a14f0676b8eb196e9e02abe0b2bb0f07cf
-DIST google-chrome-unstable_64.0.3282.24-1_amd64.deb 52944420 BLAKE2B 72b9171eb159471e9f690721f3e9c262e5205f208be72363b82c2311fd04f652fadaeb1bbc6b704d864bb67c69da4556e52577d082ef757005668beca54ab90b SHA512 23ef5ab9f72e78123739deed3f7a671e794b55c7ea28afa8d87bb3b2589611942d08ac713618348857ad3841dc94b692acd1e3494a2cf63f9918a03418926e5e
+DIST google-chrome-beta_64.0.3282.24-1_amd64.deb 52994522 BLAKE2B 9dd60e6bdf6977ced00ba47bc647e0cfe29f45fe30b81d5bfbc0406604c60245d28476da4b74210daf610e1c73ba8115e380a9fd3881f1f89afaa591ff97ebb5 SHA512 89c79bb3d1ee6eae8ed0823f79d6f90c644bb3032610f5b83ab1c8433755ca130e7e6455a479c1afdee70343095c891a0c0b10356a13c95b78b9f4411abf3660
+DIST google-chrome-stable_63.0.3239.108-1_amd64.deb 49035482 BLAKE2B 9bf364e69232f6b6a9888e5525fcbda476e5e8bbe1bd138c3b78fdc6e8e88412fbc5a10d625139e4155d822983bac75be16d7682214f28470c6e9d9891a84703 SHA512 50a0eb154d550db3473f255f27b8297522660654ed344477c967f84926103056552f404ce411a8aa4041c1aa8142c7ab929097904236d8696eb37347abecfb74
+DIST google-chrome-unstable_65.0.3294.5-1_amd64.deb 53115364 BLAKE2B ece7e4f82aca38bca313abe9896393876a73aa2256166bddca407ca1f7dde99d6d8cecd8f8c94c03ce4425cc3b9cba77a10e7dba476f49b17abda05dcc072881 SHA512 3c1eee8e477df2dbed1540af818f76ece0454125cc22ecb8dcf57fad6c499fe4972da61bfdb5e0e77ee15b060db196461bebe183b6b3fb813629a28a997286eb
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-63.0.3239.84.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-63.0.3239.108.ebuild
index 8173f0b7f5f0..8173f0b7f5f0 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-63.0.3239.84.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-63.0.3239.108.ebuild
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-63.0.3239.90_beta.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-64.0.3282.24_beta.ebuild
index fb901aa5d5d9..fb901aa5d5d9 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-63.0.3239.90_beta.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-64.0.3282.24_beta.ebuild
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-64.0.3282.24_alpha.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-65.0.3294.5_alpha.ebuild
index fb901aa5d5d9..fb901aa5d5d9 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-64.0.3282.24_alpha.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-65.0.3294.5_alpha.ebuild