summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-08-23 12:04:53 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-08-24 14:20:04 +0200
commitb53e06123dc49a0cdb965fee76a9533038a56a88 (patch)
treee02af269e512798120ee9a75597cdba4669399b6
parentacct-user/airdcppd: new user for net-p2p/airdcpp-webclient (diff)
downloadgentoo-b53e06123dc49a0cdb965fee76a9533038a56a88.tar.gz
gentoo-b53e06123dc49a0cdb965fee76a9533038a56a88.tar.bz2
gentoo-b53e06123dc49a0cdb965fee76a9533038a56a88.zip
net-p2p/airdcpp-webclient: v2.8.1, migrate to acct-user, misc. fixes
* Migrate to cmake.eclass * Add a systemd unit * Add Python 3.8 and 3.9 support * Add a debug USE flag * Move some dependencies to BDEPEND Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.8.1.ebuild60
-rw-r--r--net-p2p/airdcpp-webclient/files/airdcppd.service15
3 files changed, 76 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 838597c56439..a8a782337d97 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-2.6.0.tar.gz 903873 BLAKE2B 7a82891efef14e8d3c2da9a15165698084daf9c044d420c271dd1401710f030fc3c6fd83d7f58cee746767624b1292e7fcb7a48387e03b0eca2cf779753686d8 SHA512 d6d029638e69d19743d2e49185b08a808d95d725c3f40bd98ab42c384d3eae6d07e4528ac28ac9db50011f8a68592ae60f49cedbbccb45a78e82a5e424bb731c
DIST airdcpp-webclient-2.6.1.tar.gz 908393 BLAKE2B 8734cdfc1b0e380d231cf6e571d215b7cec196fe012bf842fd2257496f252dd803eee0a308e97033f959652dbd4d21bd2b96559c4a4262a8f7ddd2c491c7d263 SHA512 bad35d09475ef9a95f358bce99d1143586e3eedb58b3c5c74570c707f099ed1b1214714c093f74c6e2bbfa733077dcaf3e590ae3d821330938f9ec32c75a7152
+DIST airdcpp-webclient-2.8.1.tar.gz 945274 BLAKE2B e98ea603d52f041fed1a60a2c6dd4bff141c230bd554ccc6e7f013a28bd2ef8f2001e5343d3233d09b7cc9ef7e1af8b45a18757f59d29cdfb592763375c01e0c SHA512 c75b20591deb62a62dfb26df1536c521073643d3d7893d2ac85f2206c52a1786349a980994084abf840d1610000128247e6ae94aecf31b1d5266224086257ca7
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.8.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.8.1.ebuild
new file mode 100644
index 000000000000..acb5cd4995b0
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.8.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit cmake python-any-r1 systemd
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug nat-pmp +tbb +webui"
+
+RDEPEND="
+ acct-user/airdcppd
+ acct-group/airdcppd
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ -DINSTALL_WEB_UI=OFF
+ )
+ CMAKE_BUILD_TYPE=$(usex debug Debug Gentoo) cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ systemd_dounit "${FILESDIR}/airdcppd.service"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}
diff --git a/net-p2p/airdcpp-webclient/files/airdcppd.service b/net-p2p/airdcpp-webclient/files/airdcppd.service
new file mode 100644
index 000000000000..00d4ea071865
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/files/airdcppd.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Cross-platform Direct Connect client
+After=network-online.target
+
+[Service]
+Type=forking
+User=airdcppd
+Group=airdcppd
+# Grant write access to group members
+UMask=007
+PIDFile=/var/lib/airdcppd/.airdc++/airdcppd.pid
+ExecStart=/usr/bin/airdcppd -d
+
+[Install]
+WantedBy=multi-user.target