summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-21 11:25:41 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-21 11:55:24 +0200
commitb371ed15c2774e22a81edcd52f6c3580d65543c0 (patch)
treec9ac14abd6343a2a6f467d96d92c47b545671721
parentsci-astronomy/ds9-bin: drop 7.2 (diff)
downloadgentoo-b371ed15c2774e22a81edcd52f6c3580d65543c0.tar.gz
gentoo-b371ed15c2774e22a81edcd52f6c3580d65543c0.tar.bz2
gentoo-b371ed15c2774e22a81edcd52f6c3580d65543c0.zip
sci-libs/cgcode: Port to EAPI 8
Closes: https://bugs.gentoo.org/688888 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--sci-libs/cgcode/cgcode-1.0-r2.ebuild20
-rw-r--r--sci-libs/cgcode/files/1.0-gentoo.patch6
2 files changed, 11 insertions, 15 deletions
diff --git a/sci-libs/cgcode/cgcode-1.0-r2.ebuild b/sci-libs/cgcode/cgcode-1.0-r2.ebuild
index dbb7d0622da8..6fe1ddee3b21 100644
--- a/sci-libs/cgcode/cgcode-1.0-r2.ebuild
+++ b/sci-libs/cgcode/cgcode-1.0-r2.ebuild
@@ -1,33 +1,35 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch fortran-2 flag-o-matic toolchain-funcs
+inherit fortran-2 flag-o-matic toolchain-funcs
DESCRIPTION="Conjugate gradient Codes for large sparse linear systems"
HOMEPAGE="http://fetk.org/codes/cgcode/index.html"
SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-LICENSE="GPL-2"
-IUSE=""
RDEPEND="virtual/blas"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}"/${PN}
+PATCHES=(
+ "${FILESDIR}"/${PV}-gentoo.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PV}-gentoo.patch
+ default
# GCC 10 workaround
# bug #722000
append-fflags $(test-flags-FC -fallow-argument-mismatch)
- cat >> make.inc <<- EOF
+ cat >> make.inc <<- EOF || die
F77 = $(tc-getFC)
FFLAGS = ${FFLAGS}
BLASLIBS = $($(tc-getPKG_CONFIG) --libs blas)
diff --git a/sci-libs/cgcode/files/1.0-gentoo.patch b/sci-libs/cgcode/files/1.0-gentoo.patch
index 612ca9e06497..449f1f18dde5 100644
--- a/sci-libs/cgcode/files/1.0-gentoo.patch
+++ b/sci-libs/cgcode/files/1.0-gentoo.patch
@@ -1,5 +1,3 @@
-diff --git a/makefile b/makefile
-index 4813b55..f20af02 100644
--- a/makefile
+++ b/makefile
@@ -1,21 +1,23 @@
@@ -33,8 +31,6 @@ index 4813b55..f20af02 100644
clean :
rm -f *.o goos good
-diff --git a/src/makefile b/src/makefile
-index 10cf6c3..1dfd02d 100644
--- a/src/makefile
+++ b/src/makefile
@@ -1,16 +1,17 @@
@@ -60,8 +56,6 @@ index 10cf6c3..1dfd02d 100644
clean :
rm -f *.o $(THISLIB)
-diff --git a/util/makefile b/util/makefile
-index 6dad0d1..5c9d24f 100644
--- a/util/makefile
+++ b/util/makefile
@@ -6,11 +6,12 @@ SOBJLIB = saxpy.o scopy.o sdot.o snrm2.o sscal.o