summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-26 10:53:20 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-26 11:48:30 +0100
commitb0b2554899b7adfcb4ac1340ef88f25afdd10378 (patch)
tree52286f3f462c31cc84ff9abdb07065255a944a7e
parentwww-servers/apache: Renamed CDEPEND to COMMON_DEPEND (diff)
downloadgentoo-b0b2554899b7adfcb4ac1340ef88f25afdd10378.tar.gz
gentoo-b0b2554899b7adfcb4ac1340ef88f25afdd10378.tar.bz2
gentoo-b0b2554899b7adfcb4ac1340ef88f25afdd10378.zip
www-servers/apache: Moved IUSE handling back to eclass
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--eclass/apache-2.eclass12
-rw-r--r--www-servers/apache/apache-2.4.46-r1.ebuild6
-rw-r--r--www-servers/apache/apache-2.4.46-r4.ebuild6
-rw-r--r--www-servers/apache/apache-2.4.46.ebuild6
4 files changed, 10 insertions, 20 deletions
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index 9e80b914afe4..e51c12cb0a28 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -88,10 +88,18 @@ SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2
# built-in modules
IUSE_MPMS="${IUSE_MPMS_FORK} ${IUSE_MPMS_THREAD}"
-IUSE="${IUSE} debug doc gdbm ldap libressl selinux ssl static suexec threads"
+IUSE="${IUSE} debug doc gdbm ldap libressl selinux ssl static suexec +suexec-caps suexec-syslog split-usr threads"
for module in ${IUSE_MODULES} ; do
- IUSE="${IUSE} apache2_modules_${module}"
+ case ${module} in
+ # Enable http2 by default (bug #563452)
+ http2)
+ IUSE+=" +apache2_modules_${module}"
+ ;;
+ *)
+ IUSE+=" apache2_modules_${module}"
+ ;;
+ esac
done
_apache2_set_mpms() {
diff --git a/www-servers/apache/apache-2.4.46-r1.ebuild b/www-servers/apache/apache-2.4.46-r1.ebuild
index de842ec792ef..16149fb8b80f 100644
--- a/www-servers/apache/apache-2.4.46-r1.ebuild
+++ b/www-servers/apache/apache-2.4.46-r1.ebuild
@@ -140,12 +140,6 @@ LICENSE="Apache-2.0 Apache-1.1"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x64-macos ~sparc64-solaris ~x64-solaris"
-# Enable http2 by default (bug #563452)
-# FIXME: Move to apache-2.eclass once this has reached stable.
-IUSE="${IUSE/apache2_modules_http2/+apache2_modules_http2}"
-# New suexec options (since 2.4.34)
-IUSE="${IUSE} +suexec-caps suexec-syslog split-usr"
-
COMMON_DEPEND="apache2_modules_brotli? ( >=app-arch/brotli-0.6.0:= )
apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )
apache2_modules_proxy_http2? ( >=net-libs/nghttp2-1.2.1 )
diff --git a/www-servers/apache/apache-2.4.46-r4.ebuild b/www-servers/apache/apache-2.4.46-r4.ebuild
index 8a6aea0662a1..676c0e2d246a 100644
--- a/www-servers/apache/apache-2.4.46-r4.ebuild
+++ b/www-servers/apache/apache-2.4.46-r4.ebuild
@@ -140,12 +140,6 @@ LICENSE="Apache-2.0 Apache-1.1"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x64-macos ~sparc64-solaris ~x64-solaris"
-# Enable http2 by default (bug #563452)
-# FIXME: Move to apache-2.eclass once this has reached stable.
-IUSE="${IUSE/apache2_modules_http2/+apache2_modules_http2}"
-# New suexec options (since 2.4.34)
-IUSE="${IUSE} +suexec-caps suexec-syslog split-usr"
-
COMMON_DEPEND="apache2_modules_brotli? ( >=app-arch/brotli-0.6.0:= )
apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )
apache2_modules_proxy_http2? ( >=net-libs/nghttp2-1.2.1 )
diff --git a/www-servers/apache/apache-2.4.46.ebuild b/www-servers/apache/apache-2.4.46.ebuild
index b4a4b7d7fb40..828a9a1a8348 100644
--- a/www-servers/apache/apache-2.4.46.ebuild
+++ b/www-servers/apache/apache-2.4.46.ebuild
@@ -138,12 +138,6 @@ LICENSE="Apache-2.0 Apache-1.1"
SLOT="2"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x64-macos ~sparc64-solaris ~x64-solaris"
-# Enable http2 by default (bug #563452)
-# FIXME: Move to apache-2.eclass once this has reached stable.
-IUSE="${IUSE/apache2_modules_http2/+apache2_modules_http2}"
-# New suexec options (since 2.4.34)
-IUSE="${IUSE} +suexec-caps suexec-syslog split-usr"
-
COMMON_DEPEND="apache2_modules_brotli? ( >=app-arch/brotli-0.6.0:= )
apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )
apache2_modules_proxy_http2? ( >=net-libs/nghttp2-1.2.1 )