summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-07-26 14:02:09 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-07-26 14:02:09 +0000
commit9e8ad56b36eedcd3f8074758ddf3eaba038b7476 (patch)
treea89eda16bd9bc67ae301e7bf5082d5f7e76a6513
parent2016-07-26 13:27:43 UTC (diff)
parentapp-accessibility/espeakup: 0.80 version bump (diff)
downloadgentoo-9e8ad56b36eedcd3f8074758ddf3eaba038b7476.tar.gz
gentoo-9e8ad56b36eedcd3f8074758ddf3eaba038b7476.tar.bz2
gentoo-9e8ad56b36eedcd3f8074758ddf3eaba038b7476.zip
Merge updates from master
-rw-r--r--app-accessibility/espeakup/Manifest1
-rw-r--r--app-accessibility/espeakup/espeakup-0.80.ebuild63
-rw-r--r--app-text/poppler/poppler-0.45.0.ebuild2
-rw-r--r--net-analyzer/tcpdump/Manifest1
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.8.0.ebuild98
-rw-r--r--net-analyzer/tcpdump/tcpdump-9999.ebuild7
-rw-r--r--net-libs/libpcap/Manifest1
-rw-r--r--net-libs/libpcap/libpcap-1.8.0.ebuild78
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild21
9 files changed, 258 insertions, 14 deletions
diff --git a/app-accessibility/espeakup/Manifest b/app-accessibility/espeakup/Manifest
index d37f8fcc5be8..e9fa11c19115 100644
--- a/app-accessibility/espeakup/Manifest
+++ b/app-accessibility/espeakup/Manifest
@@ -1 +1,2 @@
DIST espeakup-0.71.tar.bz2 24663 SHA256 8307986998256db21e615c4edc1befedde28a6995971da258e9d513dd79bd3ab SHA512 01091560cd4843897fa6925a54b4c856fe57ed5728ddc0c091c93b1ae14eb2f4d07ab2247e40bd5a5968cc22ee3696abfe1b28f67b95aa7ab61e33667c51135d WHIRLPOOL 8cc6d335e40a560c14ed17fddc475473722606c7e98148f2f3aa786443b49bdee343cfa0c85e845ce79e8c0bdd330825232512e67869bf8aed6fac81d5e3f4b8
+DIST espeakup-0.80.tar.gz 39626 SHA256 4de284e30b6bdb0f9dee9c8ea02d13a3d20a61415b812338446b8b381e997ef4 SHA512 1b7e2bd46c3c13a5305746d2d2810ec94a8660f561e4f679ee4779be1b22178f8ac7de42d626d649710509f7b087b9a2f94608bde203d1bcd6d353229ed9ff83 WHIRLPOOL 911c3326631c36a6515b4e109421bfa76847a0803617cb1490ea5779024d38ae5ec0568aaee47b1691b816e24346624fda383ca89ae926c50d36aa0cea4f3a8c
diff --git a/app-accessibility/espeakup/espeakup-0.80.ebuild b/app-accessibility/espeakup/espeakup-0.80.ebuild
new file mode 100644
index 000000000000..c50eee21a251
--- /dev/null
+++ b/app-accessibility/espeakup/espeakup-0.80.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/williamh/espeakup.git"
+ inherit git-r3
+else
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://github.com/williamh/espeakup/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ inherit vcs-snapshot
+fi
+
+inherit linux-info
+
+DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
+HOMEPAGE="https://github.com/williamh/espeakup"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="|| (
+ app-accessibility/espeak[portaudio]
+ app-accessibility/espeak[pulseaudio] )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
+ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
+ERROR_SPEAKUP_SYNTH_SOFT="CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
+
+pkg_setup() {
+ if kernel_is -ge 2 6 37; then
+ check_extra_config
+ elif ! has_version app-accessibility/speakup; then
+ ewarn "Cannot find speakup on your system."
+ ewarn "Please upgrade your kernel to 2.6.37 or later and enable the"
+ ewarn "CONFIG_SPEAKUP and CONFIG_SPEAKUP_SYNTH_SOFT options"
+ ewarn "or install app-accessibility/speakup."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ einstalldocs
+ newconfd "${FILESDIR}"/espeakup.confd espeakup
+ newinitd "${FILESDIR}"/espeakup.rc espeakup
+}
+
+pkg_postinst() {
+ elog "To get espeakup to start automatically, it is currently recommended"
+ elog "that you add it to the default run level, by giving the following"
+ elog "command as root."
+ elog
+ elog "rc-update add espeakup default"
+ elog
+ elog "You can also set a default voice now for espeakup."
+ elog "See /etc/conf.d/espeakup for how to do this."
+}
diff --git a/app-text/poppler/poppler-0.45.0.ebuild b/app-text/poppler/poppler-0.45.0.ebuild
index c6e4a3972887..1260acbebff7 100644
--- a/app-text/poppler/poppler-0.45.0.ebuild
+++ b/app-text/poppler/poppler-0.45.0.ebuild
@@ -12,7 +12,7 @@ if [[ "${PV}" == "9999" ]] ; then
SLOT="0/9999"
else
SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT="0/62" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
fi
diff --git a/net-analyzer/tcpdump/Manifest b/net-analyzer/tcpdump/Manifest
index dd684034e061..d3b9358f8a3c 100644
--- a/net-analyzer/tcpdump/Manifest
+++ b/net-analyzer/tcpdump/Manifest
@@ -1 +1,2 @@
DIST tcpdump-4.7.4.tar.gz 1153657 SHA256 6be520269a89036f99c0b2126713a60965953eab921002b07608ccfc0c47d9af SHA512 5660d82abdf7327c3e1717db519b2c98cd217fff17440019f3ccf166b3cb28ab1c1850b7c42f8c6ee38110838bb8a4a10cd394f25123783bb3d58e1f350ef326 WHIRLPOOL 7c320adf64bf5ff57af7f98fec9919ba3c07056fbbbe1c8a87ac73ecb767ce245c4963e69e24ff71704be7b42dc604992f261173a34b12a87cd0eab153762816
+DIST tcpdump-4.8.0.tar.gz 1149698 SHA256 6d80fe345d0f5ee42fd273bfafe076231ad700c2daaf56805d17dc8159a6d1a7 SHA512 c35b26bd170706116a5274846f967893c2d6f1f67082c0aa264d0811b6bdd2d7bd9dcde3f725179b0916c0160088bc87298af061179d2f1ca47a0f3e2cd870ab WHIRLPOOL 43129349417cb68b2076efb2d01683f122d998d98e625e39edc25c336d06fc714ccb06beb85e8ce4bcbe12f185cff9865c27583e242420dd3b44b7b26dd3ca90
diff --git a/net-analyzer/tcpdump/tcpdump-4.8.0.ebuild b/net-analyzer/tcpdump/tcpdump-4.8.0.ebuild
new file mode 100644
index 000000000000..94f6eabd06e0
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-4.8.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit flag-o-matic toolchain-funcs user
+
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="
+ https://github.com/the-${PN}-group/${PN}/archive/${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+drop-root libressl smi ssl samba suid test"
+
+RDEPEND="
+ drop-root? ( sys-libs/libcap-ng )
+ net-libs/libpcap
+ smi? ( net-libs/libsmi )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6m:0 )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ drop-root? ( virtual/pkgconfig )
+ test? (
+ || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
+ dev-lang/perl
+ )
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+pkg_setup() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+src_configure() {
+ # tcpdump needs some optimization. see bug #108391
+ # but do not replace -Os
+ filter-flags -O[0-9]
+ has -O? ${CFLAGS} || append-cflags -O2
+
+ filter-flags -finline-functions
+
+ if use drop-root; then
+ append-cppflags -DHAVE_CAP_NG_H
+ export LIBS=$( $(tc-getPKG_CONFIG) --libs libcap-ng )
+ fi
+
+ econf \
+ $(use_enable samba smb) \
+ $(use_with drop-root chroot '') \
+ $(use_with smi) \
+ $(use_with ssl crypto "${EPREFIX}/usr") \
+ $(usex drop-root "--with-user=tcpdump" "")
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] || ! use drop-root; then
+ sed -i -e '/^\(espudp1\|eapon1\)/d;' tests/TESTLIST || die
+ emake check
+ else
+ ewarn "If you want to run the test suite, make sure you either"
+ ewarn "set FEATURES=userpriv or set USE=-drop-root"
+ fi
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc CHANGES CREDITS README.md
+
+ if use suid; then
+ fowners root:tcpdump /usr/sbin/tcpdump
+ fperms 4110 /usr/sbin/tcpdump
+ fi
+}
+
+pkg_preinst() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+pkg_postinst() {
+ use suid && elog "To let normal users run tcpdump add them into tcpdump group."
+}
diff --git a/net-analyzer/tcpdump/tcpdump-9999.ebuild b/net-analyzer/tcpdump/tcpdump-9999.ebuild
index 7ca91164ec8c..f19a0c4ec801 100644
--- a/net-analyzer/tcpdump/tcpdump-9999.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils flag-o-matic git-r3 toolchain-funcs user
DESCRIPTION="A Tool for network monitoring and data acquisition"
@@ -12,7 +12,7 @@ EGIT_REPO_URI="https://github.com/the-tcpdump-group/tcpdump"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="+drop-root libressl smi ssl ipv6 samba suid test"
+IUSE="+drop-root libressl smi ssl samba suid test"
RDEPEND="
drop-root? ( sys-libs/libcap-ng )
@@ -53,7 +53,6 @@ src_configure() {
fi
econf \
- $(use_enable ipv6) \
$(use_enable samba smb) \
$(use_with drop-root chroot '') \
$(use_with smi) \
diff --git a/net-libs/libpcap/Manifest b/net-libs/libpcap/Manifest
index 935a2beb3180..d433f5921ed2 100644
--- a/net-libs/libpcap/Manifest
+++ b/net-libs/libpcap/Manifest
@@ -1 +1,2 @@
DIST libpcap-1.7.4.tar.gz 663021 SHA256 7ad3112187e88328b85e46dce7a9b949632af18ee74d97ffc3f2b41fe7f448b0 SHA512 83c55aa4173a90e8080a63dc6f0faeb4339d5def998abb9a578f08210c1784a1787ac6975f8bd27b02f8854dd18f03a23c1cd5fa611f46247090b2cc13943cf9 WHIRLPOOL b74cb9f55fd58f4521b0c074ae71448af8bc9e3d66577b6631b5ee59e27cca40f38519b9f2ab097755bd5a86a298bb3edb6d37aad9d0530060eb7ec9dc6221a8
+DIST libpcap-1.8.0.tar.gz 698506 SHA256 aef925af509cfe8c50224299a2748b0fbf85e4ae6cf1c5ce332f9eb240d8761f SHA512 1d8d455f64c67627e12e9b4e8fa7d311fa71e63db1864f7287bb8cf598f0b51a178cf92e0ad8c1c6d0229b8b8d23aa493450e324af1ec5f35acee9a9fd0254f7 WHIRLPOOL 2ec86289dd18e807a96b54475b6651e12c7920594494f43dc31bdb29713c5208ccacace33954a23031b5dbd3984a91d85deca7bd54daccf7a4460ef2589b1764
diff --git a/net-libs/libpcap/libpcap-1.8.0.ebuild b/net-libs/libpcap/libpcap-1.8.0.ebuild
new file mode 100644
index 000000000000..93bda60507b5
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.8.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="
+ https://github.com/the-tcpdump-group/${PN}/archive/${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth dbus ipv6 netlink static-libs canusb"
+
+RDEPEND="
+ bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ netlink? ( dev-libs/libnl:3[${MULTILIB_USEDEP}] )
+ canusb? ( virtual/libusb:1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ dbus? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
+ "${FILESDIR}"/${PN}-1.6.1-configure.patch
+ "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
+ "${FILESDIR}"/${PN}-1.7.2-libnl.patch
+ )
+src_prepare() {
+ default
+
+ mkdir bluetooth || die
+ cp "${FILESDIR}"/mgmt.h bluetooth/ || die
+
+ eapply_user
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable ipv6) \
+ $(use_enable canusb) \
+ $(use_enable dbus) \
+ $(use_with netlink libnl)
+}
+
+multilib_src_compile() {
+ emake all shared
+}
+
+multilib_src_install_all() {
+ dodoc CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel}
+
+ # remove static libraries (--disable-static does not work)
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -exec rm {} + || die
+ fi
+ prune_libtool_files
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h
+ fi
+}
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index 5a09a1502eb8..1c311cddf268 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit autotools eutils git-r3 multilib-minimal
DESCRIPTION="A system-independent library for user-level network packet capture"
@@ -12,7 +12,7 @@ EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="bluetooth dbus ipv6 netlink static-libs canusb"
+IUSE="bluetooth dbus netlink static-libs canusb"
RDEPEND="
bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
@@ -26,16 +26,20 @@ DEPEND="${RDEPEND}
dbus? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
+ "${FILESDIR}"/${PN}-1.6.1-configure.patch
+ "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
+ "${FILESDIR}"/${PN}-1.7.2-libnl.patch
+ )
src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch \
- "${FILESDIR}"/${PN}-1.6.1-configure.patch \
- "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch \
- "${FILESDIR}"/${PN}-1.7.2-libnl.patch
+ default
mkdir bluetooth || die
cp "${FILESDIR}"/mgmt.h bluetooth/ || die
+ eapply_user
+
eautoreconf
}
@@ -43,7 +47,6 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \
$(use_enable bluetooth) \
- $(use_enable ipv6) \
$(use_enable canusb) \
$(use_enable dbus) \
$(use_with netlink libnl)