summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-01 06:37:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-01 07:06:16 +0200
commit9dedf30623dab509e30b38d08134bc418ab940d9 (patch)
tree80f9d43ef50311eec2b666419778ece09758756b
parentdev-python/cfn-lint: Bump to 0.79.8 (diff)
downloadgentoo-9dedf30623dab509e30b38d08134bc418ab940d9.tar.gz
gentoo-9dedf30623dab509e30b38d08134bc418ab940d9.tar.bz2
gentoo-9dedf30623dab509e30b38d08134bc418ab940d9.zip
dev-python/pytest-regressions: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-regressions/Manifest1
-rw-r--r--dev-python/pytest-regressions/pytest-regressions-2.5.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pytest-regressions/Manifest b/dev-python/pytest-regressions/Manifest
index 9a098b95ec93..ff5051faff4a 100644
--- a/dev-python/pytest-regressions/Manifest
+++ b/dev-python/pytest-regressions/Manifest
@@ -1,2 +1,3 @@
DIST pytest-regressions-2.4.2.tar.gz 111030 BLAKE2B 4c1d3ce9a210b6156e046b91688aec6ecab53d4719b5b556cdf6773a6af891352f7f213259140fdb7234f2528dbad5bf5c4ed43431aee94bfd373dd1839c1231 SHA512 f5abcc09da7a466e446329737d4926d3c7c9ac274e1087e6f746fe263b4cfd1b0f4b8870eea3d22b1209a0d5ead7b7169e700d10f3f29bb978e12a33511b1f51
DIST pytest-regressions-2.4.3.tar.gz 111049 BLAKE2B a9b11ec715c49f63c5972bad6332715b22efd363c70f067c4c077ae0e9af64178edb98aa36cd4d24287db4b2705367c18c09795b7830a09e2007c7da8a078964 SHA512 4264e2d791f6235b5de57a45550f8d0d0a6d3f7f10b40095698670daa8848005bc44c3cb2c11d793b58eb8b27e3910042c63fd4c0bd573ed57615d570e9e7d8b
+DIST pytest-regressions-2.5.0.tar.gz 113615 BLAKE2B 3364893a9cd96a44611d023c08fe5e319ceaad5a6a9b210b72095a560c42742c871406de1290821ea5cd61960bf5bef72d08bd143db93b20f288d5367cf1ae70 SHA512 2d23568b8d5dbc86000c9b552c72a1e269fafe79e0b829f799fe31ecc142e74d233c69940a51d2da457c6f7b3713fcd788461b0420eca9d56cc395568c517c0f
diff --git a/dev-python/pytest-regressions/pytest-regressions-2.5.0.ebuild b/dev-python/pytest-regressions/pytest-regressions-2.5.0.ebuild
new file mode 100644
index 000000000000..2656b1b8d726
--- /dev/null
+++ b/dev-python/pytest-regressions/pytest-regressions-2.5.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easy to use fixtures to write regression tests"
+HOMEPAGE="
+ https://github.com/ESSS/pytest-regressions/
+ https://pypi.org/project/pytest-regressions/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-datadir[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/matplotlib[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py::test_image_regression
+ )
+ fi
+ if ! has_version "dev-python/numpy[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_ndarrays_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_filenames.py::test_foo
+ tests/test_filenames.py::TestClass::test_foo
+ tests/test_filenames.py::TestClassWithIgnoredName::test_foo
+ )
+ EPYTEST_IGNORE+=(
+ tests/test_dataframe_regression.py
+ tests/test_num_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pillow[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py
+ )
+ fi
+
+ epytest
+}