summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-01-29 15:21:41 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-01-29 15:21:41 +0000
commit9830f4ebd56f8bf1220297f9f962286efc59af79 (patch)
treeecc952ee076626691f4c50be980c4b29a67c2276
parent2022-01-29 14:36:54 UTC (diff)
parentdev-python/ipywidgets: Switch to PEP 517 build (diff)
downloadgentoo-9830f4ebd56f8bf1220297f9f962286efc59af79.tar.gz
gentoo-9830f4ebd56f8bf1220297f9f962286efc59af79.tar.bz2
gentoo-9830f4ebd56f8bf1220297f9f962286efc59af79.zip
Merge updates from master
-rw-r--r--dev-python/empy/empy-3.3.4-r1.ebuild37
-rw-r--r--dev-python/entrypoints/entrypoints-0.3-r3.ebuild19
-rw-r--r--dev-python/eradicate/eradicate-2.0.0-r1.ebuild21
-rw-r--r--dev-python/httpauth/httpauth-0.3-r1.ebuild19
-rw-r--r--dev-python/ipaddr/ipaddr-2.2.0-r2.ebuild25
-rw-r--r--dev-python/ipy/ipy-1.01-r1.ebuild36
-rw-r--r--dev-python/ipython_genutils/ipython_genutils-0.2.0-r3.ebuild22
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild32
8 files changed, 211 insertions, 0 deletions
diff --git a/dev-python/empy/empy-3.3.4-r1.ebuild b/dev-python/empy/empy-3.3.4-r1.ebuild
new file mode 100644
index 000000000000..93a4db847ee6
--- /dev/null
+++ b/dev-python/empy/empy-3.3.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful and robust templating system for Python"
+HOMEPAGE="http://www.alcyone.com/software/empy/"
+SRC_URI="http://www.alcyone.com/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="doc"
+
+python_test() {
+ "${PYTHON}" em.py sample.em | diff sample.bench -
+ assert "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ docinto examples
+ dodoc sample.em sample.bench
+ # 3.3 has the html in this funny place. Fix in later version:
+ docinto html
+ dodoc doc/home/max/projects/empy/doc/em/*
+ dodoc doc/home/max/projects/empy/doc/em.html
+ dodoc doc/index.html
+ fi
+}
diff --git a/dev-python/entrypoints/entrypoints-0.3-r3.ebuild b/dev-python/entrypoints/entrypoints-0.3-r3.ebuild
new file mode 100644
index 000000000000..1f220ff7c478
--- /dev/null
+++ b/dev-python/entrypoints/entrypoints-0.3-r3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Discover and load entry points from installed packages"
+HOMEPAGE="https://github.com/takluyver/entrypoints"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
diff --git a/dev-python/eradicate/eradicate-2.0.0-r1.ebuild b/dev-python/eradicate/eradicate-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..3d56e702338b
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.0.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="https://github.com/myint/eradicate"
+# TODO: revert to PyPI tarball once it includes tests
+# https://github.com/myint/eradicate/pull/28
+SRC_URI="https://github.com/myint/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest
diff --git a/dev-python/httpauth/httpauth-0.3-r1.ebuild b/dev-python/httpauth/httpauth-0.3-r1.ebuild
new file mode 100644
index 000000000000..703fdd988ecb
--- /dev/null
+++ b/dev-python/httpauth/httpauth-0.3-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI middleware that secures routes using HTTP Digest Authentication"
+HOMEPAGE="https://github.com/jonashaag/httpauth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests nose
diff --git a/dev-python/ipaddr/ipaddr-2.2.0-r2.ebuild b/dev-python/ipaddr/ipaddr-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..cf3c4704e910
--- /dev/null
+++ b/dev-python/ipaddr/ipaddr-2.2.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IP address manipulation library"
+HOMEPAGE="https://github.com/google/ipaddr-py https://pypi.org/project/ipaddr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+src_configure() {
+ 2to3 -n -w --no-diffs *.py || die
+}
+
+python_test() {
+ "${EPYTHON}" ipaddr_test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/ipy/ipy-1.01-r1.ebuild b/dev-python/ipy/ipy-1.01-r1.ebuild
new file mode 100644
index 000000000000..3557a2fbcd28
--- /dev/null
+++ b/dev-python/ipy/ipy-1.01-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="https://github.com/autocracy/python-ipy/wiki https://pypi.org/project/IPy/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+python_test() {
+ "${EPYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ipython_genutils/ipython_genutils-0.2.0-r3.ebuild b/dev-python/ipython_genutils/ipython_genutils-0.2.0-r3.ebuild
new file mode 100644
index 000000000000..1f61e977886a
--- /dev/null
+++ b/dev-python/ipython_genutils/ipython_genutils-0.2.0-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Vestigial utilities from IPython"
+HOMEPAGE="https://github.com/ipython/ipython_genutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Needed because package provides decorators which use nose
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+distutils_enable_tests nose
diff --git a/dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild b/dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild
new file mode 100644
index 000000000000..d5960928a26b
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="https://ipywidgets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-7.6.3-py310.patch"
+)