summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-10-16 02:35:03 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-10-16 02:35:03 +0000
commit9495cb7964498a6881b481e7044bdf6351c5b00f (patch)
treed0a42029e2a11f5e539c21a4fb6ed3f554575f5d
parentMerge updates from master (diff)
parentsys-apps/bolt: 0.9-r2 - work with newer kernels (diff)
downloadgentoo-9495cb7964498a6881b481e7044bdf6351c5b00f.tar.gz
gentoo-9495cb7964498a6881b481e7044bdf6351c5b00f.tar.bz2
gentoo-9495cb7964498a6881b481e7044bdf6351c5b00f.zip
Merge updates from master
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.2.ebuild3
-rw-r--r--dev-python/bandit/bandit-1.6.2.ebuild10
-rw-r--r--dev-python/bashate/bashate-0.6.0.ebuild2
-rw-r--r--dev-python/beagle/beagle-0.3.0.ebuild8
-rw-r--r--dev-python/doc8/doc8-0.6.0.ebuild12
-rw-r--r--dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild2
-rw-r--r--dev-python/git-review/git-review-1.28.0.ebuild6
-rw-r--r--dev-python/hacking/hacking-2.0.0.ebuild2
-rw-r--r--dev-python/jsonext/jsonext-0.4.2.ebuild2
-rw-r--r--dev-python/lazr-config/lazr-config-2.2.2.ebuild3
-rw-r--r--dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild9
-rw-r--r--dev-python/logutils/logutils-0.3.5.ebuild2
-rw-r--r--dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild3
-rw-r--r--dev-python/os-ken/Manifest1
-rw-r--r--dev-python/os-ken/os-ken-1.2.0.ebuild34
-rw-r--r--dev-python/os-testr/Manifest1
-rw-r--r--dev-python/os-testr/os-testr-2.0.0.ebuild40
-rw-r--r--dev-python/oslotest/Manifest1
-rw-r--r--dev-python/oslotest/oslotest-4.4.1.ebuild24
-rw-r--r--dev-python/pecan/pecan-1.3.3-r2.ebuild2
-rw-r--r--dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild6
-rw-r--r--dev-python/tinyrpc/tinyrpc-1.0.1.ebuild2
-rw-r--r--sys-apps/bolt/bolt-0.9-r2.ebuild57
23 files changed, 192 insertions, 40 deletions
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.2.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.2.ebuild
index c0028357df7d..a75a9d4198b5 100644
--- a/dev-python/aiosmtpd/aiosmtpd-1.2.ebuild
+++ b/dev-python/aiosmtpd/aiosmtpd-1.2.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python3_6 python3_7 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
inherit distutils-r1
DESCRIPTION="asyncio based SMTP server"
diff --git a/dev-python/bandit/bandit-1.6.2.ebuild b/dev-python/bandit/bandit-1.6.2.ebuild
index f4cbf20f2c3f..e3b22ec991b3 100644
--- a/dev-python/bandit/bandit-1.6.2.ebuild
+++ b/dev-python/bandit/bandit-1.6.2.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -17,10 +17,8 @@ KEYWORDS="~amd64 ~arm64 ~s390 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
test? (
>=dev-python/coverage-4.0[${PYTHON_USEDEP}]
!~dev-python/coverage-4.4[${PYTHON_USEDEP}]
@@ -35,7 +33,7 @@ DEPEND="
>=dev-python/pylint-1.4.5[${PYTHON_USEDEP}]
)"
RDEPEND="
- ${CDEPEND}
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
>=dev-python/GitPython-1.0.1[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.13.0[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
diff --git a/dev-python/bashate/bashate-0.6.0.ebuild b/dev-python/bashate/bashate-0.6.0.ebuild
index 41ac6f0d758f..7ca3926ad713 100644
--- a/dev-python/bashate/bashate-0.6.0.ebuild
+++ b/dev-python/bashate/bashate-0.6.0.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
DISTUTILS_IN_SOURCE_BUILD=TRUE
+DISTUTILS_USE_SETUPTOOLS=rdepend
# time
RESTRICT="test"
@@ -20,7 +21,6 @@ KEYWORDS="amd64 x86"
IUSE="test"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0
"
diff --git a/dev-python/beagle/beagle-0.3.0.ebuild b/dev-python/beagle/beagle-0.3.0.ebuild
index 64fefecbcd9f..115720be57ac 100644
--- a/dev-python/beagle/beagle-0.3.0.ebuild
+++ b/dev-python/beagle/beagle-0.3.0.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="Command line client for Hound, the code search tool."
@@ -16,9 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
>=dev-python/cliff-2.11.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.18.4[${PYTHON_USEDEP}]"
diff --git a/dev-python/doc8/doc8-0.6.0.ebuild b/dev-python/doc8/doc8-0.6.0.ebuild
index 53aa08ff87b5..6ee20cc6bc9e 100644
--- a/dev-python/doc8/doc8-0.6.0.ebuild
+++ b/dev-python/doc8/doc8-0.6.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python3_{6,7} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,12 +16,9 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
IUSE=""
-CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
+DEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
RDEPEND="
- ${CDEPEND}
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
>=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
diff --git a/dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild b/dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild
index 70fe16344d32..31b1a2c50fae 100644
--- a/dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild
+++ b/dev-python/gevent-websocket/gevent-websocket-0.10.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
diff --git a/dev-python/git-review/git-review-1.28.0.ebuild b/dev-python/git-review/git-review-1.28.0.ebuild
index 3b45fb2c1cad..3bcb89a2b528 100644
--- a/dev-python/git-review/git-review-1.28.0.ebuild
+++ b/dev-python/git-review/git-review-1.28.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,10 +16,7 @@ SLOT="0"
KEYWORDS="amd64 x86 ~x64-cygwin ~amd64-linux ~x86-linux"
IUSE=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
-"
+DEPEND=">=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]"
RDEPEND="
>=dev-python/requests-1.1[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
diff --git a/dev-python/hacking/hacking-2.0.0.ebuild b/dev-python/hacking/hacking-2.0.0.ebuild
index 4d7dcba426e5..0e3b81317c9e 100644
--- a/dev-python/hacking/hacking-2.0.0.ebuild
+++ b/dev-python/hacking/hacking-2.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
diff --git a/dev-python/jsonext/jsonext-0.4.2.ebuild b/dev-python/jsonext/jsonext-0.4.2.ebuild
index 20e93cbdff56..53f7a690090c 100644
--- a/dev-python/jsonext/jsonext-0.4.2.ebuild
+++ b/dev-python/jsonext/jsonext-0.4.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
inherit distutils-r1
diff --git a/dev-python/lazr-config/lazr-config-2.2.2.ebuild b/dev-python/lazr-config/lazr-config-2.2.2.ebuild
index 1b3afe149d60..b0137573b967 100644
--- a/dev-python/lazr-config/lazr-config-2.2.2.ebuild
+++ b/dev-python/lazr-config/lazr-config-2.2.2.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
inherit distutils-r1
MY_PN=${PN/-/.}
diff --git a/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
index f326aa3dae97..26ee52990e7c 100644
--- a/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
+++ b/dev-python/lazr-delegates/lazr-delegates-2.0.4.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
inherit distutils-r1
MY_PN=${PN/-/.}
@@ -18,7 +19,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
+RDEPEND="
dev-python/zope-interface[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]"
+ dev-python/nose[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/logutils/logutils-0.3.5.ebuild b/dev-python/logutils/logutils-0.3.5.ebuild
index 4263320bff1d..65ba529a949e 100644
--- a/dev-python/logutils/logutils-0.3.5.ebuild
+++ b/dev-python/logutils/logutils-0.3.5.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
diff --git a/dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild b/dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild
index 2d4348b40bbf..5e79cdbb947c 100644
--- a/dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild
+++ b/dev-python/openstackdocstheme/openstackdocstheme-2.2.5.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -13,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc64 x86"
DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/os-ken/Manifest b/dev-python/os-ken/Manifest
index 84c6a583ce57..aa2c2cfaf4dc 100644
--- a/dev-python/os-ken/Manifest
+++ b/dev-python/os-ken/Manifest
@@ -1 +1,2 @@
DIST os-ken-0.3.1.tar.gz 1440173 BLAKE2B 1b861e79e3aa324ac24b0a120b1edc06ce3b9916f2863538a95ecd96d618cbf416c2633af6a89e923d346d6092dcf72f25bf486b5e46d2d7a18774c58f839efc SHA512 ddf3309165614a9d25046623cefbb0e961452eefd43a9260ad3e1bdeb9999200624848d14bf5ef318b53dee786374131bcaf14d9798d7b7a8cd581bc47aaf9ed
+DIST os-ken-1.2.0.tar.gz 1442682 BLAKE2B 37582acac257cc840039ef4f75a938bce357d53f680b460e0f92a116b0c3eb0a3d38f631998760083f60a4ddf45741489f2b40d6f336ca60f257f8307d3c82f9 SHA512 a88c5165822b70ca4f9c172788acdd08ad8de4f0a07bbc53d3bc37c9c97481d55f1272c74a3438a86fa0d5ebce945f04a12d7a065c580319a0d94049476408ff
diff --git a/dev-python/os-ken/os-ken-1.2.0.ebuild b/dev-python/os-ken/os-ken-1.2.0.ebuild
new file mode 100644
index 000000000000..34da46126d6f
--- /dev/null
+++ b/dev-python/os-ken/os-ken-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
+HOMEPAGE="https://github.com/openstack/os-ken"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/os-ken-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.2[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.18.3[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ovs-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tinyrpc-0.6[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]"
diff --git a/dev-python/os-testr/Manifest b/dev-python/os-testr/Manifest
index f1580f3fdadd..a8d2dea221e2 100644
--- a/dev-python/os-testr/Manifest
+++ b/dev-python/os-testr/Manifest
@@ -1 +1,2 @@
DIST os-testr-1.0.0.tar.gz 43382 BLAKE2B c5a9b22700ce40acff8ceeb796d9fa0b840038cd285d80630b16c3399e8c188d87dc54de653d06a2c0918185e9ffd4695747f59d4d42eb158f9ea18bc361963d SHA512 2189abc76840d935d63635874ebdae7c325b392bc24a52e07e1046b47a17be6fd97ba17dc5593ae7a1e2bff9c5b0dbbfd8ade8a2382dce2223ee4047b3483cec
+DIST os-testr-2.0.0.tar.gz 46787 BLAKE2B ff1b862c24d1f88d0794ad9139a0d57e6da5d57404ad3c659a18d84316b0cb603ec5c3455cf89fd12183dabc060537f6b077cd09a9fe1f785c6cd56fc0c596b4 SHA512 0ee6a144a75f7742aaf6859161f7918fb908a6783180a022a8698ce4dffeac50bf453c208b47ec784687d88a55739fff822483f404f246f222c24245ed6845ea
diff --git a/dev-python/os-testr/os-testr-2.0.0.ebuild b/dev-python/os-testr/os-testr-2.0.0.ebuild
new file mode 100644
index 000000000000..b81454b8ef0e
--- /dev/null
+++ b/dev-python/os-testr/os-testr-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A testr wrapper to provide functionality for OpenStack projects"
+HOMEPAGE="https://pypi.org/project/os-testr/ https://github.com/openstack/os-testr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.1[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/oslotest/Manifest b/dev-python/oslotest/Manifest
index 1487fd07ffd9..cff8ef02abee 100644
--- a/dev-python/oslotest/Manifest
+++ b/dev-python/oslotest/Manifest
@@ -1 +1,2 @@
DIST oslotest-3.7.1.tar.gz 38176 BLAKE2B 94924dca8384dcc8ba9e4f62220eb6d29b27b38966ffce7dddbd23d5c5e66493141ce4170565325a0516648db186a0171cd33de6d536bb8ed5cdef76161d4f94 SHA512 dfc55bc91ebd8ef448d4c69b2af51b8f2a9f2068b2ef2ec1cfbcfffc27eff7ccafb00dc2a3059730427aecbcd815f9dee2f00b8c74df154c8dbb95793aff7e78
+DIST oslotest-4.4.1.tar.gz 34879 BLAKE2B dd7241793f88f31c9427e07b07c015a0f8fe39f65c59341be0874fd4f9b735d1da3b105213d77bfc8cec3ea0d7587cd770a88c2a4b59902c595e9fefa5dc4730 SHA512 e4d60ab399b4eee02d1798948f62ad3acec0d9a81e6ec3b6a8d3dca7035dec0d79a5164c05e8ca4615b0489f44b6ff0c06e6420bf3d96131d15f3458e751896d
diff --git a/dev-python/oslotest/oslotest-4.4.1.ebuild b/dev-python/oslotest/oslotest-4.4.1.ebuild
new file mode 100644
index 000000000000..c8c648f4aab9
--- /dev/null
+++ b/dev-python/oslotest/oslotest-4.4.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo test framework"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/pecan/pecan-1.3.3-r2.ebuild b/dev-python/pecan/pecan-1.3.3-r2.ebuild
index d2c2de82594a..23d00b7f4172 100644
--- a/dev-python/pecan/pecan-1.3.3-r2.ebuild
+++ b/dev-python/pecan/pecan-1.3.3-r2.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,7 +16,6 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 x86"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
>=dev-python/webob-1.4[${PYTHON_USEDEP}]
>=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
diff --git a/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild b/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
index 6e6ed25ed5f2..5ed34281d515 100644
--- a/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
+++ b/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -20,7 +21,6 @@ IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
diff --git a/dev-python/tinyrpc/tinyrpc-1.0.1.ebuild b/dev-python/tinyrpc/tinyrpc-1.0.1.ebuild
index f5cfd1e93295..a6dfd9a05e24 100644
--- a/dev-python/tinyrpc/tinyrpc-1.0.1.ebuild
+++ b/dev-python/tinyrpc/tinyrpc-1.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
inherit distutils-r1
DESCRIPTION="A protocol neutral RPC library that supports JSON-RPC and zmq."
diff --git a/sys-apps/bolt/bolt-0.9-r2.ebuild b/sys-apps/bolt/bolt-0.9-r2.ebuild
new file mode 100644
index 000000000000..ddf044ade359
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ dev-util/glib-utils
+ virtual/libudev
+ virtual/udev
+ dev-util/umockdev
+ sys-auth/polkit[introspection]
+ systemd? ( sys-apps/systemd )
+ doc? ( app-text/asciidoc )"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ if use kernel_linux && kernel_is lt 5 6; then
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ else
+ CONFIG_CHECK="~USB4"
+ ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
+ fi
+ check_extra_config
+
+ CONFIG_CHECK="~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+ check_extra_config
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=$(usex doc true false)
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --sharedstatedir=/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc boltd
+ keepdir /var/lib/boltd
+}