summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-24 06:33:33 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-24 09:49:04 +0100
commit947d69967f01db5f40bf534d3e6fabd801703583 (patch)
tree669cabce0067d13b206866fc2ebe5385c3a94852
parentmedia-libs/exiftool: Stabilize 12.76 x86, #925339 (diff)
downloadgentoo-947d69967f01db5f40bf534d3e6fabd801703583.tar.gz
gentoo-947d69967f01db5f40bf534d3e6fabd801703583.tar.bz2
gentoo-947d69967f01db5f40bf534d3e6fabd801703583.zip
dev-python/botocore: Bump to 1.34.49
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.49.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c950ea8ecbb5..69c9358699b0 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.34.45.gh.tar.gz 12726866 BLAKE2B c5095199626afcd7d83ff62623593f1
DIST botocore-1.34.46.gh.tar.gz 12726577 BLAKE2B 0c1574bd5e045bc478e44f300d64d5d56489246ad7cddc1ae19e2ad9080abbf30985330e435b833acfb1f1ded46e60ee2e70e1273568a93b69a47018df68ff4a SHA512 9ff234090e3a315612cd97e36ec5eb577d799465c4bb99ef1a5b2efbd83ce3cd5de94300996381c704896efd6bbb612a9b76831040dfd68f9cf86a821680b24b
DIST botocore-1.34.47.gh.tar.gz 12728346 BLAKE2B c1b596764ebb5c02cc9ae925e1b8610e4eb425a8adfd55434790f187c80470a78a670c4d78af15cbb08bacd35d4ff118a5eda379d086ae721510d08670984a79 SHA512 d65db0a8cd4d1e3558a493c067e894c40ca9a0cd514e488bc8f346d745b2b81d7b77f2f2161f2c14e69f7a22b891eb81465f637669df9ca8bd8f8ab73ac2e2ed
DIST botocore-1.34.48.gh.tar.gz 12729784 BLAKE2B a6206421ada02ef55a5129735332deec59d3731b4901fbac4370391fa84faca6f996323ce08211390e3f96ce527620a5b771863efdbe07dc4880282b63b67564 SHA512 00395ee882d3a8ade1ac53525127216cb5e66d59580aa0496c2d7e98812c88b999ac5dfa89d3fd182a96bf4e1023faf73bb99064af471c37b4742c028e9b108a
+DIST botocore-1.34.49.gh.tar.gz 12729109 BLAKE2B 8029fd3530f8c29e7375eaf369944ada9977a1e445eec3151f2babcd6a6480e8c9a8109f31687b588c50691dca62e635beafbcca71f3a6961d23937fa7e613d0 SHA512 8722a965658c55b35880c65b0b4b8d466691752de4b7654657fe583e4dec36f09910f8298f29099cd035e3acf0622734597e4269d2a4e71eecfc3a7fcf6825bc
diff --git a/dev-python/botocore/botocore-1.34.49.ebuild b/dev-python/botocore/botocore-1.34.49.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.49.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}