summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-12-13 00:45:49 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-12-13 00:45:49 +0000
commit9221564eab0246adf9f33d0d0d55b1ddbf337e8c (patch)
treea9a80da5afc3da2d993b88a51ecf2b5c567aaf4d
parent2019-12-13 00:26:15 UTC (diff)
parentapp-shells/sash: port to EAPI 7 (diff)
downloadgentoo-9221564eab0246adf9f33d0d0d55b1ddbf337e8c.tar.gz
gentoo-9221564eab0246adf9f33d0d0d55b1ddbf337e8c.tar.bz2
gentoo-9221564eab0246adf9f33d0d0d55b1ddbf337e8c.zip
Merge updates from master
-rw-r--r--app-shells/sash/sash-3.8.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-shells/sash/sash-3.8.ebuild b/app-shells/sash/sash-3.8.ebuild
index 6c2ee580ce04..e584cdbcd922 100644
--- a/app-shells/sash/sash-3.8.ebuild
+++ b/app-shells/sash/sash-3.8.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="A small (static) UNIX Shell"
-HOMEPAGE="http://www.canb.auug.org.au/~dbell/"
-SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
+HOMEPAGE="https://www.canb.auug.org.au/~dbell/"
+SRC_URI="https://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
LICENSE="freedist"
SLOT="0"
@@ -20,7 +20,7 @@ DEPEND="
RDEPEND="!static? ( ${DEPEND} )"
src_prepare() {
- epatch "${FILESDIR}"/sash-3.7-builtin.patch
+ eapply "${FILESDIR}"/sash-3.7-builtin.patch
sed \
-e "s:-O3:${CFLAGS}:" \
@@ -29,6 +29,7 @@ src_prepare() {
sed \
-e 's:linux/ext2_fs.h:ext2fs/ext2_fs.h:g' \
-i cmd_chattr.c || die
+ eapply_user
}
src_compile() {
@@ -38,7 +39,6 @@ src_compile() {
}
src_install() {
- into /
dobin sash
doman sash.1
dodoc README