summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2025-01-09 02:48:22 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2025-01-09 02:48:22 +0000
commit8f504e8dd68f90c6f248fdf57a0494abff83e8bf (patch)
tree2a85dd717d1088171266bb2b11c035a61032709f
parent2025-01-09 02:33:29 UTC (diff)
parentdev-python/pychromecast: add 14.0.5 (diff)
downloadgentoo-8f504e8dd68f90c6f248fdf57a0494abff83e8bf.tar.gz
gentoo-8f504e8dd68f90c6f248fdf57a0494abff83e8bf.tar.bz2
gentoo-8f504e8dd68f90c6f248fdf57a0494abff83e8bf.zip
Merge updates from master
-rw-r--r--dev-db/mysql/mysql-8.0.37.ebuild4
-rw-r--r--dev-python/pychromecast/Manifest1
-rw-r--r--dev-python/pychromecast/pychromecast-14.0.5.ebuild27
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-db/mysql/mysql-8.0.37.ebuild b/dev-db/mysql/mysql-8.0.37.ebuild
index 7cfb7a41bb10..e96f1f6700c5 100644
--- a/dev-db/mysql/mysql-8.0.37.ebuild
+++ b/dev-db/mysql/mysql-8.0.37.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,7 +24,7 @@ S="${WORKDIR}/mysql"
LICENSE="GPL-2"
SLOT="8.0"
# -ppc for bug #761715
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips -ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+KEYWORDS="amd64 arm arm64 ~hppa ~mips -ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
IUSE="cjk cracklib debug jemalloc latin1 numa +perl profiling router selinux +server tcmalloc test"
RESTRICT="!test? ( test )"
diff --git a/dev-python/pychromecast/Manifest b/dev-python/pychromecast/Manifest
index b9b67db2e5e1..b11613c8db5b 100644
--- a/dev-python/pychromecast/Manifest
+++ b/dev-python/pychromecast/Manifest
@@ -1,3 +1,4 @@
DIST PyChromecast-13.0.7.tar.gz 52074 BLAKE2B 4e67ce21bf91c52cd83b8a17d86cd321d937c1f55b567d4df7a5548ad02aacb4c269b9d29030a7e41f9f310d53313b6b287032c1d5f1448b415c3896b168b783 SHA512 dc63c901287ae31ce278c9978701ad335715f1daaab1b2683aa7b02ddb38e3e207f2527ae144f6836b65c4ddb4b1fdd62c40005bf776e0655e647ab40634857e
DIST PyChromecast-13.1.0.tar.gz 53436 BLAKE2B f8d92f0db9da2898e87340de47bf85cfd71ba4a18ca30af95c261e42c0aff95fcf633637b489a15073c5ed946c4f61370473f07ac83bf37078f37bb90377702a SHA512 a4823b79bf9c54d4734e23cd0c064f9ab51be715297fe02632627812778b2d36600382e18f11e6f368046fb70dc6176a9293888bcbc233cd773443edf4c303c4
DIST PyChromecast-14.0.1.tar.gz 60482 BLAKE2B a34dcba0b975bc8b3c0fb08f5a29a80c2324de3acbcc75dea74cecd5aa9be2fb17fb70f3c2f0131d355edfba5fd0f1d6bdf3d42eb8f368d0b2d3a9f2776f5698 SHA512 72119e27be49128d57a9354aaebd2a5711f3da0ad2e7ca07863107382061d9398c95c901ac33ea2a1c45687b2cbef32dfdba228be99e1acdef79ce133510fb4e
+DIST PyChromecast-14.0.5.tar.gz 60934 BLAKE2B b42e5242d67a0f964e47b381a57c6ddb4714ee2714b92aeea763faf35bd919290beb84f198fbe3437396ec61458c657c9b1eaa3c644ae5eb4436f62ee49f439b SHA512 9627ad6f67b4625e44b56f72e05e0a673396b8c89a542de896beb14f186c86974397878eab8ff42652b987a0524541575797ebea18098a8cdaadf78f9bdfa6d7
diff --git a/dev-python/pychromecast/pychromecast-14.0.5.ebuild b/dev-python/pychromecast/pychromecast-14.0.5.ebuild
new file mode 100644
index 000000000000..ac774c8e101e
--- /dev/null
+++ b/dev-python/pychromecast/pychromecast-14.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=PyChromecast
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to talk to Google Chromecast"
+HOMEPAGE="
+ https://github.com/home-assistant-libs/pychromecast/
+ https://pypi.org/project/PyChromecast/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-4.25.1[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.25.1[${PYTHON_USEDEP}]
+"