summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-21 10:34:14 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-21 10:54:13 +0200
commit8cae35e56a79be95b27943490329a1ef9963ccc3 (patch)
tree65646cc2195ee50c37f2895e12139b93cb740855
parentdev-ml/cudf: do not call ar directly (diff)
downloadgentoo-8cae35e56a79be95b27943490329a1ef9963ccc3.tar.gz
gentoo-8cae35e56a79be95b27943490329a1ef9963ccc3.tar.bz2
gentoo-8cae35e56a79be95b27943490329a1ef9963ccc3.zip
dev-python/pyparsing: add 3.0.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-3.0.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index a319dc21b02f..9cee19b2620d 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -1,2 +1,3 @@
DIST pyparsing_2.4.7.tar.gz 648158 BLAKE2B 24525b4ee7876e245b9eb270f0e3e22fe2d8b398f9777ad3b3657b8a1227dcbd25983aa64a3f3018debdbffc1a042c732e6b3a09800e081c7acac7b97da15317 SHA512 c7a546729f86a2b5176e2482b566b9fd715b03e495aaef4d720b21307bb03f385dbc849247f8d266cb3d92be0a83c34ce4995b655ce85318355d5a0d42d6991e
DIST pyparsing_3.0.6.tar.gz 942509 BLAKE2B 1ece2e83dd4193c8364bf690afc54090b46658fced62fc852b0098208d2ae4b18e96f050e63d8751c4b5cf95aa178a11dd1c37fc9d63ae1551639b5c91fe81d8 SHA512 5e94f1dcb4560a0f8e5b9a979b691b6362939648d03e9ea03f74e3aeeddafc09029c8e82c42a517aebe4a0483fd06cac03ae45030e074a40576f9570ed1eb5cc
+DIST pyparsing_3.0.7.tar.gz 944917 BLAKE2B bcbcd18817c69a69ac6863affb1309a5ca63fe46a45dc056d8407d79a77d1f19e4d1abce08f5d6f1aff7cbdaefb5b699787abcddfcbf64e5514e79e2b0b86ce6 SHA512 d5d5547188ebda6fb7f45928174314d3d4d10302acc8fb476cd6590fb4a75167dee5f6397ab0b63efd4cb55c0765708ffd432bcfecf28d8f808815e62615f447
diff --git a/dev-python/pyparsing/pyparsing-3.0.7.ebuild b/dev-python/pyparsing/pyparsing-3.0.7.ebuild
new file mode 100644
index 000000000000..2130df7b4182
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2004-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+)
+
+EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}