summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-12 22:01:42 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-12 22:08:50 +0300
commit8845ad860d00bdf66ef5553d7d62d4afad767ce1 (patch)
tree4cdcd3f131c5814977b89af47e89dc0b0b8adae3
parentdev-python/argparse-manpage: enable py3.11 (diff)
downloadgentoo-8845ad860d00bdf66ef5553d7d62d4afad767ce1.tar.gz
gentoo-8845ad860d00bdf66ef5553d7d62d4afad767ce1.tar.bz2
gentoo-8845ad860d00bdf66ef5553d7d62d4afad767ce1.zip
dev-python/async_generator: update EAPI 7 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/async_generator/async_generator-1.10-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/async_generator/async_generator-1.10-r2.ebuild b/dev-python/async_generator/async_generator-1.10-r2.ebuild
new file mode 100644
index 000000000000..0581742e6711
--- /dev/null
+++ b/dev-python/async_generator/async_generator-1.10-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Making it easy to write async iterators in Python 3.5"
+HOMEPAGE="https://github.com/python-trio/async_generator https://pypi.org/project/async_generator/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}