summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-08-18 09:45:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-08-18 10:04:14 +0200
commit8603c7a32ab6c211df98657ee21ea56dde96ae53 (patch)
tree253064bd4e1cf2b54ff3d6de07c8a0c75e332477
parentapp-admin/gnome-abrt: Bump to 1.4.0 (diff)
downloadgentoo-8603c7a32ab6c211df98657ee21ea56dde96ae53.tar.gz
gentoo-8603c7a32ab6c211df98657ee21ea56dde96ae53.tar.bz2
gentoo-8603c7a32ab6c211df98657ee21ea56dde96ae53.zip
net-libs/libnsl: Bump to version 2.0.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-libs/libnsl/Manifest1
-rw-r--r--net-libs/libnsl/libnsl-2.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libnsl/Manifest b/net-libs/libnsl/Manifest
index f3b14b934fd5..1b1355f34238 100644
--- a/net-libs/libnsl/Manifest
+++ b/net-libs/libnsl/Manifest
@@ -1 +1,2 @@
DIST libnsl-1.3.0.tar.xz 321488 BLAKE2B 25cb4fa2b3f161ce4cd06ca5cc0a716bf981620de4eb102f464bc1919b8f6d82f7b02a6108260122000bbac0307d9db05d406183dc533dd1b97683d08a7fc5f5 SHA512 a5a6c3ccb2d1e724c8c1f65e55dcd09383eb1ae019c55f4c09441eadf23ffbc2196cfad259805b0ac40ddf3a10af0da453e4d739d67d46829c64d0995dab4e55
+DIST libnsl-2.0.0.tar.xz 284408 BLAKE2B 843cd0346b45a688c59b88caebd9c5c938b0ef4b5e751b27599ae725a19f0ba2b88bc23b861edc75d79ae6c6bb829e4f82e9e3cd994d25d3385b1a75b9b58b8e SHA512 02ff41d335b7e965182c1f47a6448c1a71ae991a4d5a86ae5472cea7b38633a36b736469cc0d9fc407c706f3f144f90e4b7c9653643976805aa96fc319a69784
diff --git a/net-libs/libnsl/libnsl-2.0.0.ebuild b/net-libs/libnsl/libnsl-2.0.0.ebuild
new file mode 100644
index 000000000000..eb30d9918952
--- /dev/null
+++ b/net-libs/libnsl/libnsl-2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Public client interface for NIS(YP) in a IPv6 ready version"
+HOMEPAGE="https://github.com/thkukuk/libnsl"
+SRC_URI="https://github.com/thkukuk/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0/3"
+LICENSE="LGPL-2.1+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="static-libs"
+
+DEPEND="
+ >=net-libs/libtirpc-1.2.0:=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ !<sys-libs/glibc-2.26
+"
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-shared
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}