summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-22 03:27:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-22 03:27:58 +0200
commit82f4473f7da2b8ea0006716e8bf04ee60272efc3 (patch)
treeb5c686a8742f2e75b0855a42d4267d156ed40106
parentdev-python/pypdf: Bump to 4.3.1 (diff)
downloadgentoo-82f4473f7da2b8ea0006716e8bf04ee60272efc3.tar.gz
gentoo-82f4473f7da2b8ea0006716e8bf04ee60272efc3.tar.bz2
gentoo-82f4473f7da2b8ea0006716e8bf04ee60272efc3.zip
dev-python/pytest-httpserver: Bump to 1.0.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-httpserver/Manifest1
-rw-r--r--dev-python/pytest-httpserver/pytest-httpserver-1.0.12.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-httpserver/Manifest b/dev-python/pytest-httpserver/Manifest
index 99d11c0ae59d..c02cf9663032 100644
--- a/dev-python/pytest-httpserver/Manifest
+++ b/dev-python/pytest-httpserver/Manifest
@@ -1,2 +1,3 @@
DIST pytest_httpserver-1.0.10.tar.gz 60446 BLAKE2B 99d1db58f7b6fab78b687db0fc2448cbd9a3132b999e4d0ca1c8533ec2afebc717b9c28a16635260fb305aaafb832f591d28752ba3930473312a677dfaffd0be SHA512 f8636ccf757f687666a5336db66ac061ea6205979c7bbf8c9a2534282d8559453a7470318c07384aa755282c12e63537cce2ab9e9f3b2fbcda0e649ed2a45f92
DIST pytest_httpserver-1.0.11.tar.gz 66742 BLAKE2B 641c566b2ae349bf02f9a457c488ac6820cbeabbf430d12d84ba02b09382947aa60b61a6a1578b260d160b3e8d01c37745dfd2e90bdb6aea40f546a8103b367f SHA512 3d3055bc48bbe523fddbf9e9ba3495c3141a6dcd4f8b2cf9c19f11d1e6f4a93eebe64bb920ea5bd3bc0d30f4469ecb9a8beca35fc844ca2c62f6868edcb570ee
+DIST pytest_httpserver-1.0.12.tar.gz 66948 BLAKE2B b50871038b1c313db76c456e86bfe82046bcb8207cb72126db18bde5dea4e3cabb6740a19d27eba672967078f60978c1b20946bf502837e0859d957d0318afeb SHA512 fd3d290b23137d0c2893672611e7087e86ed47ccda865779304d177ac2ef6e0068321eb42f42ec89db859fb66910ad68399d3a4aefde250bd207ab9ff4666e3e
diff --git a/dev-python/pytest-httpserver/pytest-httpserver-1.0.12.ebuild b/dev-python/pytest-httpserver/pytest-httpserver-1.0.12.ebuild
new file mode 100644
index 000000000000..7c488288d502
--- /dev/null
+++ b/dev-python/pytest-httpserver/pytest-httpserver-1.0.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP server for pytest to test HTTP clients"
+HOMEPAGE="
+ https://github.com/csernazs/pytest-httpserver/
+ https://pypi.org/project/pytest_httpserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests from building release artifacts
+ tests/test_release.py
+ )
+
+ epytest -p no:localserver
+}