summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2018-08-09 14:51:37 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2018-08-09 14:51:37 +0000
commit780c4937e093ba9ee832180e44b4e9d11dfb9d66 (patch)
treeda5bc89b251c5cb45c1ef72bc1435f62fbb97e5b
parent2018-08-09 14:04:26 UTC (diff)
parentdesktop.eclass: Add missing ||die when writing to files (diff)
downloadgentoo-780c4937e093ba9ee832180e44b4e9d11dfb9d66.tar.gz
gentoo-780c4937e093ba9ee832180e44b4e9d11dfb9d66.tar.bz2
gentoo-780c4937e093ba9ee832180e44b4e9d11dfb9d66.zip
Merge updates from master
-rw-r--r--app-i18n/skktools/Manifest2
-rw-r--r--app-i18n/skktools/skktools-1.3.3_p20170305.ebuild4
-rw-r--r--app-i18n/skktools/skktools-1.3.4.ebuild (renamed from app-i18n/skktools/skktools-1.3.3_p20150901.ebuild)11
-rw-r--r--eclass/desktop.eclass26
4 files changed, 19 insertions, 24 deletions
diff --git a/app-i18n/skktools/Manifest b/app-i18n/skktools/Manifest
index 346a2b9e0c02..499f81a9502b 100644
--- a/app-i18n/skktools/Manifest
+++ b/app-i18n/skktools/Manifest
@@ -1,2 +1,2 @@
-DIST skktools-1.3.3_p20150901.tar.gz 483005 BLAKE2B 6db22c59276aee007ed4a457b8b66750d792596855ddfdd98310b14741cd20fe8594672626022dafc17c31d06f3292026e6bba35ea1fa001f4a224e7439eb082 SHA512 dbb15068239158c31a706da2fd5afcb8514d088854bdd4f0d05bb8b9e10947cbdce584ff3698571d601e3b357a1ba11b4608f0457615062016862ac89fb91b83
DIST skktools-1.3.3_p20170305.tar.gz 483715 BLAKE2B 0de2cb906e8433f66e706f0aa4dd8c4900343b48bfb9bb24aee4927f583650f54132c2a3bb607c17cefb0f0e686bcf8a0f4bd6ac07b6a9a71c0bd870eda587a7 SHA512 f6e9041fecf8c28a84c3996ca120371528c034eeca3695cb224b4cf225e8dab9e69969d7fb955112cd1e9c1e80c2ba8e2aef4f0eb81f55374dd626402482c235
+DIST skktools-1.3.4.tar.gz 482860 BLAKE2B f9e822531f8f715291e55ec6dec0eeb31683dc72efc7ba73621cfd0c29f0c5147cbef8256d44848792b8a1601c1878321b2dc0260df9d32d0e5e18eb65220987 SHA512 8749dfc4f18474db860d8b7cd85fadfc00327b199addb31a339aa78dd66cb98032429664bdad4b47176b5b64b156b7264bc35a284861f6b9ec8cc9979d4d5ce1
diff --git a/app-i18n/skktools/skktools-1.3.3_p20170305.ebuild b/app-i18n/skktools/skktools-1.3.3_p20170305.ebuild
index 0e1c1f93783d..bf622beb43df 100644
--- a/app-i18n/skktools/skktools-1.3.3_p20170305.ebuild
+++ b/app-i18n/skktools/skktools-1.3.3_p20170305.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/skk-dev/skktools/archive/${EGIT_COMMIT}.tar.gz -> ${
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="amd64 ~arm x86"
IUSE="emacs"
RDEPEND="dev-libs/glib:2
diff --git a/app-i18n/skktools/skktools-1.3.3_p20150901.ebuild b/app-i18n/skktools/skktools-1.3.4.ebuild
index 3ed4d6a6582c..31dc8f2d8b1a 100644
--- a/app-i18n/skktools/skktools-1.3.3_p20150901.ebuild
+++ b/app-i18n/skktools/skktools-1.3.4.ebuild
@@ -1,19 +1,17 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
inherit elisp-common vcs-snapshot
-EGIT_COMMIT="28e36bac97dc8ed089bac409bef15f1831b6adde"
-
DESCRIPTION="SKK utilities to manage dictionaries"
HOMEPAGE="http://openlab.jp/skk/"
-SRC_URI="https://github.com/skk-dev/skktools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/skk-dev/skktools/archive/${P//./_}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~arm x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="emacs"
RDEPEND="dev-libs/glib:2
@@ -22,7 +20,6 @@ RDEPEND="dev-libs/glib:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
-DOCS=( ChangeLog README.md )
SITEFILE="50${PN}-gentoo.el"
src_configure() {
@@ -48,7 +45,7 @@ src_install() {
done
insinto /usr/share/${PN}
- doins *.awk *.scm
+ doins *.{awk,scm}
rm -rf convert2skk/obsolete
doins -r convert2skk filters
diff --git a/eclass/desktop.eclass b/eclass/desktop.eclass
index 91521b85a821..6fc72ab8ec03 100644
--- a/eclass/desktop.eclass
+++ b/eclass/desktop.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: desktop.eclass
@@ -174,7 +174,7 @@ make_desktop_entry() {
icon=${icon%.*}
fi
- cat <<-EOF > "${desktop}"
+ cat <<-EOF > "${desktop}" || die
[Desktop Entry]
Name=${name}
Type=Application
@@ -190,7 +190,9 @@ make_desktop_entry() {
ewarn "make_desktop_entry: update your 5th arg to read Path=${fields}"
fields="Path=${fields}"
fi
- [[ -n ${fields} ]] && printf '%b\n' "${fields}" >> "${desktop}"
+ if [[ -n ${fields} ]]; then
+ printf '%b\n' "${fields}" >> "${desktop}" || die
+ fi
(
# wrap the env here so that the 'insinto' call
@@ -217,7 +219,7 @@ make_session_desktop() {
local desktop=${T}/${wm:-${PN}}.desktop
shift 2
- cat <<-EOF > "${desktop}"
+ cat <<-EOF > "${desktop}" || die
[Desktop Entry]
Name=${title}
Comment=This session logs you into ${title}
@@ -244,20 +246,16 @@ domenu() {
(
# wrap the env here so that the 'insinto' call
# doesn't corrupt the env of the caller
- local i j ret=0
+ local i ret=0
insopts -m 0644
insinto /usr/share/applications
for i in "$@" ; do
- if [[ -f ${i} ]] ; then
- doins "${i}"
- ((ret+=$?))
- elif [[ -d ${i} ]] ; then
- for j in "${i}"/*.desktop ; do
- doins "${j}"
- ((ret+=$?))
- done
+ if [[ -d ${i} ]] ; then
+ doins "${i}"/*.desktop
+ ((ret|=$?))
else
- ((++ret))
+ doins "${i}"
+ ((ret|=$?))
fi
done
exit ${ret}