summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-22 03:42:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-22 03:42:43 +0200
commit736a40c24bb69f64306f0c55ec2e6833220b740e (patch)
tree28393faf7de5785039bef3cb1989b733454cf727
parentdev-python/dep-logic: Bump to 0.4.4 (diff)
downloadgentoo-736a40c24bb69f64306f0c55ec2e6833220b740e.tar.gz
gentoo-736a40c24bb69f64306f0c55ec2e6833220b740e.tar.bz2
gentoo-736a40c24bb69f64306f0c55ec2e6833220b740e.zip
dev-python/sphinx-gallery: Bump to 0.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.17.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 3a1c4c5b08a6..692043ce408f 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1 +1,2 @@
DIST sphinx_gallery-0.16.0.tar.gz 432247 BLAKE2B 130800616a29be2daedb77404f79ca8d1543ecd391f45f8f19cbcf46ce742d02725d9b087be337d11496021b5c486c6c24b35f22b2c7d4cb575cb2c217d328db SHA512 b45e9141d64b1e277d75f501f2cc40979942953cd8412716e5af64917a3b9adc0a746fbd6249c3636c3db222c1e438ee7f9a9ad93f57b2f05f9ec80a562796c3
+DIST sphinx_gallery-0.17.0.tar.gz 461588 BLAKE2B 2f95724b184a2fe6359cf90c5200cebb80da8bd47160eb801069a396ddc6d889bd84a088899c2e0b461e81a6bf31ebbcebd4b555b83a3a5eebd11e48048ca2a3 SHA512 969bedefdb9231fd9fd92f1a8eb4488dbf6c8b68175e6869d0e893f1a6674bbf7b6e2b0281e54b929a3b2ca1d2928f75f00cb307100391656b6ebd62e8046b7a
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.17.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.17.0.ebuild
new file mode 100644
index 000000000000..5f967116b733
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.17.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://github.com/sphinx-gallery/sphinx-gallery/
+ https://sphinx-gallery.github.io/
+ https://pypi.org/project/sphinx-gallery/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+ # require jupyterlite_sphinx
+ sphinx_gallery/tests/test_full.py
+ sphinx_gallery/tests/test_full_noexec.py
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_non_default_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_config
+ )
+
+ epytest -o addopts=
+}