summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-12-19 14:33:22 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-12-19 14:33:22 +0000
commit6df8343330aec2bc180e89a6b6485a95b4738ebd (patch)
tree71668a823116a13e047792536340367ff5c2fbdc
parent2024-12-19 13:03:25 UTC (diff)
parentnet-libs/ngtcp2: add 1.10.0 (diff)
downloadgentoo-6df8343330aec2bc180e89a6b6485a95b4738ebd.tar.gz
gentoo-6df8343330aec2bc180e89a6b6485a95b4738ebd.tar.bz2
gentoo-6df8343330aec2bc180e89a6b6485a95b4738ebd.zip
Merge updates from master
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-1.7.0.ebuild42
-rw-r--r--net-libs/ngtcp2/Manifest1
-rw-r--r--net-libs/ngtcp2/ngtcp2-1.10.0.ebuild53
4 files changed, 97 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index c5b5b202a735..d961d50a879c 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -2,3 +2,4 @@ DIST nghttp3-1.3.0.tar.xz 390176 BLAKE2B 8ff17da3e53efb27b13e9ab17dba4ca27cc8fd9
DIST nghttp3-1.4.0.tar.xz 389036 BLAKE2B f8292aded56c0778dc285cf7d8261494c89e70e1e2128b0196be97706b1ce45edfd885031d069990429ef82c56c4922e0fe07d7471d4851642ce5e8afaf02bb9 SHA512 39ff9418009dcf84ae58d8297f53427da91509a69ecc4fc78c4c00f0fe6bbe348f7afffeafe535ae4c02ff9f0413016b4f51de6a87d8e8c8f6b415bb7f2b0895
DIST nghttp3-1.5.0.tar.xz 391668 BLAKE2B cbafd1e927bc39db78e238c0a7330170ec8e7a6fad96489fe754088cd40def9ddff7f7eef64bc9dc6efc729acbd4dfe2779bb5ac72092bfe91e3e6aab5b97456 SHA512 76a089fb0dd88b9aced41fccf36758c6504f8faf68c143ca81c260c017ac6dfd83fe678c401304de8bf65e859b0559dc5e8fcb37e88e547076d0ba9fd2c4a59c
DIST nghttp3-1.6.0.tar.xz 392480 BLAKE2B 43cedaaddaf450a8c3cac4be2353605c85230ef394a94bd40d74f1561fb3593d022f865da41aa05d301de43ccc0aade69f015866cfb93501c4c9083808ef81cf SHA512 d0f585cf388a48d391f803897b0998c12c39e118ca380ecc48c4d3dfd3ff4588a5e456dc89a96f2f5ffd5afc261a2d60a71fd4d8ebb82af35bfe6668737538d8
+DIST nghttp3-1.7.0.tar.xz 395808 BLAKE2B 2a13747518883a0f11005ee1189dc6a32a73fdf390416f6e3c352a7be76cccd68522581c2148c6a86c24f14ba13fc21a7c6d6815ab3ad724c08a8088d1421d3b SHA512 77510e2056206e3e149bc3535a0e7e6095afb0a0358a9dda48c8be82199eaefd0dadbba7e027c5c14eb46572d2dbc929a99c3b9c6d27c83a1c80428263ccecab
diff --git a/net-libs/nghttp3/nghttp3-1.7.0.ebuild b/net-libs/nghttp3/nghttp3-1.7.0.ebuild
new file mode 100644
index 000000000000..435f7754e75c
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ~m68k ppc64 ~riscv ~sparc x86 ~arm64-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ test? ( static-libs )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ )
+ use test && mycmakeargs+=( -DBUILD_TESTING=ON )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && cmake_build check
+}
diff --git a/net-libs/ngtcp2/Manifest b/net-libs/ngtcp2/Manifest
index c4eb2fa96b6b..f415173c6551 100644
--- a/net-libs/ngtcp2/Manifest
+++ b/net-libs/ngtcp2/Manifest
@@ -1,3 +1,4 @@
+DIST ngtcp2-1.10.0.tar.xz 636296 BLAKE2B 21ca85ed0652d9c3721f1a8dcb890bc21ea37bb49095c3fcc418e818462629463f4410e169465ff19960b09e47684e99b9fc713919f114c3ef765cc2d754aadb SHA512 de61f9c2b8135d0d08740215002a3e1688f93825ce6ab6d074ce36569bde0e789d4f1a2abd708773c4ab123c4584e94f0eeee8f7e8ef238891f9bb36be001f9b
DIST ngtcp2-1.5.0.tar.xz 627464 BLAKE2B 6a6fc91f2755d9cbccd6118b53b56b0b4fd3b445c9a491a2d7469ad59d7fe1983516eb79242196db009e7b0875c4db5305bd4c285d2437073b605033f812084d SHA512 6c05beccac5d53c575ceaa594ac6b1d91ae9f0be01394b3520e84b51a44d3c6a71612c2c6f613d3d1b9d2992a83a68696fedbfdc3842f02d4009c95b463ad97f
DIST ngtcp2-1.7.0.tar.xz 631072 BLAKE2B 1a1ce134c54974418c0cf0bacc09a770e29cd7c7bfc44a2b5420f3bef3e70502f610bee4e9bb5ed9b87024153aa9390d5a233d2d6e2689166e1079e0e4f52600 SHA512 6efa42d17772fde00d9d0a67f2cbcf0704a8462c7305a5e3f213d1e98c9302a1ceee847081ecef358c7a421db56236e571a1ad9ff7fa5f5037987c5cb14e517d
DIST ngtcp2-1.8.0.tar.xz 632052 BLAKE2B efa8de7e8405c1360de1c8043e66e236024cacebd8be7564e2575cc568daede15ca6ceafa415b7c579a4fc205a507d6731cbff5c5a88dfab70e356f846012150 SHA512 4bb838ed94977515ad7fcd86bbafddfb9733264999b268c109b8f487caf01967b0e6d9d0791f19aa549177a375a7d4182662f14b09e7dc5240fa03b68de16235
diff --git a/net-libs/ngtcp2/ngtcp2-1.10.0.ebuild b/net-libs/ngtcp2/ngtcp2-1.10.0.ebuild
new file mode 100644
index 000000000000..789b94518acb
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-1.10.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="+gnutls openssl +ssl static-libs test"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) ) test? ( static-libs )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.7.2:0= )
+ openssl? (
+ >=dev-libs/openssl-1.1.1:0=
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_GNUTLS=$(usex gnutls)
+ -DENABLE_OPENSSL=$(usex openssl)
+ -DENABLE_BORINGSSL=OFF
+ -DENABLE_PICOTLS=OFF
+ -DENABLE_WOLFSSL=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}