summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-08-07 12:17:04 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-08-07 12:17:04 +0000
commit679a17b910008bf239aefc584e4cc292a04e236b (patch)
tree3fc9e09e333566112d83d4af451d3dc55b535cf6
parent2023-08-07 12:01:48 UTC (diff)
parentRevert "python-utils-r1.eclass: Remove old EAPI hack for exporting PYTHON" (diff)
downloadgentoo-679a17b910008bf239aefc584e4cc292a04e236b.tar.gz
gentoo-679a17b910008bf239aefc584e4cc292a04e236b.tar.bz2
gentoo-679a17b910008bf239aefc584e4cc292a04e236b.zip
Merge updates from master
-rw-r--r--eclass/python-utils-r1.eclass4
-rw-r--r--media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1-r1.ebuild4
-rw-r--r--media-libs/nv-codec-headers/nv-codec-headers-11.1.5.2.ebuild2
3 files changed, 6 insertions, 4 deletions
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 27157a003ab2..690b8ba8c79b 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -338,7 +338,9 @@ _python_export() {
debug-print "${FUNCNAME}: EPYTHON = ${EPYTHON}"
;;
PYTHON)
- export PYTHON=${BROOT}/usr/bin/${impl}
+ # Under EAPI 7+, this should just use ${BROOT}, but Portage
+ # <3.0.50 was buggy, and prefix users need this to update.
+ export PYTHON=${BROOT-${EPREFIX}}/usr/bin/${impl}
debug-print "${FUNCNAME}: PYTHON = ${PYTHON}"
;;
PYTHON_SITEDIR)
diff --git a/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1-r1.ebuild b/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1-r1.ebuild
index 9d32e6417079..b25e327d0ffc 100644
--- a/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1-r1.ebuild
+++ b/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,7 +16,7 @@ src_compile() {
}
src_install() {
- emake PREFIX="${EPREFIX}"/usr LIBDIR="$(get_libdir)" DESTDIR="${ED}" install
+ emake PREFIX="${EPREFIX}"/usr LIBDIR="$(get_libdir)" DESTDIR="${D}" install
mkdir -p "${ED}"/usr/share || die
mv "${ED}/usr/$(get_libdir)/pkgconfig" "${ED}"/usr/share/ || die
diff --git a/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.2.ebuild b/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.2.ebuild
index 8dc1a3f71262..b25e327d0ffc 100644
--- a/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.2.ebuild
+++ b/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.2.ebuild
@@ -16,7 +16,7 @@ src_compile() {
}
src_install() {
- emake PREFIX="${EPREFIX}"/usr LIBDIR="$(get_libdir)" DESTDIR="${ED}" install
+ emake PREFIX="${EPREFIX}"/usr LIBDIR="$(get_libdir)" DESTDIR="${D}" install
mkdir -p "${ED}"/usr/share || die
mv "${ED}/usr/$(get_libdir)/pkgconfig" "${ED}"/usr/share/ || die