summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-27 21:30:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-27 21:30:51 +0300
commit5ab619460fecf9773d612ba30ebd0d07fcac82c9 (patch)
tree9c5518718a06d8a303e6563d9cfeba3749af4e90
parentdev-python/pytimeparse: enable py3.11 (diff)
downloadgentoo-5ab619460fecf9773d612ba30ebd0d07fcac82c9.tar.gz
gentoo-5ab619460fecf9773d612ba30ebd0d07fcac82c9.tar.bz2
gentoo-5ab619460fecf9773d612ba30ebd0d07fcac82c9.zip
dev-python/python-cstruct: Use PEP517 build
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/python-cstruct/python-cstruct-2.1-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/python-cstruct-2.1-r1.ebuild b/dev-python/python-cstruct/python-cstruct-2.1-r1.ebuild
new file mode 100644
index 000000000000..35649fc7c268
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-2.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="https://github.com/andreax79/python-cstruct https://pypi.org/project/cstruct/"
+SRC_URI="https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest