summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-30 07:01:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-30 07:43:27 +0100
commit59d37cdd65886d4721ba4dab424fe0266bad6380 (patch)
tree426a4328b0f0f2a839f777656f28330d2d1c84bf
parentdev-python/identify: Bump to 2.6.4 (diff)
downloadgentoo-59d37cdd65886d4721ba4dab424fe0266bad6380.tar.gz
gentoo-59d37cdd65886d4721ba4dab424fe0266bad6380.tar.bz2
gentoo-59d37cdd65886d4721ba4dab424fe0266bad6380.zip
dev-python/python-engineio: Bump to 4.11.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-4.11.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 61cbebfe3e7a..446eab1f1ba1 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,2 +1,3 @@
DIST python-engineio-4.10.1.gh.tar.gz 317153 BLAKE2B 3e75591bc79bc705dd844283485e7087a97a5493a1a8db0095bbbb2935de60deba394fae2f0136167692170ab5dc21713a7683819f49528f8912c58d9d9b51ca SHA512 6fa6828803143579564b89c6ba121dd3430d884e09eff2d2a0f9018056b2c88a0b7ecaa792ff5d1d12c86fabaf48d171af266ca9a0e9aee9cee80dc02af06210
DIST python-engineio-4.11.1.gh.tar.gz 319420 BLAKE2B 8c6f56da262f824f5880fe7a5b955bedd39973de922ad9cf274f2c16d2546b7aaa5d55cc4c35a4a8b5dfa6c0611447cf1ea2f3137883023e41cf4cf59962977d SHA512 e87f62229b0d45da015d4837bbe13a2310e895f27ec24daad21a1d4d077bc5ca73b20672fa20d1c0141ea6cbcd9e842ccd495bac79fc3f33e1e7bd068aeb232c
+DIST python-engineio-4.11.2.gh.tar.gz 319497 BLAKE2B d3f97f34c6e8043b0079c1555a8b4acb12f068883a1d117b19e0875d445239cc3c24e884f9b63c82268e9a8c67f3bbac193acc417cdd441e6f9d07cc79b97ccf SHA512 05f7fad64c3ddb136bb9fe4762bc5125d1e72813bd8f28d0c567c016ab3db9ff3b99719eafa106b997ce90da71be5aafb2bd34460d5097a9f68cf4dc7db34ba7
diff --git a/dev-python/python-engineio/python-engineio-4.11.2.ebuild b/dev-python/python-engineio/python-engineio-4.11.2.ebuild
new file mode 100644
index 000000000000..f32bad5443c1
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.11.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server"
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/simple-websocket-0.10.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # eventlet is masked for removal
+ tests/common/test_async_eventlet.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # also eventlet
+ tests/common/test_server.py::TestServer::test_async_mode_eventlet
+ tests/common/test_server.py::TestServer::test_connect
+ tests/common/test_server.py::TestServer::test_service_task_started
+ tests/common/test_server.py::TestServer::test_upgrades
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}