summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-15 03:52:38 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-15 04:01:31 -0400
commit55194e9841234d00a03c2b9d6717c2b8d615dc12 (patch)
treed0a34b1a919d48fb3858ae21c5916fc74b5ea909
parentmedia-tv/tvheadend: add bug links for filter-lto (diff)
downloadgentoo-55194e9841234d00a03c2b9d6717c2b8d615dc12.tar.gz
gentoo-55194e9841234d00a03c2b9d6717c2b8d615dc12.tar.bz2
gentoo-55194e9841234d00a03c2b9d6717c2b8d615dc12.zip
dev-python/psycopg: mark as strict-aliasing unsafe
Closes: https://bugs.gentoo.org/935401 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
-rw-r--r--dev-python/psycopg/psycopg-3.1.19.ebuild10
-rw-r--r--dev-python/psycopg/psycopg-3.2.0.ebuild10
-rw-r--r--dev-python/psycopg/psycopg-3.2.1.ebuild10
3 files changed, 27 insertions, 3 deletions
diff --git a/dev-python/psycopg/psycopg-3.1.19.ebuild b/dev-python/psycopg/psycopg-3.1.19.ebuild
index d1c0ba870de9..15b4a76bbc7e 100644
--- a/dev-python/psycopg/psycopg-3.1.19.ebuild
+++ b/dev-python/psycopg/psycopg-3.1.19.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="PostgreSQL database adapter for Python"
HOMEPAGE="
@@ -52,6 +52,14 @@ BDEPEND="
distutils_enable_tests pytest
python_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/935401
+ # https://github.com/psycopg/psycopg/issues/867
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# Python code + ctypes backend
cd psycopg || die
distutils-r1_python_compile
diff --git a/dev-python/psycopg/psycopg-3.2.0.ebuild b/dev-python/psycopg/psycopg-3.2.0.ebuild
index 1bcf3b3ac2e0..d62b5590fa54 100644
--- a/dev-python/psycopg/psycopg-3.2.0.ebuild
+++ b/dev-python/psycopg/psycopg-3.2.0.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="PostgreSQL database adapter for Python"
HOMEPAGE="
@@ -54,6 +54,14 @@ BDEPEND="
distutils_enable_tests pytest
python_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/935401
+ # https://github.com/psycopg/psycopg/issues/867
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# Python code + ctypes backend
cd psycopg || die
distutils-r1_python_compile
diff --git a/dev-python/psycopg/psycopg-3.2.1.ebuild b/dev-python/psycopg/psycopg-3.2.1.ebuild
index 1bcf3b3ac2e0..d62b5590fa54 100644
--- a/dev-python/psycopg/psycopg-3.2.1.ebuild
+++ b/dev-python/psycopg/psycopg-3.2.1.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="PostgreSQL database adapter for Python"
HOMEPAGE="
@@ -54,6 +54,14 @@ BDEPEND="
distutils_enable_tests pytest
python_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/935401
+ # https://github.com/psycopg/psycopg/issues/867
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# Python code + ctypes backend
cd psycopg || die
distutils-r1_python_compile