summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-10 20:08:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-10 20:11:03 +0200
commit5512f9d0ff264ad004ce5e2139afe206877d8d97 (patch)
tree9db99339953d7bb68bf98649e3c7d3cd62aa2469
parentdev-python/croniter: Bump to 2.0.0 (diff)
downloadgentoo-5512f9d0ff264ad004ce5e2139afe206877d8d97.tar.gz
gentoo-5512f9d0ff264ad004ce5e2139afe206877d8d97.tar.bz2
gentoo-5512f9d0ff264ad004ce5e2139afe206877d8d97.zip
dev-python/agate: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/agate/Manifest1
-rw-r--r--dev-python/agate/agate-1.8.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index c70c5c1098e1..d0d18f5951e0 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1 +1,2 @@
DIST agate-1.7.1.tar.gz 202018 BLAKE2B 9df0f108f1ac47c1eb199015aedc903d72ce62a7d2c34198f0f287863527a2305c5682ef7dd385d130fd0eb3ce566e98978b9ef438858510e3aeae02a6345318 SHA512 e40df26f1e738b4c386f540d642f4fdb240dac5229032c6074977a67c7fdae7838c770703d93916e10741a9f2569ac9672165f8c8715b2567b2e5b926c7dabd5
+DIST agate-1.8.0.tar.gz 201730 BLAKE2B c0138f912d6981059b8cd62424bdb428c9b6bff566bc47466bea9f0fd78f100333583dddaf081ea2f9810e8a1e586d4697960141ea4e97e8cef4a5084f09ce78 SHA512 9870f31f87efcb057947cf0c93062c2dbfa2aa996d1e6d69c552935eca3ab5c047ea0cbdf2eaca8e37d2a0530d210318fd342324f1ce43d7cba9f6291206f6fb
diff --git a/dev-python/agate/agate-1.8.0.ebuild b/dev-python/agate/agate-1.8.0.ebuild
new file mode 100644
index 000000000000..bf35fa27a14c
--- /dev/null
+++ b/dev-python/agate/agate-1.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)